Nginx反向代理出现错误 502 bad gateway 案例解析

场景描述

Nginx + uwsgi + flask

Flask框架写的程序,使用uwsgi启动,Nginx作为反向代理调用Flask应用。

Flask应用有些操作时间比较长,会超过1分钟,在网页端访问会出现错误: 502 bad gateway。

Nginx的错误日志中会出现错误:upstream prematurely closed connection while reading response header from upstream

错误分析

经过网上仔细搜索,产生这种错误的原因:Nginx在从Flask中获得相应数据时出现了错误,链接被关闭导致的,也就是Nginx从Flask获得数据时,没有获得正常的返回结果,链接被中断了。

解决方法

修改uwsgi的配置参数,增加下面代码

复制代码
http-timeout=300
socket-timeout=300

上面两个超时的默认值都是60秒,修改成300秒后,问题解决。真正的原因是:Nginx调用uwsgi时,uwsgi默认60秒超时,到了60秒后,uwsgi将链接断开了,Nginx就产生了错误502 bad gateway。

这两个超时的含义不一样,为了能起到作用,两个都加上了,大家可以从网上搜索两个参数的区别。

其他注意

产生类似错误很可能有其他超时参数,例如Nginx的参数

复制代码
  proxy_connect_timeout 300;
  proxy_read_timeout 300;
  proxy_send_timeout 300;

上面的参数默认值都是60,对于需要长时间的操作,都需要修改这些参数。

webouse 在此记录解决方法,方便以后查阅。

相关推荐
工作10年+,存储芯片行业1 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
快乐の番薯2 小时前
卷王问卷考试系统自动化功能测试
运维·功能测试·自动化
一号弯2 小时前
装完LINUX,请先新建日常用户
linux·运维·服务器
lpfasd1232 小时前
WinSW在Win7上失败真相-实测与修复
windows·nginx
许彰午3 小时前
03-Linux环境准备依赖包内核参数与用户组
linux·运维·服务器·数据库
阳光九叶草LXGZXJ3 小时前
达梦数据库-报错-16-MERGE INTO提示:无效的列名[XX]
linux·运维·数据库·sql·学习
一号弯4 小时前
Hyperv的LINUX虚拟机扩容
linux·运维·服务器
2601_962177304 小时前
2026年AI API Gateway怎么选?我整理了6种方案的费用、稳定性和适用场景
网络·人工智能·深度学习·gateway
一条大祥脚5 小时前
【CS336】lecture4 MoE|负载均衡|MoE并行|训练稳定性|Deepseek回顾
运维·负载均衡
lpfasd1235 小时前
nginx服务化五套方案原理解剖与选型
运维·nginx