Nginx反向代理出现错误 502 bad gateway 案例解析

场景描述

Nginx + uwsgi + flask

Flask框架写的程序,使用uwsgi启动,Nginx作为反向代理调用Flask应用。

Flask应用有些操作时间比较长,会超过1分钟,在网页端访问会出现错误: 502 bad gateway。

Nginx的错误日志中会出现错误:upstream prematurely closed connection while reading response header from upstream

错误分析

经过网上仔细搜索,产生这种错误的原因:Nginx在从Flask中获得相应数据时出现了错误,链接被关闭导致的,也就是Nginx从Flask获得数据时,没有获得正常的返回结果,链接被中断了。

解决方法

修改uwsgi的配置参数,增加下面代码

复制代码
http-timeout=300
socket-timeout=300

上面两个超时的默认值都是60秒,修改成300秒后,问题解决。真正的原因是:Nginx调用uwsgi时,uwsgi默认60秒超时,到了60秒后,uwsgi将链接断开了,Nginx就产生了错误502 bad gateway。

这两个超时的含义不一样,为了能起到作用,两个都加上了,大家可以从网上搜索两个参数的区别。

其他注意

产生类似错误很可能有其他超时参数,例如Nginx的参数

复制代码
  proxy_connect_timeout 300;
  proxy_read_timeout 300;
  proxy_send_timeout 300;

上面的参数默认值都是60,对于需要长时间的操作,都需要修改这些参数。

webouse 在此记录解决方法,方便以后查阅。

相关推荐
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
还是大剑师兰特1 天前
解决nginx错误:http://localhost:7000正常,http://localhost:7000/map 报错404
nginx·大剑师
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏1 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
xing-xing1 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅1 天前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren1 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼1 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘1 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境
懂软件的胡子个哥1 天前
微信机器人为什么需要“回复候选”而不是所有 AI 内容直接发送
运维·微信·自动化·wechatapi·个人微信号二次开发