windows docker mysql8.0 挂载配置文件不生效的问题

原因

mysql 8.0 遇到sql_mode=only_full_group_by的问题,于是就自定义my.cnf 去掉only_full_group_by,修改my.cnf 文件后,进行映射启动

docker run 命令

docker run -p 3306:3306 --privileged=true --restart=always -d --name axsc-mysql -v E:/docker/mysql8.0/log:/var/log/mysql -v E:/docker/mysql8.0/data:/var/lib/mysql -v E:/docker/mysql8.0/config/my.cnf:/etc/mysql/conf.d/my.cnf mysql:8.0

验证

发现执行group by 语句时还是报only_full_group_by的问题

查看日志有一个警告

mysqld: Warning World-writable config file '/etc/mysql/conf.d/my.cnf '

后来百度了一下,发现是文件的权限过大,mysql直接给忽略了

解决

windows 中 点击my.cnf 文件右键 设置为只读 ,再启动mysql 发现可以了

相关推荐
阳光九叶草LXGZXJ4 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
黄大刀5 小时前
DataPulse一款开箱即用的SCADA(四)-历史记录
运维·scada·动环
归秋1427 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮8 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
硅基手札9 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
工作10年+,存储芯片行业11 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
快乐の番薯11 小时前
卷王问卷考试系统自动化功能测试
运维·功能测试·自动化
一号弯12 小时前
装完LINUX,请先新建日常用户
linux·运维·服务器
许彰午13 小时前
03-Linux环境准备依赖包内核参数与用户组
linux·运维·服务器·数据库
阳光九叶草LXGZXJ13 小时前
达梦数据库-报错-16-MERGE INTO提示:无效的列名[XX]
linux·运维·数据库·sql·学习