解决MySQL数据库拒绝远程计算机连接问题

错误信息:Host is not allowed to connect to this mysql server

以前MySQL数据库部署在云服务器上,程序服务端也部署在云服务器上,连接服务器从没出现过问题。最近有一次需要做一个完全局域网的环境部署,我把数据库和程序服务端部署在里两台不同的电脑上,访问数据库的时候出现了上图所示的错误。

报错的原因是MySQL数据库默认情况下只允许localhost主机登录,不允许远程计算机通过IP地址的方式登录,可以通过下面的方法解决:

  • 在装有MySQL的计算机上通过cmd登录MySQL:mysql -u root -p (这时候需要输入数据库root账号的密码)
  • 执行use mysql;
  • 执行update user set host = '%' where user = 'root';
  • 执行FLUSH PRIVILEGES;

上面的操作中,通过把root账户的host设置为'%',%在这个地方是一个通配符,允许任意IP地址进行访问登录。执行上面四步之后,MySQL就可以通过root账号和密码进行远程访问了

相关推荐
L·S·P10 小时前
25MB 管理 100+ 种数据库:开源轻量客户端 DBX 介绍与上手
数据库·mysql·开源·database·dbx
笃行35012 小时前
KingbaseES KSQL Developer 的连接管理、数据处理与对象管理
数据库
ha_lydms12 小时前
MaxCompute中加密与解密函数
大数据·数据库·数据仓库·hadoop·dataworks·maxcompute·odps
Shadow(⊙o⊙)12 小时前
MySQL内置函数
数据库·mysql
笃行35013 小时前
金仓 KingbaseES PL/SQL 开发全攻略:异常处理、数据类型、调试优化与过程语句
数据库
夜雪一千13 小时前
MySQL 常用 DEFAULT 默认值一览表
mysql
快乐的木子李14 小时前
mysql-26.7.0-linux26.7.0下载安装
数据库·mysql
excel15 小时前
prisma 如何处理数据库竞态
前端·数据库·后端
知行产研15 小时前
易控智驾:毛利率跃升17.2个百分点,矿山无人驾驶从“规模换增长“迈入“盈利拐点“
数据库·mysql
千里码aicood15 小时前
基于CART算法的图书分类系统设计与实现
数据库·算法·分类