docker 容器内手动设置服务自启动

需求描述:不使用DockerFile实现容器内的服务自动启动

1、创建执行程序,以crond为例

bash 复制代码
//进入容器xxx
docker exec -it xxx /bin/sh
//切换root账户
bash
//创建自动执行文件
vim /root/cron.sh

2、自动执行文件内容

bash 复制代码
crond start

3、修改执行文件权限

bash 复制代码
chmod +x /root/cron.sh

4、把执行文件添加到开机自启动文件

bash 复制代码
//.bashrc为docker容器开启自启动文件
vim /root/.bashrc

把一下内容添加到.bashrc文件内容之下

bash 复制代码
if [ -f /root/cron.sh ]; then
      ./root/cron.sh
fi
相关推荐
Linux-lucky12 分钟前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南1 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123451 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人1 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender2 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35002 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南2 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1313 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生
当下新鲜事3 小时前
脱硫脱硝塔动力系统科普:四方DL500变频器工作原理解析
大数据·运维·物联网·业界资讯
Lsetea4 小时前
Nginx报No required SSL certificate was sent:mTLS客户端证书排查
运维·nginx·https·ssl·openssl