华为多路径软件UltraPath

检查多路径是否安装。

rpm -qa|grep UltraPath

查看UltraPath软件版本

upadmin show version

查看物理路径状态。

#upadmin show path

查看虚拟磁盘信息。

#upadmin show vlun

查看逻辑路径状态。

#upadmin show vlun

查看多路径配置。

#upadmin show upconfig

卸载UltraPath

root@db1 \~# rpm -e UltraPath

The running service is deleted successfully.

The boot service is removed successfully.

The UltraPath files are deleted successfully.

UltraPath driver package has been successfully removed from your system.

Restart the system.

root@db1 \~# upadmin show version

Software Version : 31.02.024

Driver Version : 31.02.024

root@db1 \~# upadmin show upconfig

=======================================================

UltraPath Configuration

=======================================================

Basic Configuration

Working Mode : load balancing within controller

LoadBalance Mode : min-queue-depth

Loadbanlance io threshold : 100

LUN Trespass : off

Advanced Configuration

Io Retry Times : 10

Io Retry Delay : 0

Faulty path check interval : 10

Idle path check interval : 60

Failback Delay Time : 60

Io Suspension Time : 60

Max io retry timeout : 1800

Performance Record : off

Pending delete period of obsolete paths : 28800

Path reliability configuration

Timeout degraded statistical time : 600

Timeout degraded threshold : 1

Timeout degraded path recovery time : 1800

Frequent timeout degraded statistical time : 86400

Frequent timeout degraded threshold : 3

Frequent timeout degraded path recovery time : 86400

Intermittent IO error degraded statistical time : 300

Min. I/Os for intermittent IO error degraded statistical : 5000

Intermittent IO error degraded threshold : 20

Intermittent IO error degraded path recovery time : 1800

Intermittent fault degraded statistical time : 1800

Intermittent fault degraded threshold : 3

Intermittent fault degraded path recovery time : 3600

High latency degraded statistical time : 300

High latency degraded threshold : 1000

High latency degraded path recovery time : 3600

Sensitive delayed degraded threshold : 0

Sensitive delayed degraded recovery time : 120

HyperMetro configuration

HyperMetro Primary Array SN : 2102350HYL10H6000020

HyperMetro WorkingMode : read write within primary array

HyperMetro Split Size : 128MB

HyperMetro Load Balance Mode : round-robin

root@db1 \~#

root@db1 \~# upadmin show path


Path ID Initiator Port Array Name Controller Target Port Path State Check State Port Type Port ID

0 10000090fa81c6ef Huawei.Storage-1F 0A 2080446a2ef573be Normal -- FC CTE0.A.H0

1 10000090fa81c6ef Huawei.Storage-1F 0B 2090446a2ef573be Normal -- FC CTE0.B.H0



Path ID Initiator Port Array Name Controller Target Port Path State Check State Port Type Port ID

2 10000090fa81c6ef Huawei.Storage-2F 0B 2091446a2ef573b5 Normal -- FC CTE0.B.H1

3 10000090fa81c6ef Huawei.Storage-2F 0A 2081446a2ef573b5 Normal -- FC CTE0.A.H1


root@db1 \~# upadmin check status


Checking path status:

Serverity Array Type Description

Critical 2102350HYL10H6000020 All path down All paths of LUN (wwn:6446a2e100f573b55c5a1ff100000010) are down.

Critical 2102350HYL10H6000020 All path down All paths of LUN (wwn:6446a2e100f573b55c5a462d00000011) are down.


Checking environment and config:

Pass


Checking HBA Information:

iscsi is not installed.

complete FC checking.

Pass

...................

root@db1 \~# rpm -e UltraPath-31.02.024-2.x86_64

The running service is deleted successfully.

The boot service is removed successfully.

The UltraPath files are deleted successfully.

UltraPath driver package has been successfully removed from your system.

Restart the system.

故障处理--重新安装

root@db1 CentOS# upadmin show version

Unable to detect UltraPath device node, exit

root@db1 \~# ./install.sh

complete iscsi checking.

complete FC checking.

Verify the UltraPath existence.

WARNING The UltraPath driver has been detected.

Do you want to uninstall it now?

<Y|N>:y

The UltraPath uninstallation starts.

The running service is deleted successfully.

The boot service is removed successfully.

The UltraPath files are deleted successfully.

UltraPath driver package has been successfully removed from your system.

Modify system configuration.file:/etc/iscsi/iscsid.conf,item:node.startup ,value: automatic

Modify system configuration.file:/etc/iscsi/iscsid.conf,item:node.session.timeo.replacement_timeout ,value: 1

Modify system configuration.file:/etc/modprobe.d/nxupmodules.conf,module:qla2xxx,item:qlport_down_retry,value:5

Modify system configuration.file:/etc/modprobe.d/nxupmodules.conf,module:lpfc,item:lpfc_nodev_tmo,value:5

Modify system configuration.file:/etc/systemd/system.conf,item:DefaultTimeoutStartSec,value:600s

If the operating system is installed on a local drive of the server, you are advised

to choose boot from local; if the operating system is installed on a SAN storage

system, you must choose boot from san. Please choose the boot type of your system:

<1>--boot-from-Local

<2>--boot-from-SAN

please input your select:1

Preparing... ########################################

Updating / installing...

UltraPath-31.02.024-2 ########################################

User configuration is saved successfully.

The boot service is installed successfully.

The running service is installed successfully.

************************************Attention************************************

* UltraPath would modify some parameters of HBA cards for better performace. If *

* UltraPath is installed for the first time, you may need to update the initrd *

* image before system reboot to make the modification take effect. *

*********************************************************************************

*********************************************************************************

* UltraPath will use the system hostname for alarm generation and automatic host*

* registration. Make sure that the system hostname is correctly configured.. *

*********************************************************************************

The installation is complete. Whether to restart the system now?

<Y|N>:y

问题1:alua not support告警

华为官网文档:Centos7.5系统自带多路径报错alua not support

Centos7.5系统自带多路径报错alua not support- 华为

相关推荐
Apipi*5 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP6 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
运维行者_7 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
hz567899 小时前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
广州浮点FLOATLIC9 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
优橙教育9 小时前
零基础学AI应用开发要多久?3个月能到什么水平
服务器·开发语言·网络·php
BLUcoding9 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK9 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2089 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)9 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障