windows redis 自启动 Redis服务无法启动报错1067问题

如果你的系统服务里面已经有redis服务并且无法启动,则使用下面的命令卸载此服务 !

1、停止Redis服务:

cpp 复制代码
redis-server --service-uninstall

2、删除系统服务

复制代码
sc delete redis

进入到你的Redis安装目录,我的在以下目录,谨记此时不要双击服务。

以管理员身份打开cmd,一步一步通过cd命令定位到此目录:

后,输入以下命令后回车。

cpp 复制代码
redis-server --service-install redis.windows.conf

再输入以下命令后回车:

cpp 复制代码
net start redis

此时,你的服务已经做为系统服务器正常运行。

相关推荐
字节渡客5 分钟前
Redis键明明过期了,业务还在读到旧数据
数据库·redis·spring
前端兰博2 小时前
05-Redis
redis·后端
OnlineProxy2 小时前
亚马逊多账号运营:如何在规避“关联封号”风险的同时实现电商规模化扩张
服务器·数据库·redis
辻弋2014 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
可乐鸡翅yeah_4 小时前
业务中 M3U8 水印相关坑,硬水印和动态水印区别
前端·网络·数据库·ffmpeg·m3u8在线
石头麻辣鱼5 小时前
Bamboo 调度系统 OceanBase 适配实战:存储过程迁移踩过的三个大坑
数据库
龙亘川5 小时前
数智驱动民政升级 精准守护民生保障
大数据·数据库·人工智能
念何架构之路5 小时前
zap扩展生态与总结
java·前端·数据库
晚安日记wanna6 小时前
MySQL 回表为什么这么慢?5 种优化手段逐个拆解
数据库·mysql·性能优化
第七页独白6 小时前
汽车零件厂如何通过 QMS 真正落地 IATF 16949——QMS软件系统:品质检验-内审稽核-8d客诉管理:全星质量管理软件系统
java·前端·数据库