windows redis 自启动 Redis服务无法启动报错1067问题

如果你的系统服务里面已经有redis服务并且无法启动,则使用下面的命令卸载此服务 !

1、停止Redis服务:

cpp 复制代码
redis-server --service-uninstall

2、删除系统服务

复制代码
sc delete redis

进入到你的Redis安装目录,我的在以下目录,谨记此时不要双击服务。

以管理员身份打开cmd,一步一步通过cd命令定位到此目录:

后,输入以下命令后回车。

cpp 复制代码
redis-server --service-install redis.windows.conf

再输入以下命令后回车:

cpp 复制代码
net start redis

此时,你的服务已经做为系统服务器正常运行。

相关推荐
这个DBA有点耶9 小时前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G9 小时前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备9 小时前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远9 小时前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
IT大白鼠10 小时前
Redis 系列 · 第 01 篇——认知入门:Redis 是什么
redis·nosql
彧azz10 小时前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
2601_9622186111 小时前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
全栈弄潮儿²⁰²⁴11 小时前
AI Agent 开发实战(30):限流、缓存与成本控制
人工智能·gpt·缓存·agent·限流·agi·成本控制
张洛闻Eren11 小时前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安12 小时前
MySQL-触发器
数据库·mysql