windows redis 自启动 Redis服务无法启动报错1067问题

如果你的系统服务里面已经有redis服务并且无法启动,则使用下面的命令卸载此服务 !

1、停止Redis服务:

cpp 复制代码
redis-server --service-uninstall

2、删除系统服务

复制代码
sc delete redis

进入到你的Redis安装目录,我的在以下目录,谨记此时不要双击服务。

以管理员身份打开cmd,一步一步通过cd命令定位到此目录:

后,输入以下命令后回车。

cpp 复制代码
redis-server --service-install redis.windows.conf

再输入以下命令后回车:

cpp 复制代码
net start redis

此时,你的服务已经做为系统服务器正常运行。

相关推荐
lusklusklusk12 分钟前
Oracle数据库基础之11_Duplicate和Dataguard和RAC
数据库·oracle
hweiyu0016 分钟前
Redis命令:HPERSIST
redis·缓存
hweiyu0022 分钟前
Redis命令:HPEXPIRE
redis·缓存
PHP实战开发录1 小时前
MySQL字段加索引为什么没变快
数据库·mysql·php·开发
红红谈说3 小时前
标签化推送与已读统计怎么做?一次通知链路的工程复盘
数据库·消息推送·数字乡村·集合运算·已读回执·标签体系·写入放大
Shadow(⊙o⊙)3 小时前
MySQL索引
数据库·mysql
starzy19904 小时前
Flink 优化之网络缓存优化及参数详解:从数据传输机制到反压原理的生产调优指南
网络·缓存·flink
ShineWinsu4 小时前
对于Redis:string类型的解析
java·c++·redis·分布式·缓存·面试·string
倔强的石头_5 小时前
多环境配置治理:开发、测试、生产连接信息如何隔离
数据库
杨云龙UP5 小时前
一次数据库查询缓慢故障复盘:大表数据增长、SQL全表扫描导致系统响应异常
linux·运维·服务器·数据库·sql·mysql