KylinOSv10系统k8s集群启动mysql5.7占用内存高的问题

问题现象

麒麟系统搭建k8s集群

mysql的pod启动失败

describe查看ommkill,放大limit资源限制到30G依旧启动失败

系统


报错信息

原因

内存占用太高

open_files_limit初始化太高

解决:

1、更换镜像

bash 复制代码
链接: https://pan.baidu.com/s/1b9uJLcc5Os0uDqD1eVUyxA 提取码: fit9

2、dockerfile自制镜像

修改官方镜像中的启动脚本

entrypoint.sh

相关推荐
guo_wen_qiang8 小时前
docker的备份与迁移
运维·docker·容器
hasty9 小时前
policy.xml 在,不代表策略生效:ImageMagick 补丁给安全配置验收的提醒
xml·mysql·安全
小小龙学IT11 小时前
Kubernetes 深度实践:架构、API 与避坑指南
容器·架构·kubernetes
晚风叙码14 小时前
MySQL 数据类型详解:从数值到字符串,一篇讲透
android·mysql·adb
做运维的阿瑞15 小时前
SQL 面试高频:用户、商品、订单三表查询全解析
数据库·sql·mysql
MrSYJ16 小时前
别人再问你路由表是啥,这篇文章摔它脸上
docker·云原生·kubernetes
CJi0NG16 小时前
【自用】MySQL - 语法:DDL、DML、DQL、DCL
数据库·mysql
羑悻17 小时前
穿越Docker内核迷雾:揭秘镜像分层存储的叠加态与卷挂载的多维空间穿梭技术
后端·docker·容器
一技安身17 小时前
【mysql】Windows MySQL 8.4.10 绿色免安装喂饭教程
windows·mysql·adb
斯内普吖17 小时前
(开源)宠物饲养系统实战指南 基于 Java + SSM + Vue + MySQL
java·vue.js·mysql·开源·宠物