error response from daemon: unknown or invalid runtime name: docker-runc

参考文章:docker 启动容器提示:Error response from daemon: unknown or invalid runtime name: docker-runc 七 第七公社

1、错误原因

  • 服务器docker版本升级/或者重装后,导致不兼容问题
  • 错误:Error response from daemon: unknown or invalid runtime name: docker-runc
    Error: failed to start containers: 495f12d4ced5

2、解决方式

  • 更改/var/lib/docker/containers目录中的文件参数,把docker-runc替换为runc
  1. 命令如下
复制代码
  grep -rl 'docker-runc' /var/lib/docker/containers/ | xargs sed -i 's/docker-runc/runc/g'
  1. 重启docker:
复制代码
  systemctl restart docker
相关推荐
贵沫末7 小时前
Ubuntu——常用软件安装
linux·运维·ubuntu
Doraemomo8 小时前
Linux内核驱动开发——中断与定时器
linux·运维·驱动开发
2301_808414388 小时前
Linux中动静态库的理解
linux·运维·服务器
誰能久伴不乏8 小时前
保姆级 Docker 入门教程
docker·容器·eureka
分布式存储与RustFS8 小时前
模型 checkpoint 放对象存储:分片上传、断点续传与残留清理
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
一条破秋裤10 小时前
Linux 线程创建:pthread_create 与基本回收
java·linux·运维
FED_AF12 小时前
Linux运维“邪修”功法之通配符
linux·运维
YOLO数据集集合12 小时前
风机叶片表面损伤检测数据集 | 风机叶片 表面损伤 污渍检测 无人机巡检 风电运维9119期
运维·人工智能·计算机视觉·目标跟踪·无人机·智慧城市·电力巡检
j7~12 小时前
【Linux网络编程】四十七.《Linux IO 模型详解:阻塞 IO、非阻塞 IO 与 IO 多路转接(select)》
linux·运维·网络·select·非阻塞io·阻塞io·i/o多路连接
分布式存储与RustFS13 小时前
用RustFS给Harbor当S3存储后端
运维·云原生·开源·对象存储·分布式存储·s3·性能基准