Centos7安装Elasticsearch记录(无坑版)

说明:

本文命令全部标红

elasticsearch使用版本是7.17.5

ik分词器也是7.17.5

虚拟机配置:2核8g

centos版本:7

1、获取elasticsearch的安装包

下载:wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-7.17.5-linux-x86_64.tar.gz

解压:tar -zvxf elasticsearch-7.17.5-linux-x86_64.tar.gz

2、修改节点名称和设置任意主机允许访问:

进入es安装目录(我安装在了 /usr/local/soft_hzz/elasticsearch/ 目录下了)

执行: vi elasticsearch.yml 添加如下:

shell 复制代码
node.name: node-1
discovery.seed_hosts: ["node-1"]
cluster.initial_master_nodes: ["node-1"]
#设置允许访问地址,配置位0.0.0.0允许任意主机访问
network.host: 0.0.0.0

3、修改最大线程数:

vi /etc/security/limits.conf 注意 前边的*代表所有用户都是这个配置 ,不能少,如果你只想某个用户是这个配置,那么将其改为对应的用户名即可

shell 复制代码
* soft nofile 65536
* hard nofile 65536
* soft nproc 4096
* hard nproc 4096

如图:

4、修改Linux句柄数

vi /etc/sysctl.conf

指定最大句柄数 vm.max_map_count=262144

4、虚拟内存配置

查询内存和虚拟内存:free -m

如果swap是0代表没开启虚拟内存,我这里需要使用虚拟内存(如果不使用我的会报错,因为我的机器配置不高) 使用swapon -a 开启虚拟内存

5、重启服务:

reboot

6、添加用户以及授权:(注意ES不能以 root 用户启动,否则会报错)

useradd elasticsearch

passwd elasticsearch

  • 给elasticsearch账号增加管理员权限:

vi /etc/sudoers

shell 复制代码
# 给elasticsearch添加 账号权限 :
elasticsearch ALL=(ALL) ALL
  • 给ES的安装目录进行授权:

chown -R elasticsearch:elasticsearch elasticsearch-7.17.5

7、调整elk的config目录下的jvm大小

(注意是在这个目录下:)

vi jvm.options 我这里调整成下边这样:

shell 复制代码
根据自己的内存自行调整,内存不够则会启动失败
-Xms4g
-Xmx4g

8、下载安装ik分词器到 : es安装目录/plugins目录下

注意: ik分词器要和elasticsearch的版本一致!

wget https://github.com/medcl/elasticsearch-analysis-ik/releases/download/v7.17.5/elasticsearch-analysis-ik-7.17.5.zip

如图我是搞到了es安装目录/pllugins/ik 目录下(ik是我自己建的文件夹):

解压下载好的zip文件: unzip elasticsearch-analysis-ik-7.17.5.zip

9、切换到es账号并启动es

su elasticsearch

shell 复制代码
# 前台启动
sh bin/elasticsearch

# 后台启动
sh bin/elasticsearch -d

我使用前台启动(好观察日志):sh bin/elasticsearch

查看日志: 查看进程号: 进程起来了说明启动成功。

10、访问elasticsearch服务

安装成功,开启快乐的elasticsearch之旅吧!!!

相关推荐
一只旭宝11 小时前
C++ 后端开发面试题整理
java·c++·面试
sunshine22 girl12 小时前
Java学习五 面向对象高级5 内部类3-静态内部类和局部内部类(了解)
java·学习
en.en..12 小时前
Linux 进程退出exit(函数)
java·开发语言·算法
李游Leo12 小时前
HarmonyOS 7 TaskPool + Node-API + zstd:Native 批量压缩任务的主线程隔离、进度回传与资源收口【鸿蒙心迹】
java·华为·harmonyos
Light Gao12 小时前
Encoder 与 Decoder 详解:从 Embedding 到 Seq2Seq 的完整数据流
java·开发语言·embedding
Harvil_12 小时前
任务跑一半,API 突然报“对话超长“断流:我给 Agent 修的紧急逃生通道
后端
用户EasyAdminBlazor12 小时前
EasyAdminBlazor SignalR 实时消息源码解析:从 NotificationHub 到站内消息
后端
程序猿乐锅12 小时前
【黑马点评 | 第十一篇】关注 Feed 流实现
java·数据库·redis·分布式·后端·缓存·maven
用户EasyAdminBlazor12 小时前
EasyAdminBlazor 定时任务:FreeScheduler 可视化调度与任务管理
后端
开开心心就好12 小时前
图片白底怎么去掉?抠图工具抠完背景透明
java·服务器·开发语言·pdf·ocr·散列表·启发式算法