利用exec命令进入docker容器时的报错问题

进入Docker 容器 docker exec CONTAINER ID bin/bash报错问题

一、详细报错信息

  • 执行docker exec -it containerId /bin/bash报错:
java 复制代码
OCI runtime exec failed: exec failed: unable to start 
container process: exec: "/bin/bash": 
stat /bin/bash: no such file or directory: unknown

**原因分析:**说明镜像不是bash风格的操作,提示未知的文件或者目录,这个错误说明你的镜像可能是基于busybox的风格,它没有bash shell,但是它在/bin/sh有一个shell

二、解决方案

可以将命令中的/bin/bash改成bin/sh 执行命令:docker exec -it containerId /bin/bash

如上图所示,已经进入容器内部

相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS4 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站4 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心4 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)4 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang4 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren4 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github