HDU 1716:排列2 ← next_permutation()

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1716

【题目描述】
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。

【输入格式】
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。

【输出格式】
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。

【输入样例】
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

【输出样例】
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

【算法代码】

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;

int main() {
    int a[4];
    while(1) {
        scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]);
        if(a[0]+a[1]+a[2]+a[3]==0) break;
        sort(a,a+4);
        int flag=0;
        int t;

        do {
            if(a[0]==0) continue;
            else if(flag==0) {
                printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
                flag=1;
            } else if(t==a[0]) {
                printf(" %d%d%d%d",a[0],a[1],a[2],a[3]);
            } else {
                printf("\n%d%d%d%d",a[0],a[1],a[2],a[3]);
            }
            t=a[0];
        } while(next_permutation(a,a+4));

        printf("\n\n");
    }
    return 0;
}


/*
in:
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

out:
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210
*/

【参考文献】
https://blog.csdn.net/qie_wei/article/details/81068186
https://blog.csdn.net/qq_31741481/article/details/84530287
https://cplusplus.com/reference/algorithm/next_permutation/

相关推荐
珹洺2 天前
C++从入门到实战(十五)String(上)介绍STL与String的关系,为什么有string类,String有什么用
开发语言·c++·stl
belldeep2 天前
python:trimesh 用于 STL 文件解析和 3D 操作
python·3d·stl
DARLING Zero two♡3 天前
C++效率掌握之STL库:map && set底层剖析及迭代器万字详解
c++·stl·set·map
咚咚轩5 天前
蓝桥杯14届 数三角
蓝桥杯·stl
珊瑚里的鱼6 天前
第八讲 | stack和queue的使用及其模拟实现
开发语言·c++·笔记·visualstudio·stl·学习方法·visual studio
yxc_inspire7 天前
C++STL在算法竞赛中的应用详解
c++·算法·stl
一匹电信狗9 天前
【C++】手搓一个STL风格的string容器
c语言·数据结构·c++·算法·leetcode·stl·visual studio
珊瑚里的鱼12 天前
LeetCode 102题解 | 二叉树的层序遍历
开发语言·c++·笔记·算法·leetcode·职场和发展·stl
珊瑚里的鱼15 天前
牛客网题解 | 栈的压入、弹出序列
开发语言·c++·笔记·算法·leetcode·stl
DARLING Zero two♡16 天前
C++漫溯键值的长河:map && set
c++·stl·set·map·搜索二叉树