HDU 1716:排列2 ← next_permutation()

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1716

【题目描述】
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。

【输入格式】
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。

【输出格式】
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。

【输入样例】
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

【输出样例】
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

【算法代码】

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;

int main() {
    int a[4];
    while(1) {
        scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]);
        if(a[0]+a[1]+a[2]+a[3]==0) break;
        sort(a,a+4);
        int flag=0;
        int t;

        do {
            if(a[0]==0) continue;
            else if(flag==0) {
                printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
                flag=1;
            } else if(t==a[0]) {
                printf(" %d%d%d%d",a[0],a[1],a[2],a[3]);
            } else {
                printf("\n%d%d%d%d",a[0],a[1],a[2],a[3]);
            }
            t=a[0];
        } while(next_permutation(a,a+4));

        printf("\n\n");
    }
    return 0;
}


/*
in:
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

out:
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210
*/

【参考文献】
https://blog.csdn.net/qie_wei/article/details/81068186
https://blog.csdn.net/qq_31741481/article/details/84530287
https://cplusplus.com/reference/algorithm/next_permutation/

相关推荐
Lenyiin16 小时前
《 C++ 修炼全景指南:十 》自平衡的艺术:深入了解 AVL 树的核心原理与实现
数据结构·c++·stl
C3 天前
C++_map_set详解
c++·stl
螺蛳粉只吃炸蛋的走风3 天前
面试题总结(四) -- STL与算法篇
开发语言·c++·算法·容器·stl·适配器
桃酥4034 天前
STL02——手写简单版本的list
c++·stl·list·项目
临沂堇7 天前
CCF刷题计划——垦田计划(手握map砍竹子)
c++·算法·stl·ccf
愿天垂怜8 天前
【C++】_list常用方法解析及模拟实现
c语言·数据结构·c++·算法·链表·stl·list
徐霞客3208 天前
C++——stack、queue的实现及deque的介绍
开发语言·c++·stl
Lenyiin9 天前
《 C++ 容器全景指南:四 》实现媲美 C++ 标准库的 stack 和 queue 容器 —— 模板、动态扩容、迭代器与线程安全详解
开发语言·c++·stl
徐霞客32010 天前
C++——list的实现
数据结构·c++·stl·list
看未来捏11 天前
【C++】STL容器详解【下】
c++·stl