HDU 1716:排列2 ← next_permutation()

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1716

【题目描述】
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。

【输入格式】
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。

【输出格式】
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。

【输入样例】
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

【输出样例】
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

【算法代码】

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;

int main() {
    int a[4];
    while(1) {
        scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]);
        if(a[0]+a[1]+a[2]+a[3]==0) break;
        sort(a,a+4);
        int flag=0;
        int t;

        do {
            if(a[0]==0) continue;
            else if(flag==0) {
                printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
                flag=1;
            } else if(t==a[0]) {
                printf(" %d%d%d%d",a[0],a[1],a[2],a[3]);
            } else {
                printf("\n%d%d%d%d",a[0],a[1],a[2],a[3]);
            }
            t=a[0];
        } while(next_permutation(a,a+4));

        printf("\n\n");
    }
    return 0;
}


/*
in:
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

out:
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210
*/

【参考文献】
https://blog.csdn.net/qie_wei/article/details/81068186
https://blog.csdn.net/qq_31741481/article/details/84530287
https://cplusplus.com/reference/algorithm/next_permutation/

相关推荐
被二进制支配的打工人3 天前
【STL】list 双向循环链表的使用介绍
数据结构·c++·链表·stl·list
轩情吖3 天前
C++模拟实现queue
开发语言·c++·后端·容器·stl·队列·queue
羊小猪~~14 天前
C/C++语言基础--C++STL库算法记录(质变算法、非质变算法、查找、排序、排列组合、关系算法、集合算法、堆算法等)
c语言·开发语言·数据结构·c++·算法·stl
青青丘比特16 天前
List ---- 模拟实现LIST功能的发现
开发语言·数据结构·c++·stl·list
float_六七19 天前
头文件math/cmath
c++·算法·stl
AL流云。21 天前
【CPP_STL篇】总结可遍历STL所有容器的迭代器(反向迭代器的模拟+实现)
windows·迭代器·stl
charlie1145141911 个月前
C++ STL CookBook
开发语言·c++·stl·c++20
羊小猪~~1 个月前
C/C++语言基础--C++STL库之仿函数、函数对象、bind、function简介
java·c语言·开发语言·数据结构·c++·visualstudio·stl
专科在努力!1 个月前
STL中的deque(双端队列),存储结构与使用
开发语言·c++·stl
charlie1145141911 个月前
C++ STL Cookbook STL算法
c++·算法·stl·c++20