HDU 1716:排列2 ← next_permutation()

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1716

【题目描述】
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。

【输入格式】
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。

【输出格式】
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。

【输入样例】
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

【输出样例】
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

【算法代码】

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;

int main() {
    int a[4];
    while(1) {
        scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]);
        if(a[0]+a[1]+a[2]+a[3]==0) break;
        sort(a,a+4);
        int flag=0;
        int t;

        do {
            if(a[0]==0) continue;
            else if(flag==0) {
                printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
                flag=1;
            } else if(t==a[0]) {
                printf(" %d%d%d%d",a[0],a[1],a[2],a[3]);
            } else {
                printf("\n%d%d%d%d",a[0],a[1],a[2],a[3]);
            }
            t=a[0];
        } while(next_permutation(a,a+4));

        printf("\n\n");
    }
    return 0;
}


/*
in:
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

out:
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210
*/

【参考文献】
https://blog.csdn.net/qie_wei/article/details/81068186
https://blog.csdn.net/qq_31741481/article/details/84530287
https://cplusplus.com/reference/algorithm/next_permutation/

相关推荐
Trouvaille ~1 天前
【C++篇】跨越有限与无限的边界:STL之set容器中的自我秩序与无限可能
开发语言·数据结构·c++·容器·stl·set·红黑树
fhvyxyci2 天前
【C++之STL】一文学会使用 string
开发语言·数据结构·c++·stl
Trouvaille ~3 天前
【C++篇】在秩序与混沌的交响乐中: STL之map容器的哲学探寻
开发语言·数据结构·c++·算法·迭代器模式·stl·map
sc写算法3 天前
STL 迭代器iteratior 详解
开发语言·c++·stl
Y.O.U..4 天前
STL学习-关联容器-pair数对
开发语言·c++·学习·stl·1024程序员节
Y.O.U..9 天前
STL学习-容器适配器
开发语言·c++·学习·stl·1024程序员节
XiaoCCCcCCccCcccC12 天前
C++中红黑树的实现
开发语言·数据结构·c++·算法·stl
Y.O.U..13 天前
STL学习-顺序容器-deque双端队列
c++·学习·stl·1024程序员节
Trouvaille ~13 天前
【C++篇】栈的层叠与队列的流动:在 STL 的韵律中探寻数据结构的优雅之舞
数据结构·c++·容器·stl·适配器模式·双端队列·栈和队列
ephemerals__14 天前
【c++丨STL】string模拟实现(附源码)
开发语言·c++·算法·stl·1024程序员节