Nginx 使用笔记大全(唯一入口)

Linux服务器因为Nginx日志access.log文件过大项目无法访问

项目处于运行状态下无法访问,第一步查看磁盘状态

1、查看磁盘状态

df -h

2、查找100M以上的文件

find / -size +100M |xargs ls -lh

3、删除文件

rm -rf /usr/local/nginx/logs/access.log

4、配置nginx.conf文件,关闭access_log

error_log /dev/null;

access_log off;

windows系统nginx停止启动及常用命令

https://www.dgrt.cn/a/1911260.html?action=onClick

1 windows启动nginx

可以直接双击nginx.exe启动或者将下边的脚本保存为bat文件双击运行.

bash 复制代码
d:\dashidan.com\nginx-1.0.2>start nginx

d:\dashidan.com\nginx-1.0.2>nginx.exe

建议使用第一种,第二种会使你的cmd窗口一直处于执行中,不能进行其他命令操作.

注:d:\dashidan.com换成自己的nginx安装路径

2 windows停止nginx

可以直接在资源管理器中找到nginx.exe进程点右键,选择结束进程, 或者将下边的脚本保存为nginx_stop.bat文件双击运行.需要将nginx.exe的路径改为nginx的安装目录.

d:\dashidan.com\nginx-1.0.2>nginx.exe -s stop

d:\dashidan.com\nginx-1.0.2>nginx.exe -s quit

stop是快速停止nginx,可能并不保存相关信息.

quit是完整有序的停止nginx,并保存相关信息.

3 重新载入Nginx配置

nginx配置有修改,但你不想重启nginx的时候,可以使用reload命令重新加载配置文件.

d:\dashidan.com\nginx-1.0.2>nginx.exe -s reload

4 重新打开日志文件

通过nginx.exe -s reopen命令可以重新打开日志文件.

d:\dashidan.com\nginx-1.0.2>nginx.exe -s reopen

5 查看Nginx版本

nginx -v查看Nginx版本号.

d:\dashidan.com\nginx-1.0.2>nginx -v

相关推荐
蓝速科技16 分钟前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese1 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky1 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南2 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123452 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人2 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender3 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35003 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
马可家的菠萝3 小时前
你收藏的资料,有多少真的被你第二次打开过?
笔记·知识管理·效率提升·个人知识库
智能运维指南3 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台