大数据-之LibrA数据库系统告警处理(ALM-37014 Gaussdb进程锁文件已经存在)

告警解释

当集群中的CN实例或者DN实例锁文件创建失败时,产生该告警。

告警属性
告警ID 告警级别 可自动清除
37014 严重 是
告警参数
参数名称 参数含义
ServiceName 产生告警的服务名称
RoleName 产生告警的角色名称
HostName 产生告警的主机名
Instance 产生告警的实例
对系统的影响

发生数据库锁文件创建失败时,锁文件创建失败的实例可能无法启动,集群将无法正常启动。

可能原因

系统数据实例异常终止,导致系统中存在锁文件残留。

处理步骤
  1. 使用omm用户登录告警上报的节点。
  2. 初始化环境变量。 source ${BIGDATA_HOME}/mppdb/.mppdbgs_profile
  1. 执行如下命令获取出现告警的主机和数据实例的数据目录。(如下主机为10.252.153.218,数据目录为/srv/BigData/mppdb/data1/coordinator)

    复制代码
  2. 使用SSH方式登录上述主机,执行如下命令进入目录并检查是否存在postmaster.pid文件。

    复制代码
    • 是,执行5。
    • 否,执行8。
  3. 执行如下命令获取postmaster.pid文件中第一行的pid。

    复制代码
  4. 执行如下命令查看上述pid对应的进程是否存在。

    复制代码
    ps -ef |grep 42883
    复制代码
    omm       42883      1  4 Nov05 ?        17:25:59 /opt/huawei/Bigdata/mppdb/core/bin/gaussdb --coordinator -D /srv/BigData/mppdb/data1/coordinator
    omm      125791  55322  0 15:10 pts/0    00:00:00 grep --color=auto 42883
    • 是,执行7。
    • 否,执行8。
  5. 执行如下命令终止上述进程,并删除postmaster.pid文件后查看告警是否恢复。

    复制代码
    • 是,处理完毕。
    • 否,执行8。
  6. 在FusionInsight Manager界面,单击"系统设置 > 日志下载"。

  7. 在"服务"下拉框中勾选"MPPDB",单击"确定"。

  8. 设置日志收集的"开始时间"和"结束时间"分别为告警产生时间的前后1小时,单击"下载"。

相关推荐
PaperData2 小时前
1985-2025年全国区县专利申请与授权面板数据
数据库
snpgroupcn2 小时前
大数据量SAP迁移方案:系统越大,越不能硬搬
数据库·sap
微三云马玮均—GEO源码系统 私有化部署2 小时前
消费返物业费:消费+服务趋势的必然产物!
大数据·人工智能·物联网·区块链·生活
Flynt3 小时前
Redis Cluster主节点挂了,为什么"高可用"还全员掉线?我把三次kill的记录翻出来了
数据库·redis·分布式
笃行3503 小时前
KingbaseES 数据加密全解:从 SSL 到全密态
数据库
Ivanqhz4 小时前
激活函数在 Transformer 中的作用及各种变体简述
java·linux·数据库·人工智能·深度学习
workflower4 小时前
AI system product quality model
大数据·人工智能·机器学习·云计算·无人机
yl45304 小时前
硫酸泄露处理生产商怎么选才够专业
大数据·人工智能·python
java1234_小锋5 小时前
【技术专题】Mysql8 数据库 - Mysql8 数据类型简介
数据库·mysql
xianghongtao01165 小时前
麦肯锡2026技术趋势02_智能体AI_研究解读
大数据·人工智能