连接Redis报错&解决方案

连接Redis报错&解决方案

  1. 问题描述:Could not connect to Redis at 127.0.0.1:6379: 由于目标计算机积极拒绝,无法连接。

  2. 问题原因:redis启动方式不正确

  3. 解决方案:

    • 在redis根目录下打开命令行窗口,输入命令redis-server.exe redis.windows.conf后,不要关闭本窗口。

    • 重新打开cmd窗口,输入redis-cli执行。

  4. 启动redis的三种方式

    1. 默认6379端口启动:redis-server
    2. 指定端口启动:redis-server --port 8888
    3. 配置文件启动:
      • redis中的配置文件是 redis.conf
      • 启动配置文件的命令:./src/redis-server redis-01.conf
  5. 让redis服务保持开启的命令:redis-server --service-install redis.windows-service.conf --loglevel verbose

相关推荐
这个DBA有点耶5 天前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G5 天前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备5 天前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远5 天前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
IT大白鼠5 天前
Redis 系列 · 第 01 篇——认知入门:Redis 是什么
redis·nosql
彧azz5 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
2601_962218615 天前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
全栈弄潮儿²⁰²⁴5 天前
AI Agent 开发实战(30):限流、缓存与成本控制
人工智能·gpt·缓存·agent·限流·agi·成本控制
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
于平安5 天前
MySQL-触发器
数据库·mysql