K8s中安装calico一直无法启动成功

问题描述

powershell 复制代码
#k8s版本为v1.20.9

查看对应日志

sh 复制代码
#calico-node-xxx 对应pod名称
kubectl logs calico-node-xxxx -n kube-system 
#没有错误但是一直启动不起来
  • 应该是版本不匹配问题
  • 解决方案
    • 删除 calico重新安装对应版本
    • 删除podskubectl delete -f calico.yaml
    • 删除文件 rm -f calico.yaml
    • 重新下载对应版本curl https://docs.projectcalico.org/v3.20/manifests/calico.yaml -O
    • 修改 calico.yaml 文件中的 CALICO_IPV4POOL_CIDR 配置,修改为与初始化(master中kubelet init的pod-network-cidr)的 cidr 相同
    • 删除镜像 docker.io/ 前缀,避免下载过慢导致失败 sed -i 's#docker.io/##g' calico.yaml (这一步可以忽略)
    • #构建calico应用kubectl apply -f calico.yaml 重新构建后发现正常
  • 可以到官网查看匹配版本
相关推荐
未济5 天前
linux 配置环境变量
linux
傲世仙尊5 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
_艾伦 耶格尔.5 天前
进程间通信
linux
Liuqy-055 天前
Linux IO编程——静态库、动态库
linux
彧azz5 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅5 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)5 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
AIgorithmGEEK5 天前
[Linux]线程三部曲(上):一个执行流的诞生——从操作系统一路拆到 pthread_create
linux·线程·pid