目录
- 实验条件
- 配置实现
-
- 基础配置
-
- [1. 配置所有设备的IP地址](#1. 配置所有设备的IP地址)
- 实现目标
-
- [1. 要求按照下列标准配置一个OSPF网络。 路由协议采用OSPF,进程ID为89 ,RID为loopback0地址。](#1. 要求按照下列标准配置一个OSPF网络。 路由协议采用OSPF,进程ID为89 ,RID为loopback0地址。)
- [3. R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性DR。](#3. R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性DR。)
- [4. 按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。](#4. 按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。)
- [5. R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA 23,配置使得所有网络可达(采用ping测试)。](#5. R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA 23,配置使得所有网络可达(采用ping测试)。)
- [6. OSPF内部的网络希望通过R5路由器访问Internet(假设R5和Internet连接),配置R5使其能够满足需求,只考虑内部OSPF的实现。](#6. OSPF内部的网络希望通过R5路由器访问Internet(假设R5和Internet连接),配置R5使其能够满足需求,只考虑内部OSPF的实现。)
- [7. AREA 0基于安全的原因配置上MD5认证,密码:SPOTO](#7. AREA 0基于安全的原因配置上MD5认证,密码:SPOTO)
- [8. AREA 146中,配置R1为指定路由器(DR),R4/R6之间保持two-way的邻居关系。](#8. AREA 146中,配置R1为指定路由器(DR),R4/R6之间保持two-way的邻居关系。)
- [9. 为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。](#9. 为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。)
- [10. 由于R6与R5之间的链路质量较好,适当配置使得R1优先选取R6访问自身区域除外的外部网络。](#10. 由于R6与R5之间的链路质量较好,适当配置使得R1优先选取R6访问自身区域除外的外部网络。)
实验条件
网络拓朴
需求
- 要求按照下列标准配置一个OSPF网络。
- 路由协议采用OSPF,进程ID为89 ,RID为loopback0地址。
- R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性DR。
- 按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。
- R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA 23,配置使得所有网络可达(采用ping测试)。
- OSPF内部的网络希望通过R5路由器访问Internet(假设R5和Internet连接),配置R5使其能够满足需求,只考虑内部OSPF的实现。
- AREA 0基于安全的原因配置上MD5认证,密码:SPOTO
- AREA 146中,配置R1为指定路由器(DR),R4/R6之间保持two-way的邻居关系。
- 为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。
- 由于R6与R5之间的链路质量较好,适当配置使得R1优先选取R6访问自身区域除外的外部网络。
- 在AREA 0以外的所有区域启用OSPF明文认证,密码:SPOTO
配置实现
基础配置
拓扑中的IP地址段采用:172.8.AB.X/24:
其中AB为两台路由器编号组合,
例如:R2-R3之间的AB为23,X为路由器编号,例如R3的X=3
R1/R4/R6之间的网段为:172.8.146.X/24,其中X为路由器编号。
R4/R5/R6之间的网段为:172.8.100.X/24,其中X为路由器编号。
所有路由器都有一个loopback 0接口,地址格式为:X.X.X.X/32,其中X为路由器编号。
1. 配置所有设备的IP地址
R2
java
R2(config)#int e0/0
R2(config-if)#ip address 172.8.23.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int lo 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no sh
R3
java
R3(config)#int e0/0
R3(config-if)#ip address 172.8.23.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int e0/1
R3(config-if)#ip address 172.8.35.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int lo0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no sh
R5
java
R5(config)#int e0/1
R5(config-if)#ip address 172.8.35.5 255.255.255.0
R5(config-if)#no sh
R5(config-if)#int e0/0
R5(config-if)#ip address 172.8.100.5 255.255.255.0
R5(config-if)#no sh
R5(config-if)#int lo 0
R5(config-if)#ip address 5.5.5.5 255.255.255.255
R5(config-if)#no sh
R5(config-if)#
R4
java
R4(config)#int e0/1
R4(config-if)#ip address 172.8.100.4 255.255.255.0
R4(config-if)#no sh
R4(config-if)#int e0/2
R4(config-if)#ip address 172.8.146.4 255.255.255.0
R4(config-if)#no sh
R4(config-if)#int lo 0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#no sh
R4(config-if)#
R6
java
R6(config)#int e0/1
R6(config-if)#ip address 172.8.100.6 255.255.255.0
R6(config-if)#no sh
R6(config-if)#int e0/0
R6(config-if)#ip address 172.8.146.6 255.255.255.0
R6(config-if)#no sh
R6(config-if)#int lo 0
R6(config-if)#ip address 6.6.6.6 255.255.255.255
R6(config-if)#no sh
R1
java
R1(config)#int e0/0
R1(config-if)#ip address 172.8.146.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int lo0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no sh
Internet ISP
java
ISP(config)#username SPOTO password SPOTO123
ISP(config)#ip local pool cciepools 211.98.5.100 211.98.5.253
ISP(config)#interface virtual-template 1
ISP(config-if)#ip address 211.98.5.254 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#encapsulation ppp
ISP(config-if)#ip mtu 1492
ISP(config-if)#ppp authentication pap
ISP(config-if)#peer default ip address pool cciepools
ISP(config-if)#exit
ISP(config)#bba-group pppoe bgISP
ISP(config-bba-group)#virtual-template 1
ISP(config-bba-group)#exit
ISP(config)#int e0/0
ISP(config-if)#pppoe enable group bgISP
ISP(config-if)#no shutdown
ISP(config-if)#exit
ISP(config)#do show ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES NVRAM up up
Ethernet0/1 unassigned YES NVRAM administratively down down
Ethernet0/2 unassigned YES NVRAM administratively down down
Ethernet0/3 unassigned YES NVRAM administratively down down
Virtual-Access1 unassigned YES unset down down
Virtual-Access2 unassigned YES unset up up
Virtual-Template1 211.98.5.254 YES manual down down
ISP(config)#
实现目标
1. 要求按照下列标准配置一个OSPF网络。 路由协议采用OSPF,进程ID为89 ,RID为loopback0地址。
R2
java
R2(config-router)#do show run | s route
router ospf 89
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 23
R2(config-router)#
R3
java
R3(config-router)#do show run | s route
router ospf 89
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 23
network 172.8.23.0 0.0.0.255 area 23
network 172.8.35.0 0.0.0.255 area 35
R3(config-router)#
R5
java
R5(config-router)#do show run | s route
router ospf 89
router-id 5.5.5.5
network 5.5.5.5 0.0.0.0 area 0
network 172.8.35.0 0.0.0.255 area 35
network 172.8.100.0 0.0.0.255 area 0
R5(config-router)#
R6
java
R6(config-router)#do show run | s route
router ospf 89
router-id 6.6.6.6
network 6.6.6.6 0.0.0.0 area 0
network 172.8.100.0 0.0.0.255 area 0
network 172.8.146.0 0.0.0.255 area 146
R6(config-router)#
R4
java
R4(config-router)#do show run | s route
router ospf 89
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
network 172.8.100.0 0.0.0.255 area 0
network 172.8.146.0 0.0.0.255 area 146
R4(config-router)#
R1
java
R1(config-router)#do show run | s route
router ospf 89
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 146
R1(config-router)#
邻居关系表
R3
java
R3(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/DR 00:00:35 172.8.23.2 Ethernet0/0
5.5.5.5 1 FULL/BDR 00:00:34 172.8.35.5 Ethernet0/1
R3(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 89 23 3.3.3.3/32 1 LOOP 0/0
Et0/0 89 23 172.8.23.3/24 10 BDR 1/1
Et0/1 89 35 172.8.35.3/24 10 DR 1/1
R3(config-router)#
R5
java
R5(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/DROTHER 00:00:37 172.8.100.4 Ethernet0/0
6.6.6.6 1 FULL/BDR 00:00:32 172.8.100.6 Ethernet0/0
3.3.3.3 1 FULL/DR 00:00:32 172.8.35.3 Ethernet0/1
R5(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 89 0 5.5.5.5/32 1 LOOP 0/0
Et0/0 89 0 172.8.100.5/24 10 DR 2/2
Et0/1 89 35 172.8.35.5/24 10 BDR 1/1
R5(config-router)#
R4
java
R4(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 1 FULL/DR 00:00:30 172.8.100.5 Ethernet0/1
6.6.6.6 1 FULL/BDR 00:00:38 172.8.100.6 Ethernet0/1
1.1.1.1 1 FULL/DROTHER 00:00:37 172.8.146.1 Ethernet0/2
6.6.6.6 1 FULL/DR 00:00:31 172.8.146.6 Ethernet0/2
R4(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 89 0 4.4.4.4/32 1 LOOP 0/0
Et0/1 89 0 172.8.100.4/24 10 DROTH 2/2
Et0/2 89 146 172.8.146.4/24 10 BDR 2/2
R4(config-router)#
R6
java
R6(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/DROTHER 00:00:33 172.8.100.4 Ethernet0/1
5.5.5.5 1 FULL/DR 00:00:32 172.8.100.5 Ethernet0/1
1.1.1.1 1 FULL/DROTHER 00:00:37 172.8.146.1 Ethernet0/0
4.4.4.4 1 FULL/BDR 00:00:31 172.8.146.4 Ethernet0/0
R6(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 89 0 6.6.6.6/32 1 LOOP 0/0
Et0/1 89 0 172.8.100.6/24 10 BDR 2/2
Et0/0 89 146 172.8.146.6/24 10 DR 2/2
R6(config-router)#
3. R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性DR。
R
java
R5(config-router)#int e0/0
R5(config-if)#ip ospf priority 255
R5(config-if)#
4. 按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。
R4 & R5
java
R(config-router)#router ospf 89
R(config-router)#area 146 stub no-summary
R(config-router)#
R6
java
R(config-router)#router ospf 89
R(config-router)#area 146 stub
R(config-router)#
5. R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA 23,配置使得所有网络可达(采用ping测试)。
R3
java
R3(config-router)#area 35 virtual-link 5.5.5.5
R5
java
R5(config-router)#area 35 virtual-link 3.3.3.3
验证结果
R5
java
R5(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
VL0 89 0 172.8.35.5/24 10 P2P 1/1
Lo0 89 0 5.5.5.5/32 1 LOOP 0/0
Et0/0 89 0 172.8.100.5/24 10 DR 2/2
Et0/1 89 35 172.8.35.5/24 10 BDR 1/1
R5(config-router)#
R1
java
R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#
6. OSPF内部的网络希望通过R5路由器访问Internet(假设R5和Internet连接),配置R5使其能够满足需求,只考虑内部OSPF的实现。
R5拨号上网
java
R5(config)#interface dialer 1
R5(config-if)#encapsulation ppp
R5(config-if)#ip mtu 1492
R5(config-if)#ppp pap sent-username SPOTO password SPOTO123
R5(config-if)#ppp chap hostname SPOTO
R5(config-if)#ppp chap password SPOTO123
R5(config-if)#ip address negotiated
R5(config-if)#ppp ipcp route default
R5(config-if)#dialer pool 1
R5(config-if)#exit
R5(config)#int e0/0
R5(config-if)#pppoe enable group global
R5(config-if)#pppoe-client dial-pool-number 1
R5(config-if)#no shutdown
R5(config-if)#do show ip int br
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 172.8.100.5 YES manual up up
Ethernet0/1 172.8.35.5 YES manual up up
Ethernet0/2 unassigned YES TFTP up up
Ethernet0/3 unassigned YES TFTP administratively down down
Dialer1 211.98.5.100 YES IPCP up up
Loopback0 5.5.5.5 YES manual up up
Virtual-Access1 unassigned YES unset up up
Virtual-Access2 unassigned YES unset up up
R5(config-if)#do ping 211.98.5.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 211.98.5.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R5(config-if)#interface range e0/0-1
R5(config-if-range)#ip nat inside
R5(config-if-range)#interface dialer 1
R5(config-if)#ip nat outside
R5(config-if)#access-list 1 permit any
R5(config)#ip nat inside source list 1 interface dialer 1 overload
R5(config)#router ospf 89
R5(config-router)#default-information originate
java
// 添加以下语句,给所有的路由器下发一条默认路由
R5(config-router)#default-information originate
验证交易
R1
R4&R6
R5
默认上网
7. AREA 0基于安全的原因配置上MD5认证,密码:SPOTO
R4&R5&R6
全启开启全局摘要认证
R(config-router)#area 0 authentication message-digest
在3接口,1个虚拟链路上配置MD5密码
R(config-if)#ip ospf message-digest-key 1 md5 SPOTO
三个接口这样配置
R5(config-router)#area 35 virtual-link 3.3.3.3 message-digest-key 1 md5 SPOTO
虚拟链路这样配置
全局开启了,接口上就不用再开启一次
执行后
java
R5(config-router)#do show ip ospf int br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 89 0 5.5.5.5/32 1 LOOP 0/0
Et0/0 89 0 172.8.100.5/24 10 BDR 1/1
VL0 89 0 172.8.35.5/24 10 P2P 1/1
Et0/1 89 35 172.8.35.5/24 10 BDR 1/1
R5(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
6.6.6.6 1 FULL/DR 00:00:30 172.8.100.6 Ethernet0/0
3.3.3.3 0 FULL/ - - 172.8.35.3 OSPF_VL0
3.3.3.3 1 FULL/DR 00:00:31 172.8.35.3 Ethernet0/1
R5(config-router)#
邻居连接状态正常
8. AREA 146中,配置R1为指定路由器(DR),R4/R6之间保持two-way的邻居关系。
java
// 配置成0,退出竞争
R4(config-if)#int e0/2
R4(config-if)#ip ospf priority 0
// 配置成0,退出竞争
R6(config-if)#int e0/0
R6(config-if)#ip ospf priority 0
R4#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 255 FULL/BDR 00:00:33 172.8.100.5 Ethernet0/1
1.1.1.1 255 FULL/DR 00:00:35 172.8.146.1 Ethernet0/2
6.6.6.6 0 2WAY/DROTHER 00:00:33 172.8.146.6 Ethernet0/2
R6(config-router)#do show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
5.5.5.5 255 FULL/BDR 00:00:33 172.8.100.5 Ethernet0/1
1.1.1.1 255 FULL/DR 00:00:38 172.8.146.1 Ethernet0/0
4.4.4.4 0 2WAY/DROTHER 00:00:36 172.8.146.4 Ethernet0/0
R4和R6处在了2Way的状态,R1成了DR
9. 为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。
这个最好是在ABR上操作,因选择R4或是R6
java
R4(config-router)#area 146 range 172.8.0.0 255.255.0.0
R4(config-router)#area 146 range 1.0.0.0 255.0.0.0
R4(config-router)#
java
R5(config-router)#do show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is 211.98.5.254 to network 0.0.0.0
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/21] via 172.8.100.4, 00:00:19, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/11] via 172.8.100.4, 00:09:52, Ethernet0/0
172.8.0.0/16 is variably subnetted, 5 subnets, 2 masks
O IA 172.8.146.0/24 [110/20] via 172.8.100.4, 00:00:17, Ethernet0/0
// ABR R4 路由汇总之后,R5收到的通告
R5(config-router)#do show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is 211.98.5.254 to network 0.0.0.0
O IA 1.0.0.0/8 [110/21] via 172.8.100.4, 00:00:05, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/11] via 172.8.100.4, 00:10:09, Ethernet0/0
172.8.0.0/16 is variably subnetted, 5 subnets, 3 masks
O IA 172.8.0.0/16 [110/20] via 172.8.100.4, 00:00:08, Ethernet0/0
R5(config-router)#
10. 由于R6与R5之间的链路质量较好,适当配置使得R1优先选取R6访问自身区域除外的外部网络。
加大去往R4的开销值。从而让R1选R6走
java
R1(config-router)#do show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is 172.8.146.6 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/11] via 172.8.146.6, 00:01:33, Ethernet0/0
[110/11] via 172.8.146.4, 00:27:31, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
172.8.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.8.146.0/24 is directly connected, Ethernet0/0
L 172.8.146.1/32 is directly connected, Ethernet0/0
R1(config-router)#
// 默认两个负载均衡。
该方法只能用在NSSA/Stub类型的区域,该类型的区域默认的cost开销是1,不影响区域外的路由Metric值
java
// 现在调整开销。改变路径
R4(config-if)#router ospf 89
R4(config-router)#area 146 default-cost 1500
// 为了看出效果,特意设置比较大的Metric值。
R6(config-if)#router ospf 89
R6(config-router)#area 146 default-cost 800
实现结果
java
R1(config-router)#do show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is 172.8.146.6 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/810] via 172.8.146.6, 00:07:16, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
172.8.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.8.146.0/24 is directly connected, Ethernet0/0
L 172.8.146.1/32 is directly connected, Ethernet0/0
R1(config-router)#
R6的默认cost 800 加上 R1 入接口的 cost 10(e接口的cost为10:计算方式为10的8次方除以e口的带宽)=810
出口路径只剩下一条了从R6的810的metric的路由走了 。
- 在AREA 0以外的所有区域启用OSPF明文认证,密码:SPOTO