k8s报错处理

解决failed to verify certificate: x509报错问题

root@master1 home# kubectl get nodes

Unable to connect to the server: tls: failed to verify certificate: x509: certificate signed by unknown authority (possibly because of "crypto/rsa: verification error" while trying to verify candidate authority certificate "kubernetes")

处理:

bash 复制代码
[root@master1 ~]# rm -rf .kube/
[root@master1 ~]# sudo mkdir ~/.kube
[root@master1 ~]# sudo cp /etc/kubernetes/admin.conf ~/.kube/

[root@master1 ~]# cd ~/.kube
[root@master1 .kube]# sudo mv admin.conf config
[root@master1 .kube]# sudo service kubelet restart
Redirecting to /bin/systemctl restart kubelet.service
相关推荐
蜡笔婧萱8 小时前
Docker介绍及其基础简介(一)
云原生·eureka
谢亮_vipxieliang10 小时前
Kubernetes 的“操作系统化”:从容器编排到 AI 基础设施控制平面
人工智能·平面·kubernetes
sbjdhjd13 小时前
云安全 | Docker 容器逃逸复盘(三):docker.sock 挂载与 Docker-in-Docker 风险
经验分享·网络安全·docker·云原生·容器·kubernetes·云安全
热爱Liunx的丘丘人13 小时前
1、什么是K8s
云原生·容器·kubernetes
帷幕落秋14 小时前
Docker的两种安装
运维·docker·容器
fengkai454515 小时前
十二、Redis -2
运维·数据库·redis·容器
DolitD17 小时前
3D应用多实例并发中的GPU隔离技术路径分析
容器·gru·接口隔离原则
姜鱼问生18 小时前
docker exec 排查容器问题:从日志到进程
运维·网络·数据库·docker·容器
小匠石钧知20 小时前
07_在k8s集群中安装ingress-nginx
nginx·容器·kubernetes·ingress
零基础12321 小时前
Docker 部署实战:从入门到精通
docker·容器