本地服务启动后nacos注册ip错误导致网关请求错误以及网关无法将请求发送nacos内的本地服务错误原因

查看一下网关ip到nacos本地服务ip是否是通的本地服务ip地址是否是你想要的,如果不通请看下文

原因

如果电脑装了虚拟机,或者使用了VPN,所以存在多块网卡,服务注册到nacos时默认使用了虚拟机或者vpn对外的网卡,导致网关无法将请求路由到正确的服务上。

nacos查看服务的IP地址如下

实际想使用的IP地址是 127.0.0.1 ,即我本机的IP地址,因为开发环境服务是运行在本机的。

解决办法:

直接在spring配置文件中将相关服务nacos的配置里加上ip这一项属性,将注册的服务IP直接设置为想要的IP地址,然后重启服务即可。

java 复制代码
spring:
  cloud:
    nacos:
      discovery:
        server-addr: localhost:8848
        ip: 127.0.0.1

修改完成重启服务之后在nacos查看的地址如下:

------------------------------------------与正文内容无关------------------------------------

如果觉的文章写对各位读者老爷们有帮助的话,麻烦点赞加关注呗!小弟在这拜谢了!

如果您觉得我的文章在某些地方写的不尽人意或者写的不对,从而让你对你人生观产生颠覆(概不负责),需要斧正,麻烦在评论区不吝赐教,作者看到后会根据您的提示查阅文章进行修改,还这世间一个公理一片蓝天

相关推荐
Ruiery5 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包5 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
国科安芯6 小时前
一颗当两颗用:ASC4T245S 的“两组独立 2 位 + 控制挂靠 VCCA“账
网络·电平转换·抗辐射·在轨服务
冯胤清6 小时前
《Jev-IDS:网络入侵检测一种系统模型》论文深度分析总结
网络
91刘仁德8 小时前
HTTP协议详解:从URL到HTTP服务器的完整实战
服务器·网络·笔记·网络协议·http
Sarapines Programmer8 小时前
【Wireshark】安装与使用指南
网络·测试工具·wireshark
星夜夏空9910 小时前
网络编程(5)—— Reactor实现(v4)
网络
lisanmengmeng12 小时前
NRPE 添加命令(一)
linux·运维·服务器
rest102412 小时前
用io_uring进行io测试
网络
恒拓高科WorkPlus12 小时前
企业怎样选择IM即时通讯平台?私有化部署还是SaaS更适合?
网络·github