CCNP课程实验-06-EIGRP-Trouble-Shooting

目录

实验条件

网络拓朴

环境配置

R1

java 复制代码
R1(config)#do show run | s interface 
interface Ethernet0/0
 ip address 12.1.1.1 255.255.255.0
 delay 1
interface Ethernet0/1
 ip address 13.1.1.1 255.255.255.0

router eigrp 1234
 network 0.0.0.0

R2

java 复制代码
interface Ethernet0/0
 ip address 12.1.1.2 255.255.255.0
interface Ethernet0/1
 ip address 24.1.1.2 255.255.255.0
interface Ethernet0/3
  af-interface Ethernet0/1
   authentication mode md5
   authentication key-chain CCNP
  exit-af-interface

router eigrp CCNP
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  af-interface Ethernet0/1
   authentication mode md5
   authentication key-chain CCNP
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 12.1.1.2 0.0.0.0
  network 24.1.1.0 0.0.0.0
 exit-address-family

Key-chain CCNP
 key 1
  key-string CC1E

R3

java 复制代码
interface Ethernet0/0
 bandwidth 1

router eigrp CCNP
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  topology base
  exit-af-topology
  network 13.1.1.3 0.0.0.0
  network 34.1.1.4 0.0.0.0
  metric weights 0 1 1 1 1 1 1
 exit-address-family

R4

java 复制代码
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
interface Ethernet0/0
 ip address 34.1.1.4 255.255.255.0
interface Ethernet0/1
 ip address 24.1.1.4 255.255.255.0
 ip authentication mode eigrp 1234 md5
 ip authentication key-chain eigrp 1234 CCNP

router eigrp 123
 network 0.0.0.0

key chain CCNP
 key 1
  key-string CCIE

开始排错

错误1:没有配置IP地址,IP地址宣告有误

R3上没有配置IP地址,先配置上IP地址,同时,宣告进EIGRP

IP规则, AB.1.1.[A|B]/24, AB是两台路由器的编号.
R3路由器上配置

java 复制代码
interface Ethernet0/0
 bandwidth 1
 ip address 34.1.1.3 255.255.255.0
interface Ethernet0/1
 ip address 13.1.1.3 255.255.255.0

router eigrp CCNP
 address-family ipv4 unicast autonomous-system 123
 no network 34.1.1.4 0.0.0.0
 network 34.1.1.3 0.0.0.0

错误2:R3配置了与R1不同的K值报错了。

java 复制代码
R3(config-router-af)#
*Jan  4 06:33:44.598: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1234: Neighbor 13.1.1.1 (Ethernet0/1) is down: K-value mismatch

修改配置

java 复制代码
router eigrp CCNP
 !
 address-family ipv4 unicast autonomous-system 123
 no metric weights 0 1 1 1 1 1 1

结果显示,成功与R1建立邻居关系

java 复制代码
R3(config-router-af)#do show ip eigrp neighbor 
EIGRP-IPv4 VR(CCNP) Address-Family Neighbors for AS(1234)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   13.1.1.1                Et0/1                    14 00:00:52   10   100  0  6

错误3:R4上的AS号配置错,不是1234

刚刚在R3上查询发现,并没有R4的邻居信息。

java 复制代码
no router eigrp 123
router eigrp 1234
 router-id 4.4.4.4
 network 0.0.0.0

结果显示,成功与R4建立邻居关系

java 复制代码
R3(config-router-af)#do show ip eigrp neighbor 
EIGRP-IPv4 VR(CCNP) Address-Family Neighbors for AS(1234)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   34.1.1.4                Et0/0                    11 00:00:11   13  5000  0  3
0   13.1.1.1                Et0/1                    14 00:14:52   10   100  0  6

结果显示,成功与R3建立邻居关系

java 复制代码
R4(config-router)#do show ip eigrp neighbor
EIGRP-IPv4 Neighbors for AS(1234)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   34.1.1.3                Et0/0                    11 00:00:06 1996  5000  1  6

从R4上配置来看,并没有什么问题,但是并未发现R2邻居信息。继续排查R2的信息

错误4:R2上配置的Key-chain的R4上配置的Key-chain不一致

修改R2的Key-chain配配置
R2

java 复制代码
key chain CCNP
 key 1
  key-string CCIE

查询邻居信息,发现邻居没有正常建立。 继续排错R2的信息

错误5:R2宣告地址段不正确。

R2

java 复制代码
router eigrp CCNP
 address-family ipv4 unicast autonomous-system 1234
  no network 24.1.1.0 0.0.0.0
  network 24.1.1.2 0.0.0.0

结果显示,成功与R4建立邻居关系

java 复制代码
R2(config-router-af)#do show ip eigrp neighbor
EIGRP-IPv4 VR(CCNP) Address-Family Neighbors for AS(1234)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   24.1.1.4                Et0/1                    12 00:00:09 1598  5000  0  6
0   12.1.1.1                Et0/0                    12 00:42:33 1025  5000  0  11

错误6:R3的接口宽带被变更

所有的邻居正常建立。都可以查到邻居信息。

目标要实现R1访问R4的环回口4.4.4.4形成等价的负载均衡。查询R1的路由表
R1路由表

java 复制代码
      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/409856] via 12.1.1.2, 00:02:59, Ethernet0/0

只有一条路由信息。

java 复制代码
R1#show ip eigrp topology all-links 
EIGRP-IPv4 Topology Table for AS(1234)/ID(13.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 24.1.1.0/24, 1 successors, FD is 281856, serno 4
        via 12.1.1.2 (281856/281600), Ethernet0/0
P 4.4.4.4/32, 1 successors, FD is 409856, serno 6
        via 12.1.1.2 (409856/409600), Ethernet0/0
P 13.1.1.0/24, 1 successors, FD is 281600, serno 2
        via Connected, Ethernet0/1
P 34.1.1.0/24, 1 successors, FD is 307456, serno 5
        via 12.1.1.2 (307456/307200), Ethernet0/0
        via 13.1.1.3 (2560051200/2560025600), Ethernet0/1
P 12.1.1.0/24, 1 successors, FD is 256256, serno 1
        via Connected, Ethernet0/0

只有收到一条4.4.4.4的路由信息。并没有从R3上传递过来的路由。
继续查看R3的路由表

java 复制代码
      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/4101120] via 13.1.1.1, 00:10:13, Ethernet0/1

结果发现路由表中该路由是从R1传递过来,并没有R4过来的路由信息,再次查询R3上的Eigrp拓扑信息

java 复制代码
P 4.4.4.4/32, 1 successors, FD is 524943360, serno 8
        via 13.1.1.1 (524943360/459407360), Ethernet0/1
        via 34.1.1.4 (655753216000/327761920), Ethernet0/0

可以发现。从R4过来的FD值巨大无比。因此可以估计出,宽带或是延迟之类的参数被配置了。

java 复制代码
R3#show int e0/0
Ethernet0/0 is up, line protocol is up 
  Hardware is AmdP2, address is aabb.cc00.3000 (bia aabb.cc00.3000)
  Internet address is 34.1.1.3/24
  MTU 1500 bytes, BW 1 Kbit/sec, DLY 1000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
......

可以看出本该正常值为BW 10000 Kbit/sec变成了1.

java 复制代码
R3(config)#int e0/0
R3(config-if)#no bandwidth 1

再次查看R3路由表

java 复制代码
      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/3584000] via 34.1.1.4, 00:01:06, Ethernet0/0

路由已经正常了,路由表中由R4过来的路由竞争RIB成功。

查询R1上的路由表

java 复制代码
      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/409856] via 12.1.1.2, 00:07:45, Ethernet0/0

目标还是没有达成。需要继续排错。

错误7:R1的接口延迟配置被变更

查看R1的拓扑数据

java 复制代码
R1#show ip eigrp topology     
EIGRP-IPv4 Topology Table for AS(1234)/ID(13.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 
......
P 4.4.4.4/32, 1 successors, FD is 409856
        via 12.1.1.2 (409856/409600), Ethernet0/0
        via 13.1.1.3 (435200/409600), Ethernet0/1
......

发现拓扑表中已经有两条路由数据了。via 12.1.1.2的FD大于via 13.1.1.3的AD值。同时via 13.1.1.3的FD也大于via 12.1.1.2的AD值。因此via 13.1.1.3的这一条路由是一条FS可行后续,形成了非等价负载均衡,仍然不满足要求的等价负载均衡,继续排查。

由两个路由记录的配置值可以看出。FD值不一致,比较两个接口的配置。发现

java 复制代码
interface Ethernet0/0
 delay 1
interface Ethernet0/1

Ethernet0/0接口的延迟配置不对,修改delay值

java 复制代码
interface Ethernet0/0
 no delay 1

查询R1路由表

java 复制代码
R1(config-router)#do show ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/435200] via 13.1.1.3, 00:17:11, Ethernet0/1
                 [90/435200] via 12.1.1.2, 00:17:11, Ethernet0/0
......

由表可见目标达成。

相关推荐
是Dream呀10 分钟前
Python从0到100(八十六):神经网络-ShuffleNet通道混合轻量级网络的深入介绍
网络·python·神经网络
山楂树の1 小时前
计算机网络 性能指标相关
网络·计算机网络
泪不是Web妳而流2 小时前
【HTML入门】Sublime Text 4与 Phpstorm
网络·经验分享·编辑器·html·学习方法·sublime text·phpstorm
star010-2 小时前
一文学会HTML编程之视频+图文详解详析
前端·网络·网络安全·html·html5
学问小小谢7 小时前
第26节课:内容安全策略(CSP)—构建安全网页的防御盾
运维·服务器·前端·网络·学习·安全
一ge科研小菜鸡8 小时前
网络安全实战指南:攻防技术与防御策略
网络
马立杰11 小时前
H3CNE-33-BGP
运维·网络·h3cne
Mason Lin12 小时前
2025年1月22日(网络编程 udp)
网络·python·udp
字节全栈_rJF12 小时前
概述、 BGP AS 、BGP 邻居、 BGP 更新源 、BGP TTL 、BGP路由表、 BGP 同步
网络·智能路由器·php
EchoToMe12 小时前
电信传输基本理论/5G网络层次架构——超三万字详解:适用期末考试/考研/工作
网络·5g·架构