CentOS下用rpm安装软件时报错error: Failed dependencies

在CentOS下用rpm安装软件时会报如下错误:

1、安装时提示:

root@db software# rpm -ivh ksh-20120801-254.el8.x86_64.rpm

warning: ksh-20120801-254.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY

error: Failed dependencies:

libm.so.6(GLIBC_2.23)(64bit) is needed by ksh-20120801-254.el8.x86_64

解决的方法就是在 rpm 语句后面加上 --force --nodeps

即原本为 rpm -ivh *.rpm 现在改成 rpm -ivh *.rpm --force --nodeps 就可以了。

nodeps的意思是忽视依赖关系,因为各个软件之间会有多多少少的联系,有了这两个设置选项就忽略了这些依赖关系,强制安装或者卸载。

root@db software# rpm -ivh ksh-20120801-254.el8.x86_64.rpm --force --nodeps

warning: ksh-20120801-254.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY

Preparing... ################################# 100%

Updating / installing...

1:ksh-20120801-254.el8 ################################# 100%

2、尝试卸载:

造成这个问题的主要原因是套件被重复(强制) 安装了两次以上,

尝试了--nodeps, --force, --justdb 都不行,可以用如下办法解决:

通过 man rpm,发现 --allmatches 应该可以解决这个问题.

root@db software# rpm -e --allmatches --nodeps ksh*

相关推荐
向成科技18 分钟前
XC3576H工控主板|深度适配Ubuntu 26.04 LTS,释放边缘AI与工业开发新潜能
linux·人工智能·ubuntu·机器人·硬件·主板·边缘ai
逐流人19 分钟前
Ceph分布式存储集群配置与池管理:从配置优先级到PG、复本池与纠删码池
运维·分布式·ceph·云原生·云计算·rados
海宇服务26 分钟前
零信任架构实战:基于海宇车型识别精准构建自动化定损网关
运维·人工智能·架构·自动化
Fcy6481 小时前
Linux下 进程间关系与守护进程
linux·运维·服务器·守护进程
g10565591391 小时前
公有云_云运维服务
java·运维·服务器
码农小韩1 小时前
Linux驱动理论(二)——Linux字符设备驱动
linux·嵌入式软件开发·linux操作系统·linux应用开发·linux驱动理论
well06121 小时前
Linux粘滞位与Makefile机制深度解析
linux·运维·服务器
再写一行代码就下班2 小时前
linux sh脚本在windows修改导致无法使用解决方式
java·linux·centos
hzxpaipai2 小时前
杭州企业官网怎么建设?从策划到上线的5步建站方法
运维·服务器·前端·网络
哲霖软件2 小时前
非标机械设备公司怎么做信息化?破解通用ERP水土不服难题
大数据·运维