CentOS下用rpm安装软件时报错error: Failed dependencies

在CentOS下用rpm安装软件时会报如下错误:

1、安装时提示:

root@db software# rpm -ivh ksh-20120801-254.el8.x86_64.rpm

warning: ksh-20120801-254.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY

error: Failed dependencies:

libm.so.6(GLIBC_2.23)(64bit) is needed by ksh-20120801-254.el8.x86_64

解决的方法就是在 rpm 语句后面加上 --force --nodeps

即原本为 rpm -ivh *.rpm 现在改成 rpm -ivh *.rpm --force --nodeps 就可以了。

nodeps的意思是忽视依赖关系,因为各个软件之间会有多多少少的联系,有了这两个设置选项就忽略了这些依赖关系,强制安装或者卸载。

root@db software# rpm -ivh ksh-20120801-254.el8.x86_64.rpm --force --nodeps

warning: ksh-20120801-254.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 8483c65d: NOKEY

Preparing... ################################# 100%

Updating / installing...

1:ksh-20120801-254.el8 ################################# 100%

2、尝试卸载:

造成这个问题的主要原因是套件被重复(强制) 安装了两次以上,

尝试了--nodeps, --force, --justdb 都不行,可以用如下办法解决:

通过 man rpm,发现 --allmatches 应该可以解决这个问题.

root@db software# rpm -e --allmatches --nodeps ksh*

相关推荐
奔跑的大白啊22 分钟前
多容器共享目录权限踩坑记
linux·ubuntu·共享目录·linux权限·docker 容器化部署
黄大刀1 小时前
DataPulse一款开箱即用的SCADA(四)-历史记录
运维·scada·动环
正在走向自律2 小时前
AI数据分析与可视化:从基础到应用实践
服务器·人工智能·python·机器学习·数据分析·pandas
OnlineProxy3 小时前
亚马逊多账号运营:如何在规避“关联封号”风险的同时实现电商规模化扩张
服务器·数据库·redis
归秋1423 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮3 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
H.莓飛4 小时前
【C++】命名空间、缺省参数、函数重载与引用
linux·开发语言·c++·visual studio
91刘仁德4 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
辻弋2014 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
硅基手札5 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议