linux部署es8.0版本以及启动了浏览器访问不了

下载地址

https://www.elastic.co/cn/downloads/past-releases/elasticsearch-8-0-0

解压安装包

tar -zxvf elasticsearch-8.0.0-linux-x86_64.tar.gz

移动到指定文件夹

mv elasticsearch-8.0.0 /usr/local/elasticsearch-8.0

进入文件夹

cd /usr/local/elasticsearch-8.0/

新建data和log文件夹用于存放数据

mkdir data

mkdir log
进入config文件夹

cd config/

修改elasticsearch.yml

vim elasticsearch.yml

path.logs: /usr/local/elasticsearch-8.0/log

#开启xpack

xpack.security.enabled: false

xpack.security.transport.ssl.enabled: false

#允许跨域

http.cors.enabled: true

http.cors.allow-origin: "*"

http.cors.allow-headers: Authorization,X-Requested-With,Content-Type,Content-Length

#配置

network.host: 0.0.0.0

http.port: 9200

cd /usr/local/elasticsearch-8.0/bin/

启动

./elasticsearch

1

出现错误:

因为es默认不能用root用户启动,也不推荐使用root启动es,通常需要去创建一个新用户

adduser es

passwd es

chown -R es:es /usr/local/elasticsearch-8.0/

chmod 770 /usr/local/elasticsearch-8.0/

切换用户,重新启动es

su es

./elasticsearch

开放端口:

firewall-cmd --zone=public --add-port=9200/tcp --permanent

firewall-cmd --reload

访问
#ip是配置文件中network.host

http://127.0.0.1:9200/

会报错
ERROR: 3 bootstrap checks failed. You must address the points described in the following 3 lines before starting Elasticsearch.

bootstrap check failure 1 of 3: max file descriptors 4096 for elasticsearch process is too low, increase to at least 65535

bootstrap check failure 2 of 3: max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

bootstrap check failure 3 of 3: the default discovery settings are unsuitable for production use; at least one of discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes must be configured

ERROR: Elasticsearch did not exit normally - check the logs at /usr/local/elasticsearch-8.0/log/es8.log

主要是文件权限与内存大小问题:

elasticsearch用户拥有的可创建文件描述的权限太低,至少需要65536,

#切换到root用户修改

vim /etc/security/limits.conf # 在最后面追加下面内容

es hard nofile 65536

es soft nofile 65536 #es是启动elasticsearch的用户

max_map_count文件包含限制一个进程可以拥有的VMA(虚拟内存区域)的数量

#切换到root用户修改

vim /etc/sysctl.conf # 在最后面追加下面内容

vm.max_map_count=655360

执行 sysctl -p

相关推荐
M78佐菲几秒前
ARM学习笔记(1)
linux·arm开发·笔记·嵌入式硬件·学习
骇客野人4 分钟前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
益达丫1 小时前
Socket编程揭秘:端口、IP与进程通信的底层逻辑
linux·笔记
蓝速科技3 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese4 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky4 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南5 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
vortex55 小时前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
我命由我123455 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人5 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器