linux部署es8.0版本以及启动了浏览器访问不了

下载地址

https://www.elastic.co/cn/downloads/past-releases/elasticsearch-8-0-0

解压安装包

tar -zxvf elasticsearch-8.0.0-linux-x86_64.tar.gz

移动到指定文件夹

mv elasticsearch-8.0.0 /usr/local/elasticsearch-8.0

进入文件夹

cd /usr/local/elasticsearch-8.0/

新建data和log文件夹用于存放数据

mkdir data

mkdir log
进入config文件夹

cd config/

修改elasticsearch.yml

vim elasticsearch.yml

path.logs: /usr/local/elasticsearch-8.0/log

#开启xpack

xpack.security.enabled: false

xpack.security.transport.ssl.enabled: false

#允许跨域

http.cors.enabled: true

http.cors.allow-origin: "*"

http.cors.allow-headers: Authorization,X-Requested-With,Content-Type,Content-Length

#配置

network.host: 0.0.0.0

http.port: 9200

cd /usr/local/elasticsearch-8.0/bin/

启动

./elasticsearch

1

出现错误:

因为es默认不能用root用户启动,也不推荐使用root启动es,通常需要去创建一个新用户

adduser es

passwd es

chown -R es:es /usr/local/elasticsearch-8.0/

chmod 770 /usr/local/elasticsearch-8.0/

切换用户,重新启动es

su es

./elasticsearch

开放端口:

firewall-cmd --zone=public --add-port=9200/tcp --permanent

firewall-cmd --reload

访问
#ip是配置文件中network.host

http://127.0.0.1:9200/

会报错
ERROR: 3 bootstrap checks failed. You must address the points described in the following 3 lines before starting Elasticsearch.

bootstrap check failure 1 of 3: max file descriptors 4096 for elasticsearch process is too low, increase to at least 65535

bootstrap check failure 2 of 3: max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

bootstrap check failure 3 of 3: the default discovery settings are unsuitable for production use; at least one of discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes must be configured

ERROR: Elasticsearch did not exit normally - check the logs at /usr/local/elasticsearch-8.0/log/es8.log

主要是文件权限与内存大小问题:

elasticsearch用户拥有的可创建文件描述的权限太低,至少需要65536,

#切换到root用户修改

vim /etc/security/limits.conf # 在最后面追加下面内容

es hard nofile 65536

es soft nofile 65536 #es是启动elasticsearch的用户

max_map_count文件包含限制一个进程可以拥有的VMA(虚拟内存区域)的数量

#切换到root用户修改

vim /etc/sysctl.conf # 在最后面追加下面内容

vm.max_map_count=655360

执行 sysctl -p

相关推荐
吴声子夜歌9 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng9 小时前
NRPE 添加命令(一)
linux·运维·服务器
pt104310 小时前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议
树下水月10 小时前
Typora破解
linux·服务器·前端
沫璃染墨11 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
wuminyu11 小时前
LockStack在虚拟线程Mount和Unmount拷贝过程剖析
java·linux·c语言·jvm·c++
深念Y11 小时前
rime-雾凇拼音-配置记录
linux·junit·软件·拼音·kde
HAHAXX811 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础12312 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
程序猿老A13 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器