AcWing 829. 模拟队列

题目

实现一个队列,队列初始为空,支持四种操作:

  1. push x -- 向队尾插入一个数 x
  2. pop -- 从队头弹出一个数;
  3. empty -- 判断队列是否为空;
  4. query -- 查询队头元素。

现在要对队列进行 M个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤100000 1≤x≤10^9

所有操作保证合法。

输入样例:

perl 复制代码
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例:

objectivec 复制代码
NO
6
YES
4

代码

java 复制代码
import java.util.Scanner;

public class Main {
    static int tt, hh = -1, M = 1000010;
    static int[] nums = new int[M];
    static void push(int x) {
        nums[++ hh] = x;
    }
    static void pop() {
        tt ++;
    }
    static String empty() {
        if (hh >= tt)   return "NO";
        else return "YES";
    }
    static void query() {
        System.out.println(nums[tt]);
    }
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int m = in.nextInt();
        while (m > 0) {
            m--;
            String s = in.next();
            if (s.equals("push")) {
                int x = in.nextInt();
                push(x);
            } else if (s.equals("empty")) {
                System.out.println(empty());
            } else if (s.equals("pop")) {
                pop();
            } else {
                query();
            }
        }
    }
}
相关推荐
小鸡脚来咯1 小时前
SpringBoot 常用注解通俗解释
java·spring boot·后端
豌豆花下猫2 小时前
Python 3.14 t-string 要来了,它与 f-string 有何不同?
后端·python·ai
小奏技术2 小时前
Spring7将正式弃用Junit 4,我们也是时候迁移到Junit5了
后端
吴佳浩2 小时前
Python入门指南(四)-项目初始化
人工智能·后端·python
一颗知足的心2 小时前
Go语言之路————指针、结构体、方法
开发语言·后端·golang
Rabbb3 小时前
C# JSON属性排序、比较 Newtonsoft.Json
后端
蓝易云3 小时前
在Linux、CentOS7中设置shell脚本开机自启动服务
前端·后端·centos
一千柯橘4 小时前
Nestjs 解决 request entity too large
javascript·后端
userkang4 小时前
消失的前后端,崛起的智能体
前端·人工智能·后端·ai·硬件工程