题目
实现一个队列,队列初始为空,支持四种操作:
push x
-- 向队尾插入一个数 xpop
-- 从队头弹出一个数;empty
-- 判断队列是否为空;query
-- 查询队头元素。
现在要对队列进行 M个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。
输入格式
第一行包含整数 M,表示操作次数。
接下来 M 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示队头元素的值。
数据范围
1≤M≤100000 1≤x≤10^9
所有操作保证合法。
输入样例:
perl
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
objectivec
NO
6
YES
4
代码
java
import java.util.Scanner;
public class Main {
static int tt, hh = -1, M = 1000010;
static int[] nums = new int[M];
static void push(int x) {
nums[++ hh] = x;
}
static void pop() {
tt ++;
}
static String empty() {
if (hh >= tt) return "NO";
else return "YES";
}
static void query() {
System.out.println(nums[tt]);
}
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int m = in.nextInt();
while (m > 0) {
m--;
String s = in.next();
if (s.equals("push")) {
int x = in.nextInt();
push(x);
} else if (s.equals("empty")) {
System.out.println(empty());
} else if (s.equals("pop")) {
pop();
} else {
query();
}
}
}
}