关于Ubuntu下docker-mysql:ERROR 2002报错

报错场景:

mysql容器创建好后登录mysql时即使密码正确也是报出下方提示:

原因是在创建mysql容器在创建时本地目录缺失,

先去自建一个目录,例如:

/opt/my_sql

正确完整目录如下:

docker run --name=mysql -p 3306:3306 -v /opt/my_sql:/var/lib/mysql -e MYSQL_ROOT_PASSWORD=123456 -d 镜像ID

--name 自定义容器名称 //配置容器名称

-p 系统映射端口:容器mysqld端口 //映射系统端口

-v 系统目录:docker目录 //映射系统目录

-e //配置数据库密码

重新进入容器

docker exec -it mysql mysql -u root -p

*docker exec

-i 交互模式

-t 进入容器CLI模式

容器名称

容器执行命令

重新登录数据库,报错消失。

相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS4 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站4 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心4 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)4 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang4 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren4 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github