使用docker安装dolphinscheduler

1、前提是安装docker和docker-compose

2、#mkdir /data/dolphinscheduler

3、镜像

docker load -i dolphinscheduler-mysql-driver.tar

docker pull zookeeper:3.6.2:3.6.2

docker tag a7 bitnami/zookeeper:3.6.2

理论上postgresql也可以在线pull,但是在线down下来的镜像安装成功后会报错没有root库或者密码错误等(docker pull postgres:11.11.0),所以最终采用了离线镜像

docker load -i postgresql-11.11.0.tar

查看镜像:docker images

确保镜像的名称及版本是以下内容:

REPOSITORY TAG IMAGE ID CREATED SIZE

apache/dolphinscheduler mysql-driver d55a08cd125d 21 months ago 404MB

bitnami/zookeeper 3.6.2 a72350516291 2 years ago 268MB

bitnami/postgresql 11.11.0 783da6164a58 2 years ago 258MB

如果不是,则使用docker tag命令修改下。

4、脚本

最后把config.env.sh和docker-compose.yml脚本拷贝到/data/dolphinscheduler目录下

5、启动

最后执行启动命令:

docker-compose up -d

6、查看状态

docker ps -a

netstat -ntulp |grep 12345

7、浏览器访问:

http://192.xxx.xxx.xx:12345/dolphinscheduler

相关推荐
虎头金猫12 小时前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS12 小时前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站13 小时前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏14 小时前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心14 小时前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing14 小时前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅15 小时前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)15 小时前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang15 小时前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren15 小时前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github