centos 搭建ftp服务器

项目上需要用到ftp文件服务同步,所以在测试环境进行搭建,其中遇到了一些问题,遂记录。

1、安装vsftpd软件包

打开终端并输入以下命令来安装vsftpd

bash 复制代码
yum install vsftpd -y

2、运行vsftpd

bash 复制代码
systemctl start vsftpd

3、测试匿名连接

我这里用的工具是MobaXterm

点击OK,然后弹出输入密码,直接点 OK,即可。如果一切正常则会登录成功。

这个pub目录就是默认的ftp文件服务器的目录了,真实地址是在/var/ftp目录下:

bash 复制代码
ls -l /var/ftp 

4、配置vsftpd

编辑/etc/vsftpd/vsftpd.conf文件,使用任何文本编辑器打开该文件:

bash 复制代码
vim /etc/vsftpd/vsftpd.conf

修改配置参数。根据需要对以下参数进行调整或取消注释:

bash 复制代码
anonymous_enable=NO: 关闭匿名登录功能;

local_enable=YES: 允许本地用户登录;

write_enable=YES: 允许写入文件;

local_root=/data/nas: 配置ftp目录;

chroot_local_user=YES: 限制用户只能访问其主目录;

重启vsftpd服务

bash 复制代码
systemctl restart vsftpd

此时再用anonymous登录就会提示:530 Please login with USER and PASS.

5、添加FTP用户

创建一个系统用户,并为其分配FTP目录

bash 复制代码
useradd ftpuser
# useradd ftpuser -s /sbin/nologin #添加一个名为ftpuser的账户用于登陆ftp
passwd ftpuser
mkdir /home/ftpuser
chown ftpuser:ftpuser /home/ftpuser

6、使用新用户密码登录

7、常见问题

vsftpd目录限制chroot(用户隔离)500错误分析以及解决方案-阿里云开发者社区

1)chroot_list文件不存在

500 OOPS: could not read chroot() list file:/etc/vsftpd/chroot_list

由于vsftpd默认没有chroot_list文件,故而登录失败,创建一下文件:

touch /etc/vsftpd/chroot_list

再尝试登录

2)安全问题

500 OOPS: vsftpd: refusing to run with weitable root inside chroot()

这是因为,为了避免一个安全漏洞,从vsftpd 2.3.5 开始,chroot目录必须不可写,否则用户不能登录

若要解决该问题,可以新增一条参数:

allow_writeable_chroot=YES

相关推荐
左手の明天9 小时前
SLIP 协议封装与解析详解:原理、C 代码与实战案例
linux·c语言·开发语言·c++
꯭自꯭闭꯭9 小时前
达梦SQL优化相关
linux·运维·数据库·sql
一条破秋裤9 小时前
Linux 共享内存通信:POSIX 共享内存与 mmap
linux·运维·服务器
贵州山魈羡民10 小时前
【玩转手机】通过 Podroid 上的 Alpine 部署 1Panel,把微型服务器装进口袋
运维·服务器
谷哥的小弟11 小时前
CentOS Stream浴火重生
linux·运维·centos
程序员-Benothing12 小时前
Shell输入输出详解:read、echo、printf、颜色输出
linux·运维·服务器
FPGA小徐12 小时前
从 NEMU 到 AbstractMachine:程序、运行时环境与 AM 完全解析
linux·运维·服务器
qetfw14 小时前
Debian Chrony 时间同步、RAID5 与 LUKS 磁盘加密配置
linux·debian
东城居士16 小时前
Linux驱动阻塞与非阻塞访问的理解
linux·嵌入式系统
..Dauntless..16 小时前
【Linux】进程地址空间初步理解
linux·运维·服务器