Sentinel的控制台部署在服务器,控制台一直读取不到本机的服务的原因

控制台一直报

2021-02-22 17:36:48.641 ERROR 7265 --- pool-2-thread-1 c.a.c.s.dashboard.metric.MetricFetcher : Failed to fetch metric from http://192.168.111.19:8719/metric?startTime=1613986473000\&endTime=1613986479000\&refetch=false (ConnectionException: Connection timed out)

这个错误。

而且在这个服务器部署的sentinel控制台上面拿不到远程服务器Nacos里面配置的限流规则,但是在本机启动一个dashboard项目就可以看到Nacos里面配置的。

原因是本机网络是局域网,sentinel需要监控主机,sentinel部署在服务器的话是无法访问到本机网络的,所以要么sentinel和应用都部署上服务器,要么都在本地运行

相关推荐
不会就选b6 小时前
Linux之TCP理论<1>
linux·运维·服务器
小π军6 小时前
操作系统面试题
java·linux·服务器
倔强的石头1067 小时前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言
Android系统攻城狮8 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
_upupup8 小时前
Linux中的自动化构建——make/Makefile
linux·运维·自动化
还卿一钵无情泪9 小时前
Docker 部署Unsloth 绕开环境配置难题
运维·人工智能·docker·ai·容器·nlp·干货
打工仔折腾 AI10 小时前
Docker镜像分层与卷挂载到底怎么工作:一次文件系统层面的实测分析
运维·人工智能·后端·python·docker·容器·性能优化
大猫会长11 小时前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
夜之眷属11 小时前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
极客先躯11 小时前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图