解决kubesphere流水线docker登陆错误http: server gave HTTP response to HTTPS client

kubesphere DevOps流水线中,在登录私有的harbor仓库时,报以下错误

复制代码
+ docker login 111.230.19.120:80 -u admin -p test123.
WARNING! Using --password via the CLI is insecure. Use --password-stdin.
Error response from daemon: Get "https://111.230.19.120:80/v2/": http: server gave HTTP response to HTTPS client
script returned exit code 1

原因:

默认情况下,Docker 要求镜像仓库使用 HTTPS 来保证通信的安全。如果仓库没有使用 HTTPS 或者证书不是由受信任的证书颁发机构签发的,Docker 客户端将无法与其建立连接。

解决方案:

kubesphere集群中节点的docker,需要配置docker支持该私有harbor仓库的http访问

在K8S集群的所有节点,执行以下操作

1、配置daemon.json文件
复制代码
tee /etc/docker/daemon.json <<-'EOF'
{
  "registry-mirrors": ["https://chqac97z.mirror.aliyuncs.com"]
  ,"insecure-registries":["https://111.230.19.120"]
  ,"registry-mirrors":["https://111.230.19.120"]
}
EOF

其中:

  • registry-mirrors:配置的是阿里云镜像加速,该文的问题不需要配置该项
  • insecure-registries:允许 Docker 客户端连接到没有使用 HTTPS 或使用了自签名证书的 Docker 镜像仓库
  • 111.230.19.120:80:是我的harbor地址,需要替换成你的地址
  • registry-mirrors:必须配置你的harbor仓库!!!否则可能造成,docker login是成功的,但是push镜像时出现相同的问题!!!
2、使配置生效
复制代码
systemctl daemon-reload
systemctl restart docker

重新允许流水线,发现已成功登录harbor仓库

相关推荐
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS5 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心5 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing5 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
赵文宇(温玉)5 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
羑悻的小杀马特5 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
XUEYUAN52125 天前
ASN 自治系统号风控:平台如何通过 IP 所属自治域批量识别代理流量
python·网络协议·http·网络安全·socks5
BianHuanShiZhe5 天前
docker常见命令
docker
正经教主5 天前
【FDE系列】阶段2:Day 43:Docker Compose — 多容器一键编排
人工智能·docker·fde