MongoDB 6.1 及以上版本使用配置文件的方式启动报错 Unrecognized option: storage.journal.enabled

如果你使用的 MongoDB 的版本大于等于 6.1,并且在 MongoDB 的配置文件中编写了如下内容

yaml 复制代码
storage:
  journal:
    # 启用或禁用持久性日志以确保数据文件保持有效和可恢复
    # true 启用;false 不启用
    # 64 位系统默认启用,启用后 MongoDB 可以在宕机后根据持久性日志进行恢复
    enabled: true

那么在 MongoDB 使用配置文件的方式进行启动时,会出现如下报错

会出现这个报错的原因是 MongoDB 官方在 6.1 及其以上的版本中 对 storage.journal.enabled 配置项以及 --journal 和 --nojournal 命令行参数进行了移除,并且保证 MongoDB 的 journal 总是开启

官方文档网址:https://www.mongodb.com/docs/manual/core/journaling/

所以在 6.1 及其以上的 MongoDB 版本 中,我们无需也不能通过配置文件中的配置项 storage.journal.enabled 或者通过命令行参数 --journal 和 --nojournal 配置 MongoDB 的 journal 是否开启

因此,如果在使用配置文件的方式启动 MongoDB 时报错 Unrecognized option: storage.journal.enabled,我们只需将配置文件中如下的内容进行删除即可

yaml 复制代码
storage:
  journal:
    enabled: true
相关推荐
haerapi1 分钟前
把 PostgreSQL 复制巡检做成可审计闭环:确定性采集、阈值判定与受控模型归纳
数据库·postgresql
跨境小彭16 分钟前
Temu拉美站点铺货实操复盘:手动复制痛点与批量自动化解决方案
服务器·人工智能·搜索引擎·自动化·temu电商运营
心之语歌20 分钟前
Tkinter 画布基本梳理
运维·服务器·python
Shulex41 分钟前
面向跨境电商多渠道消息系统的技术架构:亚马逊站内信合规对接与自动化执行链路设计
运维·架构·自动化
微学AI1 小时前
不让每一步都调用最贵模型:用蓝耘智能路由改造自主式研究 Agent
数据库·人工智能·蓝耘
yjb.gz1 小时前
Oracle19 RAC查看集群状态及磁盘空间情况(巡检)
数据库
bloglin999991 小时前
vmware部署centos7启动docker容器后无法访问服务
运维·docker·容器
钝挫力PROGRAMER1 小时前
开发踩坑记:MyBatis selectKey、空 SQL
数据库·sql·mybatis
JosieBook1 小时前
【数据库】MySQL 实战精通系列 · 第6篇:InnoDB 存储引擎、日志与崩溃恢复
数据库·mysql
杨云龙UP2 小时前
TDengine 3.4.2.8 Community 三节点三副本生产集群部署实战(DNode/MNode/taosAdapter/Explorer)
大数据·linux·运维·数据库·tdengine·时序库