MongoDB 6.1 及以上版本使用配置文件的方式启动报错 Unrecognized option: storage.journal.enabled

如果你使用的 MongoDB 的版本大于等于 6.1,并且在 MongoDB 的配置文件中编写了如下内容

yaml 复制代码
storage:
  journal:
    # 启用或禁用持久性日志以确保数据文件保持有效和可恢复
    # true 启用;false 不启用
    # 64 位系统默认启用,启用后 MongoDB 可以在宕机后根据持久性日志进行恢复
    enabled: true

那么在 MongoDB 使用配置文件的方式进行启动时,会出现如下报错

会出现这个报错的原因是 MongoDB 官方在 6.1 及其以上的版本中storage.journal.enabled 配置项以及 --journal--nojournal 命令行参数进行了移除,并且保证 MongoDB 的 journal 总是开启

官方文档网址:https://www.mongodb.com/docs/manual/core/journaling/

所以在 6.1 及其以上的 MongoDB 版本 中,我们无需也不能通过配置文件中的配置项 storage.journal.enabled 或者通过命令行参数 --journal--nojournal 配置 MongoDB 的 journal 是否开启

因此,如果在使用配置文件的方式启动 MongoDB 时报错 Unrecognized option: storage.journal.enabled,我们只需将配置文件中如下的内容进行删除即可

yaml 复制代码
storage:
  journal:
    enabled: true
相关推荐
Madison-No71 天前
搭建项目测试环境
linux·运维·服务器·python
+VX:Fegn08951 天前
计算机毕业设计|基于springboot + vue蛋糕店管理系统(源码+数据库+文档)
前端·数据库·vue.js·spring boot·课程设计
吴声子夜歌1 天前
Shell编程实例——编写安全的shell脚本(二)
linux·运维·shell
悠悠121381 天前
微服务通信别只看性能:REST 与 gRPC 的 6 个选型判断和一次 502 故障复盘
运维·服务器
哈__1 天前
KES-Operator重塑Kubernetes环境下的KES数据库集群管理
数据库·kubernetes·operator·kes
云老大-阿里云国际站代理商1 天前
华为云国际站服务代理商:NAT网关怎么配?多台ECS共用公网IP要注意什么
服务器·华为云·云计算
IvorySQL1 天前
IvorySQL 5.6 发布:PG 18.6 内核升级,沙盒即开即用
数据库·人工智能·postgresql
zx_741484811 天前
【Linux入门】Shell 函数、正则表达式与文本处理:cut 与 awk
linux·运维·正则表达式
Zenova EdgeOS1 天前
Linux dmesg 工业边缘实战:内核日志过滤、持久化与故障定位
linux·运维·边缘计算·工业边缘·dmesg·内核日志