MongoDB 6.1 及以上版本使用配置文件的方式启动报错 Unrecognized option: storage.journal.enabled

如果你使用的 MongoDB 的版本大于等于 6.1,并且在 MongoDB 的配置文件中编写了如下内容

yaml 复制代码
storage:
  journal:
    # 启用或禁用持久性日志以确保数据文件保持有效和可恢复
    # true 启用;false 不启用
    # 64 位系统默认启用,启用后 MongoDB 可以在宕机后根据持久性日志进行恢复
    enabled: true

那么在 MongoDB 使用配置文件的方式进行启动时,会出现如下报错

会出现这个报错的原因是 MongoDB 官方在 6.1 及其以上的版本中 对 storage.journal.enabled 配置项以及 --journal 和 --nojournal 命令行参数进行了移除,并且保证 MongoDB 的 journal 总是开启

官方文档网址:https://www.mongodb.com/docs/manual/core/journaling/

所以在 6.1 及其以上的 MongoDB 版本 中,我们无需也不能通过配置文件中的配置项 storage.journal.enabled 或者通过命令行参数 --journal 和 --nojournal 配置 MongoDB 的 journal 是否开启

因此,如果在使用配置文件的方式启动 MongoDB 时报错 Unrecognized option: storage.journal.enabled,我们只需将配置文件中如下的内容进行删除即可

yaml 复制代码
storage:
  journal:
    enabled: true
相关推荐
李兆龙的博客5 小时前
问津集 #26:Lakebase——Postgres 的版本化页面存储、数据库分支与计算弹性
数据库
在角落发呆5 小时前
工具配置备份步骤:从手动备份到自动化方案
运维·windows·自动化
_upupup6 小时前
Linux的调试工具——gdb/cgdb
linux·服务器
百度一下吧6 小时前
Nginx 使用手册:从安装配置到实战部署
运维·nginx
JeJe同学6 小时前
Docker镜像导入、容器启动
linux·运维·docker
回眸&啤酒鸭7 小时前
【回眸】自动化白盒测试落地实战指南
运维·自动化·log4j
倔强的石头_7 小时前
聊聊金仓KFS:一款把数据同步软件做扎实的产品
数据库
闲云野鹤在人间7 小时前
MySQL|从理论、安装、备份到主从复制、MHA高可用详解
linux·运维·数据库·mysql·云计算
禾小西7 小时前
Redis:从两大维度和三大主线建立知识体系
数据库·redis·缓存
禾小西8 小时前
Redis 数据结构:快速的 Redis 有哪些慢操作?
数据结构·数据库·redis