MongoDB 6.1 及以上版本使用配置文件的方式启动报错 Unrecognized option: storage.journal.enabled

如果你使用的 MongoDB 的版本大于等于 6.1,并且在 MongoDB 的配置文件中编写了如下内容

yaml 复制代码
storage:
  journal:
    # 启用或禁用持久性日志以确保数据文件保持有效和可恢复
    # true 启用;false 不启用
    # 64 位系统默认启用,启用后 MongoDB 可以在宕机后根据持久性日志进行恢复
    enabled: true

那么在 MongoDB 使用配置文件的方式进行启动时,会出现如下报错

会出现这个报错的原因是 MongoDB 官方在 6.1 及其以上的版本中 对 storage.journal.enabled 配置项以及 --journal 和 --nojournal 命令行参数进行了移除,并且保证 MongoDB 的 journal 总是开启

官方文档网址:https://www.mongodb.com/docs/manual/core/journaling/

所以在 6.1 及其以上的 MongoDB 版本 中,我们无需也不能通过配置文件中的配置项 storage.journal.enabled 或者通过命令行参数 --journal 和 --nojournal 配置 MongoDB 的 journal 是否开启

因此,如果在使用配置文件的方式启动 MongoDB 时报错 Unrecognized option: storage.journal.enabled,我们只需将配置文件中如下的内容进行删除即可

yaml 复制代码
storage:
  journal:
    enabled: true
相关推荐
XiaoMaqqqq4 小时前
市面上正规的IP驱动产业新场景新工具哪家强
运维·python·网络协议·tcp/ip
许彰午4 小时前
01-Oracle数据库简介与版本选择
数据库·oracle
菜鸟~noob2335 小时前
【电子战】第三季预告—波武器与电子系统强力毁伤
开发语言·数据库·matlab·电子战
huainingning5 小时前
RJ SW Console口忘记密码处理方法
linux·运维·服务器
布裘5 小时前
【银河麒麟】桌面系统循环登录,无法进入桌面?
linux·运维·服务器
慧都小项5 小时前
程序到了Linux才出错?用CLion把调试接到目标环境
linux·运维·服务器
Lsetea5 小时前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang6 小时前
docker的备份与迁移
运维·docker·容器
Seraphina366 小时前
SQL注入(二)盲注
网络·数据库·经验分享·笔记·sql
Ruiery7 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器