MongoDB 6.1 及以上版本使用配置文件的方式启动报错 Unrecognized option: storage.journal.enabled

如果你使用的 MongoDB 的版本大于等于 6.1,并且在 MongoDB 的配置文件中编写了如下内容

yaml 复制代码
storage:
  journal:
    # 启用或禁用持久性日志以确保数据文件保持有效和可恢复
    # true 启用;false 不启用
    # 64 位系统默认启用,启用后 MongoDB 可以在宕机后根据持久性日志进行恢复
    enabled: true

那么在 MongoDB 使用配置文件的方式进行启动时,会出现如下报错

会出现这个报错的原因是 MongoDB 官方在 6.1 及其以上的版本中storage.journal.enabled 配置项以及 --journal--nojournal 命令行参数进行了移除,并且保证 MongoDB 的 journal 总是开启

官方文档网址:https://www.mongodb.com/docs/manual/core/journaling/

所以在 6.1 及其以上的 MongoDB 版本 中,我们无需也不能通过配置文件中的配置项 storage.journal.enabled 或者通过命令行参数 --journal--nojournal 配置 MongoDB 的 journal 是否开启

因此,如果在使用配置文件的方式启动 MongoDB 时报错 Unrecognized option: storage.journal.enabled,我们只需将配置文件中如下的内容进行删除即可

yaml 复制代码
storage:
  journal:
    enabled: true
相关推荐
虎头金猫2 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
这个DBA有点耶2 天前
MVCC深入:Read View、版本链与快照读——InnoDB并发控制的内核
数据库·mysql·架构
DBA_G2 天前
从地面到云霄:GBase数据库在民航三大场景的落地实践
数据库
自由能燃气设备2 天前
商用全预混低氮冷凝锅炉免费方案vs付费方案对比+选型避坑指南
大数据·数据库·人工智能
科创致远2 天前
科创致远 ESOP 系统核心效能与实战价值展示
大数据·数据库·人工智能·精益工程
AI职业加油站2 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏2 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
2601_962218612 天前
万象生鲜系统称重自动多退少补算法解决生鲜非标品痛点
大数据·数据库·人工智能·python·算法
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog2 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发