虚拟机网络配置

1. 为什么要配置?

当我们创建好一个虚拟机并在网络方面未作更改由虚拟机自动生成ip地址时,虚拟机的ip地址是处于动态变化的,每次开启都会再随机生成一个新的ip;这不利于我们通过其他设备远程连接该虚拟机,这时候需要我们将虚拟机设置为静态路由,通过网络配置可自行定义ip地址,确保稳定连接。

2. 虚拟机设置

a. 确认NAT连接模式

b. 查看子网地址

记住这个子网地址 " 192.168.142.0"

获取管理员权限,点击"更改设置"

点击 "NAT设置"

看到这个网关地址,记住 "192.168.142.2"

3. 设置静态ip

进入虚拟机

a. 打开虚拟机的配置文件

复制代码
vi /etc/sysconfig/network-scripts/ifcfg-ens33

编辑内容如下:

BOOTPROTO=static

将BOOTPROTO字段修改为static(静态模式),即使用静态的IP地址

IPADDR字段表示该网卡的IP地址

只要与子网IP处于同一个网段即可,可以处于192.168.142.0~192.168.142.255。

NETMASK表示子网掩码,GATEWAY表示网关,需要根据虚拟机的网络配置即可。看上图。

DNS表示域名解析器地址,是固定的。

b. 重启网卡

复制代码
systemctl  restart network

c. 查看网络连接

ping www.baidu.com

相关推荐
周洲083010 分钟前
STM32片内Flash读写深度详解|掉电参数保存、底层原理
linux·前端·stm32
数字供应链安全产品选型19 分钟前
智能体与代码安全一体化选型指南:跳出功能清单,以运行时硬指标衡量真实防护能力
网络·人工智能
shimly12345622 分钟前
比 find + grep 更好用的 nm + addr2line
linux
迷途之人不知返23 分钟前
【进程控制】-3-进程等待
linux
ycvv1 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup1 小时前
包管理器和vim
linux·服务器
ESDWAN1 小时前
SD-WAN 企业选型与落地指南:从链路测试到网络架构设计
运维·网络·架构
一颗小树x1 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
_smart_boy__1 小时前
I.MX6U开发板Uboot无法ping Ubuntu问题解决方案(二)
linux·运维·ubuntu
DianSan_ERP1 小时前
多平台订单自动下载与回传的技术实现:从消息推送到状态闭环引言
java·linux·服务器·前端·网络·架构·自动化