nginx导致的返回内容缺少

问题描述:

在个人电脑执行curl后返现接口仅返回部分内容,出参感觉被截取少了一部分;但是在服务所在机器上直接执却发现能返回完整信息

后来就了解到,个人电脑和服务器电脑的差别是是否走了nginx,所以出问题的地方可能是nginx

nginx的错误日志如下:

2024/04/16 11:43:41 crit 29434#0: *550562 open() "/opt/nginx/proxy_temp/1/29/0000000291" failed (13: Permission denied) while reading upstream, client: 10.14.168.15, server: 10.14.250.23, request: "GET /api/coursewareInfoByIdCnum?id=93f63bb7ecbc4c498b889fcfa90d7c37&cnum=19 HTTP/1.1", upstream: "http://127.0.0.1:11121/api/coursewareInfoByIdCnum?id=93f63bb7ecbc4c498b889fcfa90d7c37\&cnum=19", host: "10.14.250.23"

然后查看nginx的配置发现,nginx进程对应的用户是普通用户beibo,路径/opt/nginx/proxy_temp是属于root用户的,

执行如下指令,将/opt/nginx/proxy_temp的所有者修改为beibo

sudo chown -R beibo /opt/nginx/proxy_temp

然后重新执行对应的curl,出参完整,解决问题。

原因分析:

nginx存在一个buffer的机制,在返回数据过大超出缓存区的最大容量时,会将数据写入临时文件,而此时如果安装nginx的用户权限对该目录没有权限,就会报没权限的问题,所以在返回数据时,超出缓存区的数据将丢失,出现截断。所以将nginx的目录赋予权限就可以了

参考:

nginx 返回数据被截断_nginx使网参数被自动截断-CSDN博客

https://blog.51cto.com/u_39037/10073798

相关推荐
lpfasd1232 天前
WinSW在Win7上失败真相-实测与修复
windows·nginx
lpfasd1232 天前
nginx服务化五套方案原理解剖与选型
运维·nginx
ue星空2 天前
ALS V4 中文拆解手册
运维·nginx
吴声子夜歌3 天前
Nginx应用与运维——Nginx集群负载与配置管理(二)
运维·nginx
cpolar技术支持3 天前
外网测试机的异常传不回内网?自托管 Sentry,用 cpolar 打通错误上报链路
python·nginx·docker·cpolar·sentry
吴声子夜歌3 天前
Nginx应用与运维——Nginx在Kubernetes中的应用(一)
运维·nginx·kubernetes
螺蛳粉 螺蛳粉3 天前
第一篇:Keepalived 高可用实战:VIP 漂移与 Nginx 主备切换完整指南
运维·nginx·负载均衡·keepalived·高可用
吴声子夜歌3 天前
Nginx应用与运维——Nginx在Kubernetes中的应用(三)
运维·nginx·kubernetes
吴声子夜歌3 天前
Nginx应用与运维——Nginx在Kubernetes中的应用(二)
运维·nginx·kubernetes
Wang's Blog3 天前
Java 项目实战: 外卖平台优化-Nginx配置文件结构与块层级
java·开发语言·nginx