Anagrams

描述

Most crossword puzzle(猜字谜) fans are used to anagrams(字谜) --groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams( 变位词*)*, an example is QUIZ.

Obviously such definitions depend on the domain(领域) within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes arelative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

输入

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines(跨行中断). Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

输出

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic(字典式的) (case-sensitive) order. There will always be at least one relative ananagram.

样例输入
复制代码
ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#
样例输出
复制代码
Disk
NotE
derail
drIed
eye
ladder
soon

思路

用到两种数据结构map和set,map存入单词(在转换为小写且按照字母升序顺序后),set存入输入的单词

code

复制代码
#define _CRT_SECURE_NO_WARNINGS 1
#include<iostream>
#include<map>
#include<string>
#include<algorithm>
#include<set> 
#include<sstream>
using namespace std;

int main()
{
    string input;
    map<string, int> mp;
    set<string> st;
    while (getline(cin, input) && input != "#") {
        istringstream is(input);
        string word;
        while (is >> word) {
            string word1 = word;
            transform(word1.begin(), word1.end(), word1.begin(), ::tolower);//将单词转换为小写
            sort(word1.begin(), word1.end());
            mp[word1]++;
            st.insert(word);
        }
    }
    for (set<string>::iterator iter = st.begin(); iter != st.end(); iter++) {
        string temp = *iter;
        transform(temp.begin(), temp.end(), temp.begin(), ::tolower);
        sort(temp.begin(), temp.end());
        if (mp[temp] == 1) {
            cout << *iter << endl;
        }
    }
    return 0;
}
相关推荐
大家都说我身材好4 天前
如何优化字符串替换:四种实现方案对比与性能分析
java·字符串
carpell16 天前
【双指针法】:这么常用的你怎么能不知道
python·链表·字符串·数组·双指针法
Tisfy17 天前
LeetCode 2843.统计对称整数的数目:字符串数字转换
算法·leetcode·字符串·题解
G皮T24 天前
【Python Cookbook】字符串和文本(五):递归下降分析器
数据结构·python·正则表达式·字符串·编译原理·词法分析·语法解析
longyitongxue25 天前
洛谷 - B4276 [蓝桥杯青少年组国赛 2023] 八进制回文平方数 - 题解
字符串·转进制
ゞ 正在缓冲99%…25 天前
leetcode76.最小覆盖子串
java·算法·leetcode·字符串·双指针·滑动窗口
G皮T1 个月前
【Python Cookbook】字符串和文本(二)
数据结构·python·算法·字符串
G皮T1 个月前
【Python Cookbook】字符串和文本(一)
python·正则表达式·字符串·查找
daily_23331 个月前
coding ability 展开第四幕(滑动指针——巩固篇)超详细!!!!
c++·算法·字符串·哈希算法·滑动窗口
Tisfy1 个月前
LeetCode 2272.最大波动的子字符串:转为多次的最大子数组和 - 一步步思考推导
算法·leetcode·动态规划·字符串·题解