Anagrams

描述

Most crossword puzzle(猜字谜) fans are used to anagrams(字谜) --groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams( 变位词*)*, an example is QUIZ.

Obviously such definitions depend on the domain(领域) within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes arelative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

输入

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines(跨行中断). Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

输出

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic(字典式的) (case-sensitive) order. There will always be at least one relative ananagram.

样例输入
ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#
样例输出
Disk
NotE
derail
drIed
eye
ladder
soon

思路

用到两种数据结构map和set,map存入单词(在转换为小写且按照字母升序顺序后),set存入输入的单词

code

#define _CRT_SECURE_NO_WARNINGS 1
#include<iostream>
#include<map>
#include<string>
#include<algorithm>
#include<set> 
#include<sstream>
using namespace std;

int main()
{
    string input;
    map<string, int> mp;
    set<string> st;
    while (getline(cin, input) && input != "#") {
        istringstream is(input);
        string word;
        while (is >> word) {
            string word1 = word;
            transform(word1.begin(), word1.end(), word1.begin(), ::tolower);//将单词转换为小写
            sort(word1.begin(), word1.end());
            mp[word1]++;
            st.insert(word);
        }
    }
    for (set<string>::iterator iter = st.begin(); iter != st.end(); iter++) {
        string temp = *iter;
        transform(temp.begin(), temp.end(), temp.begin(), ::tolower);
        sort(temp.begin(), temp.end());
        if (mp[temp] == 1) {
            cout << *iter << endl;
        }
    }
    return 0;
}
相关推荐
一直学习永不止步8 天前
LeetCode题练习与总结:验证 IP 地址--468
java·数据结构·tcp/ip·算法·leetcode·职场和发展·字符串
Linux运维技术栈8 天前
Python字符串及正则表达式(十):字符串常用操作、字符串编码转换
开发语言·python·字符串
记录无知岁月1 个月前
【MATLAB】续行符号对字符串失效
matlab·字符串·技巧·续行
一直学习永不止步1 个月前
LeetCode题练习与总结:最长回文串--409
java·数据结构·算法·leetcode·字符串·贪心·哈希表
寻找码源1 个月前
【头歌实训:利用kmp算法求子串在主串中不重叠出现的次数】
c语言·数据结构·算法·字符串·kmp
—Miss. Z—1 个月前
C语言中用指针输入字符串
c语言·字符串·指针
一直学习永不止步1 个月前
LeetCode题练习与总结:至少有 K 个重复字符的最长子串--395
java·算法·leetcode·字符串·滑动窗口·哈希表·分治
AnFany1 个月前
LeetCode【0028】找出字符串中第一个匹配项的下标
python·算法·leetcode·字符串·kmp·字符串匹配
一直学习永不止步2 个月前
LeetCode题练习与总结:迷你语法分析器--385
java·数据结构·算法·leetcode·字符串··深度优先搜索
许野平2 个月前
Rust: 利用 chrono 库实现日期和字符串互相转换
开发语言·后端·rust·字符串·转换·日期·chrono