Anagrams

描述

Most crossword puzzle(猜字谜) fans are used to anagrams(字谜) --groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams( 变位词*)*, an example is QUIZ.

Obviously such definitions depend on the domain(领域) within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes arelative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

输入

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines(跨行中断). Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

输出

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic(字典式的) (case-sensitive) order. There will always be at least one relative ananagram.

样例输入
ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#
样例输出
Disk
NotE
derail
drIed
eye
ladder
soon

思路

用到两种数据结构map和set,map存入单词(在转换为小写且按照字母升序顺序后),set存入输入的单词

code

#define _CRT_SECURE_NO_WARNINGS 1
#include<iostream>
#include<map>
#include<string>
#include<algorithm>
#include<set> 
#include<sstream>
using namespace std;

int main()
{
    string input;
    map<string, int> mp;
    set<string> st;
    while (getline(cin, input) && input != "#") {
        istringstream is(input);
        string word;
        while (is >> word) {
            string word1 = word;
            transform(word1.begin(), word1.end(), word1.begin(), ::tolower);//将单词转换为小写
            sort(word1.begin(), word1.end());
            mp[word1]++;
            st.insert(word);
        }
    }
    for (set<string>::iterator iter = st.begin(); iter != st.end(); iter++) {
        string temp = *iter;
        transform(temp.begin(), temp.end(), temp.begin(), ::tolower);
        sort(temp.begin(), temp.end());
        if (mp[temp] == 1) {
            cout << *iter << endl;
        }
    }
    return 0;
}
相关推荐
一直学习永不止步5 小时前
LeetCode题练习与总结:赎金信--383
java·数据结构·算法·leetcode·字符串·哈希表·计数
△曉風殘月〆21 天前
C#与C++进行互操作时字符串处理的一些问题
开发语言·c++·c#·字符串·p/invoke
一直学习永不止步1 个月前
LeetCode题练习与总结:单词规律--290
java·数据结构·算法·leetcode·职场和发展·字符串·哈希表
碳苯1 个月前
【rCore OS 开源操作系统】Rust 字符串(可变字符串String与字符串切片&str)
开发语言·rust·操作系统·字符串·os·内存安全
IT规划师1 个月前
C#|.net core 基础 - 删除字符串最后一个字符的七大类N种实现方式
c#·.netcore·字符串·字符
闻缺陷则喜何志丹1 个月前
【C++差分数组】2381. 字母移位 II|1793
c++·算法·字符串·力扣·差分数组·移位·方向
Tisfy1 个月前
LeetCode 2207.字符串中最多数目的子序列:计数
算法·leetcode·字符串·题解·思维·计数
蟹至之2 个月前
字符串函数的使用与模拟(2)——C语言内存函数
c语言·字符串·指针·内存函数
Tisfy2 个月前
LeetCode 2414.最长的字母序连续子字符串的长度:一次遍历
算法·leetcode·字符串·题解·遍历