解决生产环境突然报错“Kibana server is not ready yet‘’

问题描述:

在生产环境上用docker-compose部署好ElasticSearch 和Kibana后(ElasticSearch基础用法-CSDN博客),Kibana上进行数据的增、删、改、查很是方便,但突然有一天在浏览器上打开kibana地址,提示'Kibana server is not ready yet''。

问题定位:

确定ElasticSearch服务是否正常:ElasticSearch服务正常,因为接口访问ES正常,日志未看到明显报错。

kibana的日志发现报错:.kibana_task_manager] Action failed with 'search_phase_execution_exception'

bash 复制代码
kibana_1             | {"type":"log","@timestamp":"2024-04-28T03:43:34+00:00","tags":["error","savedobjects-service"],"pid":1214,"message":"[.kibana_task_manager] Action failed with 'search_phase_execution_exception: '. Retrying attempt 6 in 64 seconds."}

问题解决:

尝试重启kibana服务未解决;

尝试依次重启ElasticSearch、Kibana未解决;

根据网上的办法,删除掉kibana索引后,重新创建Kibana服务并启动,问题解决。

bash 复制代码
# 删除 .kibana_task_manager_1 索引:
curl  -XDELETE http://localhost:9200/.kibana_task_manager_1
# 删除所有以 .kibana 开头的索引:
curl -X DELETE http://localhost:9200/.kibana*
# 停止并删除kibana服务容器
docker-compose stop kibana
docker-compose rm kibana
# 重新创建并启动kibana服务
docker-compose up -d kibana

目前为止,造成该问题的原因不确定,大概率是因为ES服务异常退出导致。

相关推荐
不会就选b1 天前
Linux之TCP理论<1>
linux·运维·服务器
倔强的石头1061 天前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言
Android系统攻城狮1 天前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
_upupup1 天前
Linux中的自动化构建——make/Makefile
linux·运维·自动化
还卿一钵无情泪1 天前
Docker 部署Unsloth 绕开环境配置难题
运维·人工智能·docker·ai·容器·nlp·干货
打工仔折腾 AI1 天前
Docker镜像分层与卷挂载到底怎么工作:一次文件系统层面的实测分析
运维·人工智能·后端·python·docker·容器·性能优化
大猫会长1 天前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
夜之眷属1 天前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
极客先躯1 天前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
韩振方1 天前
为什么服务显示占了 8G,实际内存却没那么多?
运维