服务器关机前未退出xampp导出MySQL无法启动

背景解决

五一放假,服务器关机了,但是关机前没有正常关闭数据库服务,导致数据库无法启动!

查看错误日志如下

从报错信息可以看出是MySQL这个服务相关文件出现问题了,解决思路:重新安装xampp

重新安装xampp

  • 备份(重命名)以前xampp的安装目录,恢复数据时用得到,千万别删了!!!
  • 启动mysql服务,验证重新安装xampp后MySQL能够正常启动

恢复数据

  • 停止mysql服务
  • 拷贝原有业务使用的数据库文件夹到新安装的xampp对应的位置
  • 启动后台服务会报错Table 'xxx' doesn't exist in engine
  • 启动apache和MariaDB,进入apache的admin,在浏览器中找到phpadmin,进入对应的数据和表,也会报错#1932 - Table 'xxx' doesn't exist in engine

Table 'xxx' doesn't exist in engine报错原因及解决办法

原因

这是因为原数据库使用的是innodb索引,还需要拷贝ibdata1文件到对应的位置

解决办法

拷贝ibdata1文件到对应的位置,重新启动数据库服务即可!

相关推荐
ai小陈8 小时前
GPU服务器租用存储验收:检查点写入与磁盘吞吐实战
运维·服务器·人工智能·ai·ssh·gpu算力
FPGA小徐10 小时前
PA1 基础设施(2)深度解析:NEMU 中 ITRACE、MTRACE、FTRACE、IRINGBUF、ETRACE、DIFFTEST 全解析
java·服务器·网络
有毒的教程10 小时前
VMware仅主机模式:物理机 ↔ 虚拟机 文件共享
运维
java1234_小锋10 小时前
【技术专题】Mysql8 数据库 - Mysql8 数据类型简介
数据库·mysql
知行EDI11 小时前
知行之桥 MaBang 端口使用指南——Create Order 订单创建篇
java·服务器·数据库
成旭先生11 小时前
【2026】企业信息模糊查询 API 实战:名称、注册号、统一社会信用代码、企业类型与法人一次查全
服务器·数据库·数据服务
JosieBook11 小时前
【数据库】MySQL 实战精通系列 · 第10篇:分库分表与分布式事务实战
数据库·分布式·mysql
山岚的运维笔记13 小时前
ComfyUI NVIDIA安装教程:官方便携版下载+run_nvidia_gpu.bat启动,8G显存Windows实操
运维·服务器·windows·笔记·prompt·aigc·comfyui
海宇大数据13 小时前
零信任架构实战:基于海宇活体识别V步骤1构建自动化远程公证会话初始化网关
运维·人工智能·架构·自动化
꯭自꯭闭꯭13 小时前
DM7主备升级方案
linux·服务器·数据库