docker迁移根目录导致的权限问题

项目场景:

起因是docker默认安装的根目录,空间不太够了,需要迁移


问题描述

按照迁移的步骤,将文件 cp -rf到新路径之后修改data-root路径,然后重启docker,看起来一切正常。


原因分析:

观察一会发现,一个之前的elastic容器不停重启,报错:

docker-entrypoint.sh: line 84: cannot create temp file for here-document: Permission denied ,

尝试给容器授权,目录授权,均未解决。然后发现别的容器也有权限问题,怀疑是迁移过程中的问题。


解决方案:

经过查找资料,发现也有人碰到类似的问题,解决方法有两种,1、使用rsync把目录和权限都迁过来,2、使用cp -rp 命令,拷贝的时候带上权限。

我采用的是第二种方案,启动正常

相关推荐
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS1 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏1 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心1 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing1 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅1 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)1 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang1 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren1 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github