docker迁移根目录导致的权限问题

项目场景:

起因是docker默认安装的根目录,空间不太够了,需要迁移


问题描述

按照迁移的步骤,将文件 cp -rf到新路径之后修改data-root路径,然后重启docker,看起来一切正常。


原因分析:

观察一会发现,一个之前的elastic容器不停重启,报错:

docker-entrypoint.sh: line 84: cannot create temp file for here-document: Permission denied ,

尝试给容器授权,目录授权,均未解决。然后发现别的容器也有权限问题,怀疑是迁移过程中的问题。


解决方案:

经过查找资料,发现也有人碰到类似的问题,解决方法有两种,1、使用rsync把目录和权限都迁过来,2、使用cp -rp 命令,拷贝的时候带上权限。

我采用的是第二种方案,启动正常

相关推荐
print_Hyon3 分钟前
【ENSP】DHCP 基础实验(路由器作为 DHCP 服务器,接口地址池模式)
运维·服务器·智能路由器
张小凡vip11 分钟前
Kubernetes--k8s---了解和使用 ServiceAccount
容器·贪心算法·kubernetes
程序员-Benothing12 分钟前
正则表达式详解:BRE、ERE、PCRE语法与实战案例
linux·运维·服务器
软件架构师-叶秋12 分钟前
V853方案之ubuntu开发环境搭建
linux·运维·服务器·全志·v853
yt004yt19 分钟前
园区绿岛 VOC 治理,能碳一体化系统设计思路分享
大数据·运维
码士集团小青24 分钟前
美团Tabbit实测:免费用GPT-5.5和Claude Opus 4.8,浏览器Agent自动化到底能干什么
运维·gpt·自动化
zhangjw3433 分钟前
1-1 PostgreSQL 多平台环境部署:Linux|Docker|Windows|MacOS 完整实操
linux·docker·postgresql
流星白龙33 分钟前
【Docker】13.容器基本操作实战
运维·docker·容器
不会就选b11 小时前
Linux之TCP理论<1>
linux·运维·服务器
倔强的石头10612 小时前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言