docker迁移根目录导致的权限问题

项目场景:

起因是docker默认安装的根目录,空间不太够了,需要迁移


问题描述

按照迁移的步骤,将文件 cp -rf到新路径之后修改data-root路径,然后重启docker,看起来一切正常。


原因分析:

观察一会发现,一个之前的elastic容器不停重启,报错:

docker-entrypoint.sh: line 84: cannot create temp file for here-document: Permission denied ,

尝试给容器授权,目录授权,均未解决。然后发现别的容器也有权限问题,怀疑是迁移过程中的问题。


解决方案:

经过查找资料,发现也有人碰到类似的问题,解决方法有两种,1、使用rsync把目录和权限都迁过来,2、使用cp -rp 命令,拷贝的时候带上权限。

我采用的是第二种方案,启动正常

相关推荐
我叫洋洋15 分钟前
涂鸦 T5+ hashcat 自动化破解 WPA2:从单缺 M2 到全自动值守的踩坑实录 破解wifi 密码
运维·单片机·自动化
troy1281 小时前
K8s 平台测试清单:深度分析与实战指南
云原生·容器·kubernetes
꯭自꯭闭꯭7 小时前
达梦SQL优化相关
linux·运维·数据库·sql
ZhangJun958 小时前
在 32GB 内存电脑上本地搭建 Qwen3.6-35B-A3B 大模型踩坑实录
运维·人工智能·阿里云·ai·软件构建
一条破秋裤8 小时前
Linux 共享内存通信:POSIX 共享内存与 mmap
linux·运维·服务器
贵州山魈羡民8 小时前
【玩转手机】通过 Podroid 上的 Alpine 部署 1Panel,把微型服务器装进口袋
运维·服务器
小白的码BUG之路8 小时前
Docker -- 构建nacos镜像
运维·docker·容器
谷哥的小弟9 小时前
CentOS Stream浴火重生
linux·运维·centos
程序员-Benothing10 小时前
Shell输入输出详解:read、echo、printf、颜色输出
linux·运维·服务器
和裕10 小时前
全纸结构重型纸箱能否满足 1 吨以上设备出口熏蒸豁免要求?通关合规性全解析
大数据·运维·网络·人工智能·算法