docker迁移根目录导致的权限问题

项目场景:

起因是docker默认安装的根目录,空间不太够了,需要迁移


问题描述

按照迁移的步骤,将文件 cp -rf到新路径之后修改data-root路径,然后重启docker,看起来一切正常。


原因分析:

观察一会发现,一个之前的elastic容器不停重启,报错:

docker-entrypoint.sh: line 84: cannot create temp file for here-document: Permission denied ,

尝试给容器授权,目录授权,均未解决。然后发现别的容器也有权限问题,怀疑是迁移过程中的问题。


解决方案:

经过查找资料,发现也有人碰到类似的问题,解决方法有两种,1、使用rsync把目录和权限都迁过来,2、使用cp -rp 命令,拷贝的时候带上权限。

我采用的是第二种方案,启动正常

相关推荐
Ruiery8 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包9 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
MicrosoftCloud9 小时前
用户权限 04|/etc/sudoers 安全配置:从最小授权到「别把 ALL 随便给人」
运维·安全·ubuntu·sudo·sudoers
梦想不只是梦与想9 小时前
docker-compose.yml
docker·docker-compose·docker run
꯭自꯭闭꯭10 小时前
达梦事物特性及MVCC
linux·运维·数据库
亚川楼宇自控系统数据中心厂家12 小时前
实验室智能化管理系统|人环物智一体化管控平台
运维
zmsup13 小时前
Agent 上下文调优:结合 OpsArk 运维智能体,设计模型每一步真正需要的信息
运维·agent·上下文压缩·运维智能体·上下文调优
吴声子夜歌15 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng15 小时前
NRPE 添加命令(一)
linux·运维·服务器
pt104315 小时前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议