重置服务器之后 SSH 登录报错:REMOTE HOST IDENTIFICATION HAS CHANGED!

问题原因:

报错是由于远程的主机的公钥发生了变化导致的。ssh服务是通过公钥和私钥来进行连接的,它会把每个曾经访问过计算机或服务器的公钥(public key),记录在~/.ssh/known_hosts 中,当下次访问曾经访问过的计算机或服务器时,ssh就会核对公钥,如果和上次记录的不同,OpenSSH会发出警告。

解决方法:

输入下面的命令,xxx 代表服务器的公网 ip

复制代码
ssh-keygen -R xxx.xxx.xxx.xxx

再重新连接就可以了

复制代码
ssh root@xx.xxx.xx.xx

参考:

我是通过下面的文章找到解决方法的,原文分析的更详细

ssh连接报错:REMOTE HOST IDENTIFICATION HAS CHANGED问题解决https://blog.csdn.net/qq_30095921/article/details/136788209


记录自己的成长,也希望能帮助到大家少走弯路,期待你的点赞支持💫!

相关推荐
fengkai45453 小时前
十二、Redis -2
运维·数据库·redis·容器
哎呦,帅小伙哦3 小时前
进程监控工具——htop
linux·运维·服务器
深圳恒讯3 小时前
海外服务器延迟高怎么解决?从线路到TCP协议的6层排查清单
运维·服务器·tcp/ip
小羊没烦恼!4 小时前
jQuery1.5的改进细节
java·服务器·开发语言·前端·c#
北龙云海4 小时前
AI驱动数据库运维变革:北龙云海智能巡检平台实践与展望
运维·数据库·人工智能
AI职业加油站4 小时前
AI 校招现状:大模型应用工程师证书,助力简历能力证明
大数据·运维·人工智能·学习·职场发展
Lsetea5 小时前
curl报58 unable to set private key file:客户端证书与私钥加载排查
运维·https·ssl证书·openssl·curl
天远Date Lab5 小时前
零信任架构实战:基于天远学籍核验三要素构建自动化竞赛资格审查网关
运维·人工智能·架构·自动化
KING-WU5126 小时前
Linux 工具之Make 与 Makefile
java·linux·服务器
阿乔外贸日记6 小时前
全球电子产业高度集中:中、韩、日和中国台湾地区占全球数字硬件产能八成
大数据·服务器·人工智能·物联网·云计算