DBeaver连接MySQL提示Access denied for user ‘‘@‘ip‘ (using password: YES)


问题描述

客户端root账号连接mysql时,远程连接不上


原因分析:

1、mysql的服务状态

2、登录账号的host是否为%,允许远程任意地址连接

3、在需要密码登录的前提下:登录账号的host为%的密码是否设置


解决方案:

1、核实MySQL服务状态:

复制代码
systemctl status mysql

MySQL服务运行正常,若MySQL已经没有启动,重启MySQL服务器:

复制代码
systemctl restart mysql

2、从服务器登录进入数据库:

复制代码
bin/mysql -u root -p

输入密码登录进去后

3、授与权限,并更新权限:

复制代码
CREATE USER 'root'@'%' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION;

刷新:

复制代码
FLUSH PRIVILEGES;

4、查看结果是不是root用户仅允许本地 localhost 登录,是的话,就要修改它的host为%,表示任意IP地址都可以登录:

复制代码
use mysql;
select user, host from user;

可以看到root用户有一个%,代表全部主机都可以使用root用户通过外网连接数据库,但是连接依然出现问题Access denied for user 'root'@'ip' (using password: YES)

5、root账号的任意地址登录的密码不对,在配置mysql的时候,遗留了host的%的密码调整为test@mysql,导致不对:

复制代码
ALTER USER 'root'@'%' IDENTIFIED WITH mysql_native_password BY 'test@mysql';

6、DBeaver连接,校验是否解决问题:

连接成功

相关推荐
JosieBook12 分钟前
【数据库】MySQL 实战精通系列 · 第10篇:分库分表与分布式事务实战
数据库·分布式·mysql
Zelman3 小时前
TCP 协议
网络协议·tcp/ip
做运维的阿瑞4 小时前
多表查询基础:INNER JOIN、LEFT JOIN、RIGHT JOIN
数据库·sql·mysql·算法
life码农4 小时前
Nginx 配置允许指定 IP 段访问:从 192.168.1.1 到 192.168.1.124 及 /24 详解
网络·tcp/ip·nginx
我就是不信6 小时前
TCP 原理详解:从三次握手到拥塞控制
网络·网络协议·tcp/ip
夜雪一千6 小时前
MySQL 中什么是条件注释
数据库·mysql
我就是不信6 小时前
TCP/IP 网络编程:从入门到实战
网络·网络协议·tcp/ip
暖核6 小时前
MySQL 高级运维核心:备份恢复、主从复制与 MHA 高可用复习总结
运维·数据库·mysql
晚风叙码8 小时前
MySQL 表的操作:从建表到删表,一篇讲清楚
android·mysql·oracle
paopaokaka_luck8 小时前
非遗文物数字化小程序(AI非遗问答、ONNX图像识别、协同过滤推荐、ECharts数据分析、非遗知识浏览与互动、文创商城订单闭环、文化活动报名签到、社区交流)
javascript·spring boot·mysql·数据分析·echarts·mybatis