jenkins docker配置方法

  1. 搜索docker可以下载镜像

    bash 复制代码
    # 找STARS数高的进行下载 和 是 OFFICIAL官方的下载
    [root@leisure docker]# docker search jenkins 
    # 输出
    NAME                           DESCRIPTION                                     STARS     OFFICIAL
    jenkins                        DEPRECATED; use "jenkins/jenkins:lts" instead   5692      [OK]
    jenkins/jenkins                The leading open source automation server       3924      
    jenkins/inbound-agent          This is an image for Jenkins agents using TC...   133       
  2. 拉取镜像

    bash 复制代码
    [root@leisure docker]# docker pull jenkins/jenkins:lts
  3. 运行镜像:

    bash 复制代码
    # 运行过程中会给你输出对应密码,需要记住这个密码方便第一次使用
    docker run --name jenkins \
    	-p 80:8080 \
    	-p 50000:50000 \
    	--restart=on-failure \
    	-v /srv/jenkins/jenkins_home:/var/jenkins_home \
    	jenkins/jenkins:lts
    
    # 运行没有问题后就可以使用ctrl + c 结束容器运行
  4. 解决权限问题:

    bash 复制代码
    # 在创建容器的过程中可能你数据卷的other的权限没有rwx,导致容器不能映射对应数据。
    # 可以使用下面命令将 数据卷全部的权限都给了,如果你清楚知道这个数据卷需要什么权限,你可以单独设置
    [root@leisure ~]# chmod -R ugo+rwx /srv/jenkins/
  5. 运行jenkins容器:

    bash 复制代码
    [root@leisure /]# docker start jenkins
  6. 查看jenkins初始密码:

    bash 复制代码
    # 初始密码只能登录一次,登录一次后就会被自动删除。
    [root@leisure /]# cat /srv/jenkins/jenkins_home/secrets/initialAdminPassword 
    7e8d0a2d4e96400ab0d284704ae89d67
  7. 访问jenkins:

    bash 复制代码
    # 浏览器网址上输入下面内容:192.168.2.244 是linux的ip地址。
    192.168.2.244:80

问题

1 复制的docker run数据错误

  1. 错误表现:在入职运行docker run jenkins的一些列命令时,出现了其他的数据。

    bash 复制代码
    [root@leisure docker]# docker run --name jenkins \
    > daemon.json -d \
    > daemon.json -p 8080:8080 \
    > daemon.json -p 50000:50000 \ 
    Unable to find image 'daemon.json:latest' locally
  2. 错误原因:应为当前目录有一个daemon.json文件。

  3. 解决办法 :移动到家目录执行命令就可以了

2 再次创建jenkins发现没有初始密码

  1. 问题原因:没有删除数据卷
  2. 结局方法:删除数据卷
相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS4 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站4 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心4 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing4 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
羑悻的小杀马特5 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作