jenkins docker配置方法

  1. 搜索docker可以下载镜像

    bash 复制代码
    # 找STARS数高的进行下载 和 是 OFFICIAL官方的下载
    [root@leisure docker]# docker search jenkins 
    # 输出
    NAME                           DESCRIPTION                                     STARS     OFFICIAL
    jenkins                        DEPRECATED; use "jenkins/jenkins:lts" instead   5692      [OK]
    jenkins/jenkins                The leading open source automation server       3924      
    jenkins/inbound-agent          This is an image for Jenkins agents using TC...   133       
  2. 拉取镜像

    bash 复制代码
    [root@leisure docker]# docker pull jenkins/jenkins:lts
  3. 运行镜像:

    bash 复制代码
    # 运行过程中会给你输出对应密码,需要记住这个密码方便第一次使用
    docker run --name jenkins \
    	-p 80:8080 \
    	-p 50000:50000 \
    	--restart=on-failure \
    	-v /srv/jenkins/jenkins_home:/var/jenkins_home \
    	jenkins/jenkins:lts
    
    # 运行没有问题后就可以使用ctrl + c 结束容器运行
  4. 解决权限问题:

    bash 复制代码
    # 在创建容器的过程中可能你数据卷的other的权限没有rwx,导致容器不能映射对应数据。
    # 可以使用下面命令将 数据卷全部的权限都给了,如果你清楚知道这个数据卷需要什么权限,你可以单独设置
    [root@leisure ~]# chmod -R ugo+rwx /srv/jenkins/
  5. 运行jenkins容器:

    bash 复制代码
    [root@leisure /]# docker start jenkins
  6. 查看jenkins初始密码:

    bash 复制代码
    # 初始密码只能登录一次,登录一次后就会被自动删除。
    [root@leisure /]# cat /srv/jenkins/jenkins_home/secrets/initialAdminPassword 
    7e8d0a2d4e96400ab0d284704ae89d67
  7. 访问jenkins:

    bash 复制代码
    # 浏览器网址上输入下面内容:192.168.2.244 是linux的ip地址。
    192.168.2.244:80

问题

1 复制的docker run数据错误

  1. 错误表现:在入职运行docker run jenkins的一些列命令时,出现了其他的数据。

    bash 复制代码
    [root@leisure docker]# docker run --name jenkins \
    > daemon.json -d \
    > daemon.json -p 8080:8080 \
    > daemon.json -p 50000:50000 \ 
    Unable to find image 'daemon.json:latest' locally
  2. 错误原因:应为当前目录有一个daemon.json文件。

  3. 解决办法 :移动到家目录执行命令就可以了

2 再次创建jenkins发现没有初始密码

  1. 问题原因:没有删除数据卷
  2. 结局方法:删除数据卷
相关推荐
网硕互联的小客服2 小时前
Linux服务器磁盘应该如何合理分区?
linux·运维·服务器
楚识科技2 小时前
合同比对全流程自动化:OCR识别+差异比对+法律风险字段抽取实战指南
运维·自动化·ocr
代码方舟2 小时前
零信任架构实战:基于天远人企关联构建自动化供应链金融网关
运维·人工智能·架构·自动化
贵沫末3 小时前
Ubuntu——常用软件安装
linux·运维·ubuntu
Doraemomo4 小时前
Linux内核驱动开发——中断与定时器
linux·运维·驱动开发
2301_808414384 小时前
Linux中动静态库的理解
linux·运维·服务器
誰能久伴不乏4 小时前
保姆级 Docker 入门教程
docker·容器·eureka
分布式存储与RustFS4 小时前
模型 checkpoint 放对象存储:分片上传、断点续传与残留清理
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
一条破秋裤6 小时前
Linux 线程创建:pthread_create 与基本回收
java·linux·运维
FED_AF8 小时前
Linux运维“邪修”功法之通配符
linux·运维