dial tcp 10.96.0.1:443: connect: no route to host

1、创建Pod一直不成功,执行kubectl describe pod runtime-java-c8b465b98-47m82

查看报错

Warning FailedCreatePodSandBox 2m17s kubelet Failed to create pod sandbox: rpc error: code = Unknown desc = failed to setup network for sandbox "132760792eed7007c26a041da36c15406e582ced36e4ab6e7b6ce780ace1d2ee": plugin type="calico" failed (add): error getting ClusterInformation: Get "https://10.96.0.1:443/apis/crd.projectcalico.org/v1/clusterinformations/default": dial tcp 10.96.0.1:443: connect: no route to host

Normal SandboxChanged 2s (x11 over 2m16s) kubelet Pod sandbox changed, it will be killed and re-created.

2、解决办法

可能是 iptables 规则乱了

systemctl stop kubelet

iptables --flush

iptables -tnat --flush

systemctl start kubelet

相关推荐
Eminem894 天前
14、k8s持久化存储
k8s
上火的金鱼妹6 天前
higress网关访问+ 模型访问的安全策略管控
k8s·higress·ai网关
weixin_444579306 天前
Containerd
容器·k8s
Dragon_qu·x8 天前
MongoDB 高可用集群部署
运维·数据库·mongodb·k8s·helm
此冬歌咏14 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心15 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
流烟默15 天前
K8s StatefulSet 详解:有状态应用的“身份证”与“固定住址”
k8s·statefulset
cg.family15 天前
K8S集群手动巡检
k8s
九皇叔叔15 天前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
九皇叔叔16 天前
K8S 资源菜单
docker·容器·kubernetes·k8s