Navicat连接服务器MySQL

    • [1. Navicat连接服务器MySQL](#1. Navicat连接服务器MySQL)
    • [2. 如何查看MySQL用户名和密码](#2. 如何查看MySQL用户名和密码)
    • [3. 修改MySQL登录密码](#3. 修改MySQL登录密码)
    • [4. 安装MySQL(Centos7)](#4. 安装MySQL(Centos7))
    • 遇到错误和问题
      • [1. error 1045 (28000): access denied for user 'root'@'localhost' (using password:yes)](#1. error 1045 (28000): access denied for user 'root'@'localhost' (using password:yes))


  1. 选择数据库

    直接使用第一个MySQL即可。我也不知道这个腾讯云版的区别在哪,我用的就是这个,表面和普通的没看出什么区别。

  2. 常规设置

  3. SSH设置

    设置ssh通道会使得操作数据库时,保证数据传输的安全...

  4. 最终效果

2. 如何查看MySQL用户名和密码

① 输入命令mysql --uroot --p,然后输入密码直接回车

② 然后再输入use mysql

③ 输入SQL语句select host,user from mysql.user;

附图:

3. 修改MySQL登录密码

  1. 修改my.cnf文件

    ① 输入命令vim /etc/my.cnf

    ② 然后在mysqld后面添加skip-grant-tables

    ③ 保存退出(Esc + :wq)

    附图:

  2. 重启MySQL服务

    ① 输入命令sudo systemctl restart mysqld

  3. 选择数据库

    ① 输入命令mysql

    ② 然后再输入use mysql

    ③ 最后输入exit退出mysql

    附图:

  4. 修改密码

    ① 输入命令mysql --uroot --p,不输入密码直接回车

    ② 输入SQL语句set password for root@localhost = password('自己要更改的密码');

    如果出现该错误:

    ERROR 1290 (HY000): The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement

    解决方法:

    1)输入命令flush privileges;

    2)再次输入命令set password for root@localhost = password('自己要更改的密码');

    ③ 设置远程访问,输入SQL语句GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'password' WITH GRANT OPTION;

    ④ 输入命令flush privileges;再次刷新

    ⑤ 最后输入exit退出mysql

    附图:

  5. 还原my.cnf文件

    ① 输入命令vim /etc/my.cnf

    ② 去掉(或者注释掉)mysqld后面添加的skip-grant-tables

    ③ 保存退出(Esc + :wq)

4. 安装MySQL(Centos7)

repo文件是什么?

repo文件是Fedora中yum源(软件仓库)的配置文件,通常一个repo文件定义了一个或者多个软件仓库的细节内容,例如我们将从哪里下载需要安装或者升级的软件包,repo文件中的设置内容将被yum读取和应用。

  1. 下载repo文件

    shell 复制代码
    [root@VM-4-2-centos ~]# wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm 
  2. 安装已下载的rpm包

    shell 复制代码
    [root@VM-4-2-centos ~]# rpm -ivh mysql-community-release-el7-5.noarch.rpm
  3. 安装mysql

    shell 复制代码
    [root@VM-4-2-centos ~]# yum install mysql-server
  4. 安装mysql开发包

    shell 复制代码
    [root@VM-4-2-centos ~]# sudo yum install mysql-devel

遇到错误和问题

1. error 1045 (28000): access denied for user 'root'@'localhost' (using password:yes)

导致的原因:

(1) mysqld的服务器停止。重启一下MySQL服务器(systemctl restart mysqld)

(2) 用户的端口号或者IP导致错误。若用户的端口号与IP(3306/3307)不一致,打开my.ini文件进行编辑。全部编辑替换为port=X

(3) mysqld的配置文件错误

(4) root用户的密码错误

先看(1)和(2)解决方法,都不行直接修密码吧,大概率是密码问题。


end.

相关推荐
qq_543447828 分钟前
DNS解析怎么排查?故障处理与运维实用手册
运维·服务器·网络·php
DeviceHub10 分钟前
AI服务器电源设计进阶:TLVR电感的应用解析与选型验证指南
运维·服务器·人工智能
Apipi*11 分钟前
30天速通Linux 第七章进程间通信
linux·运维·服务器
emo_2b20 分钟前
Pycharm配置conda解释器时遇到的问题及解决方法
linux·pycharm·conda
极光通讯37 分钟前
服务器内存替代料选型方法论:主料号缺货时如何找到Pin-to-Pin兼容型号
运维·服务器
雨落在了我的手上1 小时前
MySQL数据库基础(6):增删改查操作(1)
数据库·mysql
人生百态,人生如梦1 小时前
Ubuntu在低版本下使用ccswitch+claudecode(CCSwitch+Docker+Claude)连调教程
linux·ubuntu·docker·claudecode·ccswitch
byte轻骑兵1 小时前
【BlueZ】hciconfig 工具:蓝牙适配器管理实操 + 源码实现基础
linux·bluez·电脑蓝牙·嵌入式蓝牙
ao-weilai1 小时前
MySQL数据库:用户管理
数据库·mysql·adb
SKH.1 小时前
Linux驱动-系统移植
linux·服务器