通过docker启动Jenkins容器报错

项目场景:

通过docker启动Jenkins容器


问题描述

Jenkins容器启动失败,通过sudo docker logs -f jenkins命令 查看日志如下:

复制代码
touch: cannot touch ‘/var/jenkins_home/copy_reference_file.log’: Permission denied Can not write to /var/jenkins_home/copy_reference_file.log. Wrong volume permissions?

原因分析:

访问copy_reference_file.log文件没有权限。

由于启动用户,和docker容器内部的用不一致导致的。

复制代码
因为当映射本地数据卷时,/opt/jenkins目录的拥有者为root用户,而容器中jenkins user的uid为1000

解决方案:

修改docker宿主机文件的权限。

我的目录映射关系为:

/opt/jenkins:/var/jenkins_home

所以我需要修改/opt/jenkins目录下的文件的所属用户及用户组。

复制代码
chown -R 1000:1000 /opt/jenkins
相关推荐
Zhu7583 分钟前
docker环境,vLLM 部署 Qwen3.8-27B
docker·qwen·vllm
溜达的大象10 分钟前
多台服务器不想上重型监控?用 Beszel 搭一套轻量主机与 Docker 看板
docker
2601_9538246111 分钟前
基于SSM的水果超市管理系统
java·tomcat·maven
guo_wen_qiang14 分钟前
springboot如何自定义一个启动器starter
java·spring boot·intellij-idea
许彰午18 分钟前
55-字典缓存与通知SPI
java·低代码·架构
captain37622 分钟前
HTTP(2)
java·网络·http·java-ee
徐子童24 分钟前
介绍MVCC机制
java·mysql·面试题·秋招·并发·mvcc
Wang's Blog25 分钟前
Java 项目实战: 外卖平台-启用禁用员工账号与Long精度丢失修复
java·服务器
乌暮30 分钟前
Java 抽象类与接口详解:半成品图纸 vs 能力合同
java·开发语言·后端·学习
一条泥憨鱼38 分钟前
苍穹外卖【day12| 工作台,通过Apache POI导入/导出运营数据】
java·后端·苍穹外卖