部署nginx服务用于浏览服务器目录并实现账号密码认证登录

1、背景:

因公司业务需求,部署一套数据库备份中心服务,但是因为备份的数据库很多,有项目经理要求能经常去查看备份数据库情况及下载备份数据文件的需求。根据该需求,需要在备份数据库的服务器上部署一个nginx服务,同时考虑安全性,需要加入用户密码登入的机制。

2、部署nginx服务:

安装nginx服务:

bash 复制代码
[root@idc-db-back ~]# yum install -y nginx
.......

检查nginx服务:

bash 复制代码
[root@idc-db-back ~]# rpm -qa | grep nginx
nginx-filesystem-1.20.1-10.el7.noarch
nginx-1.20.1-10.el7.x86_64

因为没有对nginx服务有版本的要求,所以直接yum方式安装即可。源码编译安装也可以的。

3、设置nginx服务配置文件内容:

bash 复制代码
[root@idc-db-back ~]# cd /etc/nginx/
[root@idc-db-back nginx]# vim nginx.conf

编辑nginx.conf文件后的内容如下:

bash 复制代码
[root@idc-db-back nginx]# cat nginx.conf

user nginx;
worker_processes auto;
error_log /var/log/nginx/error.log;
pid /run/nginx.pid;

include /usr/share/nginx/modules/*.conf;

events {
    worker_connections 1024;
}

http {
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  /var/log/nginx/access.log  main;

    sendfile            on;
    tcp_nopush          on;
    tcp_nodelay         on;
    keepalive_timeout   65;
    types_hash_max_size 4096;

    include             /etc/nginx/mime.types;
    default_type        application/octet-stream;

    include /etc/nginx/conf.d/*.conf;

    server {
        listen       80;
        server_name  localhost;
        
        location / {
      		root /etc/nginx/html;
		    index index.html index.htm;
	}
        location /backup {
            alias /back_db;
            autoindex on;
            autoindex_exact_size off;
            autoindex_localtime on;
        }

    }

}

因还要求访问nginx服务需要进行用户密码登入验证功能,所以还需要配置htpasswd参数。
在radhat 7系统上,可以通过安装httpd-tools软件包来获得htpasswd工具。执行以下命令来安装它:

bash 复制代码
[root@idc-db-back nginx]# yum install httpd-tools

完成安装后,可以使用以下命令来使用htpasswd工具创建账号密码文件:

bash 复制代码
[root@idc-db-back nginx]# htpasswd -c /etc/nginx/.htpasswd backup

该命令将提示您输入一个密码,并将账号密码保存在/etc/nginx/.htpasswd文件中。

将htpasswd运用到nginx中去:

bash 复制代码
    server {
        listen       80;
        server_name  localhost;

        # Load configuration files for the default server block.
        
        location / {
      		root /etc/nginx/html;
		    index index.html index.htm;
            auth_basic "Restricted html";
            auth_basic_user_file /etc/nginx/html/.htpasswd;

	}
        location /backup {
            alias /back_db;
            auth_basic "Restricted";
            auth_basic_user_file /etc/nginx/.htpasswd;
            autoindex on;
            autoindex_exact_size off;
            #autoindex_localtime on;
        }

    }

}

这里我加了两个密码认证,因为有一个首页的认证,

4、重启nginx服务:

完成配置后,使用以下命令重启Nginx以使更改生效:

bash 复制代码
[root@idc-db-back nginx]# systemctl restart nginx

检查nginx服务运行状态:

cpp 复制代码
[root@idc-db-back nginx]# netstat -anlp | grep nginx
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2532/nginx: master  
unix  3      [ ]         STREAM     CONNECTED     295616   2532/nginx: master   
unix  3      [ ]         STREAM     CONNECTED     295611   2532/nginx: master   

5、验证nginx服务功能:

在浏览器输入发布地址url

输入设置用户密码,即可

总结:到此就完成了nginx服务访问后端目录文件,并实现下载龚,同时具备了用户登入认证功能。

相关推荐
YoungStudyAI13 小时前
QA的下一个自动化阶段,可能不是再写更多脚本,而是设计测试Agent
运维·自动化
分布式存储与RustFS14 小时前
纠删码到底吃掉了多少容量:EC:4、EC:8 的利用率与容错怎么算
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
遇见小修修14 小时前
3步解决打印机0x00000709报错 ,广州深圳程序员可自行排查
运维·打印机·维修·打印机报错·打印机运维·打印机故障自查
Huangjin007_16 小时前
【Linux 系统篇(二十五)】文件(二) 系统文件I/O详解
linux·运维·服务器
2601_9623811316 小时前
历史视频朝代更替动效怎么做?把 AE 关键帧换成 AI 分镜动画的实战拆解
人工智能·nginx·音视频
微小冷16 小时前
Mermaid画甘特图
运维·markdown·甘特图·mermaid·时间图
LBL122017 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器
志栋智能18 小时前
超自动化巡检:驱动持续改进的运维飞轮
运维·自动化
海宇大数据18 小时前
零信任架构实战:基于海宇学历核验版构建自动化风控审查网关
运维·人工智能·架构·自动化
NailiConveyor18 小时前
输送机系统与WMS仓储管理系统集成的5个关键技术点
大数据·运维·自动化·制造·业界资讯