常见问题记录(持续更新)

备注:

在7月10日记录之前遇到的问题及解决方法:

一:常见的访问问题:

  1. 403 Forbidden :(未有请求权限)
    • 表示服务器理解请求但是拒绝执行它。这通常是由于服务器上的文件或资源没有正确的读、写或执行权限,或者是因为安全策略阻止了请求。
  2. 404 Not Found :(请求路径不对)
    • 服务器无法根据客户端的请求找到资源(例如,一个网页或文件)。最常见的情况是用户输入了错误的URL或者请求的资源已经被移动或删除。
  3. 405 Method Not Allowed :(请求方式不对)
    • 请求行中指定的方法不被允许用于请求的资源。例如,尝试对某个仅支持GET请求的资源执行POST操作。

关于nginx的配置:

以下是config文件:

#user nobody;

worker_processes 1;

error_log logs/error.log;

#error_log logs/error.log notice;

#error_log logs/error.log info;

#pid logs/nginx.pid;

events {

worker_connections 1024;

}

http {

include mime.types;

default_type application/octet-stream;

client_max_body_size 100m;

sendfile on;

keepalive_timeout 65;

upstream gateway {

server 127.0.0.1:9995;

}

server {

listen 9996;

server_name cdmz_server;

root E:\CDMZ_JUMP\jump_server\dist;

location / {

}

location ^~/api/ {

proxy_set_header Host $host;

proxy_set_header X-Real-IP $remote_addr;

proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

proxy_buffering off;

rewrite ^/api/(.*) /1 break;

proxy_pass http://gateway;

}

location ^~/blade-report/ {

proxy_set_header Host $host;

proxy_set_header X-Real-IP $remote_addr;

proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

proxy_buffering off;

proxy_pass http://gateway;

}

location ^~/ureport/ {

proxy_set_header Host $host;

proxy_set_header X-Real-IP $remote_addr;

proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

proxy_buffering off;

proxy_pass http://gateway;

}

}

}

9995端口是服务端口

9996用来代理:好处负载均衡,更安全

keepalive_timeout 65; 超时时间

client_max_body_size 100m; 文件上传100mb

window上命令查看防火墙开放的端口

这将列出所有配置的防火墙规则

netsh advfirewall firewall show rule name=all

二:低代码开发功能设计使用:

以一下自带的功能模块为例:

2.1功能设计:这个模块可以设计表单的页面,附带增删改查,分页,模糊查询,高级查询,且能根据数据字段灵活的展示想要的数据。的功能

2.2流程设计:改模块可以让发起的事项走流程,也就是相当有权限去审批事件

三,excel的常见功能用法:

3.1=VLOOKUP(L4,D:F,2,FALSE)

这个函数:根据L4的值去D-F查找,筛选第二列也就是E这个值,false是精准查找

3.2排序功能:

这样排出来的效果是:本人排在第一行,后面的也是他这一家人。

相关推荐
YH行业报告分析15 分钟前
2026电缆铺设设备市场:自动化敷设与电网升级驱动增长
运维·自动化
ajassi20001 小时前
AI语音智能体开发日记(十八)智能体服务器xiaozhi-esp32-server源码部署指南
运维·服务器·人工智能·ai·ai编程
‎ദ്ദിᵔ.˛.ᵔ₎1 小时前
linux 进程信号(下)
linux·运维·服务器
Mikko72 小时前
Linux 磁盘满了但 du 找不到?LVM 扩容 df 不变?fstab 写错开不了机?三台真机实测磁盘排查
linux·运维·centos
蓝胖的四次元口袋2 小时前
Jenkins知识梳理(2)
运维·jenkins
yumgpkpm2 小时前
Acceldata ODP 3.3.6.4 vs CDP Private Cloud Base 7.3.2 对比
大数据·运维·服务器·hadoop·华为·zookeeper·hbase
Liuqy-052 小时前
特殊进程——孤儿、僵尸、守护进程
linux·运维·服务器
等我调个Bug3 小时前
【Linux系统篇】权限
linux·服务器
考研保研资料分享3 小时前
自动化控制保研经验合辑:上交夏令营、北工大预推免与跨专业面试复盘(2025)
运维·面试·自动化
乐维_lwops3 小时前
2026选择运维监控系统时应该重点考察哪些功能?
大数据·运维·人工智能