[AWS]EKS启动HPA,HPA指标<unknown>,报错:error: Metrics API not available

背景:在AWS上创建的EKS集群,想要对于deployment部署HPA,来autoscling副本数。

1.HPA一般基于CPU或者内存对副本数进行控制,所以必须需要Metrics Server。

(Metrics Server 是 Kubernetes 集群的一个关键组件,它负责收集和提供节点和 Pod 的资源使用数据)

如何查看集群有无:Metrics Server

复制代码
kubectl get deployment metrics-server -n kube-system #检查 Metrics Server 状态:

如果没有Metrics Server,使用kubectl top会报错:

error: Metrics API not available

下载部署Metrics Server:

复制代码
kubectl apply -f https://github.com/kubernetes-sigs/metrics-server/releases/latest/download/components.yaml

2.部署HAP,yaml实例参考:

复制代码
apiVersion: autoscaling/v2
kind: HorizontalPodAutoscaler
metadata:
  name: "给hap取名字"
  namespace: "要部署到的命名空间"
spec:
  scaleTargetRef:
    apiVersion: apps/v1
    kind: Deployment
    name: "要控制的Deployment的名字"
  minReplicas: 2        #最小数
  maxReplicas: 8        #最大数
  metrics:
  - type: Resource
    resource:
      name: cpu
      target:
        type: Utilization
        averageUtilization: 70        #CPU 70%
  - type: Resource
    resource:
      name: memory
      target:
        type: Utilization
        averageUtilization: 80      #内存 80%

部署完成之后,使用命令:kubectl get hap -n 命名空间,就可以查看了。

报错:HPA指标<unknown>

这种情况是网上或者AI都会说得很复杂,七七八八的一大堆,其实原因很简单,就是你关联的deployment没有设置resource指标,只要在deployment.yaml中加上如下:

只需要requests字段就可以成功,不需要limit字段,重新部署之后可以看到<unknown>消失了。

不用尝试其他办法了,就是这个原因。

相关推荐
workflower3 小时前
AI system product quality model
大数据·人工智能·机器学习·云计算·无人机
workflower10 小时前
世界模型的内涵与发展
人工智能·机器人·云计算·无人机
姜鱼问生14 小时前
GitHub Actions CI/CD 从零搭建:push 后 60 秒自动上线
云计算·github
workflower16 小时前
从生成式模型开始的技术延伸
人工智能·机器学习·机器人·云计算·无人机
weixin_4352470616 小时前
医保影像云索引上传倒计时:历史数据“全量补传“的3个架构取舍
云计算
论文复现现场1 天前
AutoDL、算家云与公有云 GPU 怎么选?环境复现、计费与断点恢复对比
pytorch·深度学习·云计算·gpu
troy1281 天前
阿里云 vs 谷歌云:Kubernetes 部署深度对比分析
阿里云·kubernetes·云计算
johnny2331 天前
AWS系列之Glue
aws
workflower3 天前
世界模型向产业上游发掘的热点
人工智能·机器学习·机器人·云计算·无人机
范桂飓3 天前
AWS Agent Infra 架构分析
java·架构·aws