[AWS]EKS启动HPA,HPA指标<unknown>,报错:error: Metrics API not available

背景:在AWS上创建的EKS集群,想要对于deployment部署HPA,来autoscling副本数。

1.HPA一般基于CPU或者内存对副本数进行控制,所以必须需要Metrics Server。

(Metrics Server 是 Kubernetes 集群的一个关键组件,它负责收集和提供节点和 Pod 的资源使用数据)

如何查看集群有无:Metrics Server

复制代码
kubectl get deployment metrics-server -n kube-system #检查 Metrics Server 状态:

如果没有Metrics Server,使用kubectl top会报错:

error: Metrics API not available

下载部署Metrics Server:

复制代码
kubectl apply -f https://github.com/kubernetes-sigs/metrics-server/releases/latest/download/components.yaml

2.部署HAP,yaml实例参考:

复制代码
apiVersion: autoscaling/v2
kind: HorizontalPodAutoscaler
metadata:
  name: "给hap取名字"
  namespace: "要部署到的命名空间"
spec:
  scaleTargetRef:
    apiVersion: apps/v1
    kind: Deployment
    name: "要控制的Deployment的名字"
  minReplicas: 2        #最小数
  maxReplicas: 8        #最大数
  metrics:
  - type: Resource
    resource:
      name: cpu
      target:
        type: Utilization
        averageUtilization: 70        #CPU 70%
  - type: Resource
    resource:
      name: memory
      target:
        type: Utilization
        averageUtilization: 80      #内存 80%

部署完成之后,使用命令:kubectl get hap -n 命名空间,就可以查看了。

报错:HPA指标<unknown>

这种情况是网上或者AI都会说得很复杂,七七八八的一大堆,其实原因很简单,就是你关联的deployment没有设置resource指标,只要在deployment.yaml中加上如下:

只需要requests字段就可以成功,不需要limit字段,重新部署之后可以看到<unknown>消失了。

不用尝试其他办法了,就是这个原因。

相关推荐
jqpwxt7 小时前
启点创新科技景区私有化票务管理系统:智慧景区数字化建设核心服务商,以本地部署筑牢景区数字化安全与稳定底座
大数据·人工智能·科技·云计算·旅游
ZhangJun957 小时前
三次握手、四次挥手的具体细节和流程详解,附加思考题
tcp/ip·计算机网络·云计算
腾讯云大数据10 小时前
腾讯云数据智能体TCDataAgent升级:大数据平台不只“给人用”,也要“给Agent用”
大数据·云计算·腾讯云
河北小博博1 天前
阿里云 ChatOps Agent 让非标准化环境可修复:内核漏洞换盘后的容器恢复
阿里云·云计算
会议咨询1 天前
2026年数据科学、云计算与智能技术国际会议(DCIT 2026)
云计算·数据科学·智能技术
ha_lydms2 天前
MaxCompute中窗口函数
大数据·hadoop·阿里云·云计算·dataworks·maxcompute·odps
GPU实战笔记2 天前
云端 GPU 暂停任务:如何把短期关机与七天资源释放边界分开判断?
云计算·云服务器·数据盘·gpu云计算·实例生命周期
QYR-分析2 天前
刚需赛道:全球一次性有创压力传感器市场深度解析
云计算
AKAMAI3 天前
随着瓦尔·基尔默的AI分身诞生,生成式AI是否正在将好莱坞推向边缘?
人工智能·云原生·云计算
小葱运维8 天前
命名与环境规范
运维·开源·云计算