mysql无法启动

总是报错:

1、Job for mysql.service failed because the control process exited with error code.

See "systemctl status mysql.service" and "journalctl -xeu mysql.service" for details.

2、ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

3、error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'

Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!

解决方法:(下面几个操作我也不知道是哪个起作用的,都做一遍吧)

1、重启mysql

复制代码
sudo systemctl stop mysql
sudo systemctl start mysql

2、使用安全模式进入mysql(就是免密登陆)

复制代码
sudo mysqld_safe --skip-grant-tables

3、修改localhost和端口号

来源:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

修改这个文件中的ip和端口号,如何没有这个文件夹,新建一个,然后重启mysql

复制代码
sudo vim /etc/mysql/mysql.conf.d/mysqld.cnf

ps:网上还有一个方法是在这个文件最后加上下面这个,但是我跑不起来,会报错

--skip-grant-tables

4、 查看当前用户组的帐号密码(这个肯定有用)

复制代码
sudo cat /etc/mysql/debian.cnf

然后用这个账户和密码登陆

复制代码
sudo mysql -u debian-sys-maint -p

如图:

5、重装mysql!!!!

如果前面的操作都没有用的话,建议直接重装

先看一下相关的包都有哪些

复制代码
sudo dpkg -l | grep mysql

然后使用apt purge命令卸载mysql(purge会删除配置文件,remove不会)

bash 复制代码
sudo apt purge mysql-server mysql-client mysql-server-8.0 mysql-client-8.0 mysql-common

安装:

bash 复制代码
sudo apt install mysql-server mysql-client
相关推荐
weixin_511255214 小时前
MySQL升级记录
数据库·mysql
程序猿乐锅5 小时前
【黑马点评 | 第八篇】Redisson分布式锁
java·数据库·spring boot·redis·分布式·spring·缓存
Leo.yuan5 小时前
2026年本地化Data Agent优质厂商盘点:哪些产品更适合企业生产环境
大数据·数据库·人工智能
做运维的阿瑞5 小时前
数据库增删改的安全写法
数据库·sql·mysql
程序边界6 小时前
迁移评估不再拍脑袋,这个数据迁移工具的量化报告把我救了(上)
数据库
阿狗童鞋6 小时前
Redis实战指南
数据库·redis·缓存
frjc7 小时前
数据库选型:如何从众多数据库中选出最理想的那一个
redis·mysql·clickhouse·elasticsearch
lupai7 小时前
维修保养记录精准版 API 对接实战指南
数据库·python
小马哥程序开发7 小时前
[点赞收藏免费领取 · 项目源码]37399民族服饰饰品商城小程序
sql·mysql·flask·源码·课程设计·程序开发·课设
2601_9521963610 小时前
计算机科学与技术专业应届生投商业分析岗,需要哪些额外能力?
数据库·oracle