更新服务器nginx 1.26.1版本

今天在官网下载了nginx1的1.26.1版本,使用gpt的脚本想直接覆盖安装,脚本如下

bash 复制代码
#!/bin/bash

# 设置变量
NGINX_VERSION="1.26.1"
TAR_FILE="nginx-$NGINX_VERSION.tar.gz"
SRC_DIR="nginx-$NGINX_VERSION"

# 检查是否存在tar包
if [ ! -f "$TAR_FILE" ]; then
  echo "错误: 找不到 $TAR_FILE"
  exit 1
fi

# 停止Nginx服务
echo "停止Nginx服务..."
sudo systemctl stop nginx

# 解压tar包
echo "解压 $TAR_FILE..."
tar -zxvf "$TAR_FILE"

# 进入源代码目录
cd "$SRC_DIR"

# 编译并安装Nginx
echo "编译并安装Nginx..."
./configure --sbin-path=/usr/sbin/nginx #指定安装的位置
make
sudo make install

# 启动Nginx服务
echo "启动Nginx服务..."
sudo systemctl start nginx

# 检查Nginx版本
echo "Nginx更新完成,当前版本:"
nginx -v

# 清理
cd ..
rm -rf "$SRC_DIR"

echo "更新过程完成。"

发现脚本执行完还是之前的nginx版本,无奈只能一步一步执行

先备份原来的ningx

复制代码
mv /usr/sbin/nginx /usr/sbin/nginx.old

首先发现之前的nginx旧的进程没有杀死

随后使用

bash 复制代码
ps aux | grep nginx
kill -9 进程号

杀死旧的nginx进程,想使用

bash 复制代码
systemctl restart nginx.service

拉起服务,结果拉不起来

报错:Can't open PID file /var/run/nginx.pid (yet?) after start: No such...ctory

我一开始以为存在这个文件就好,从别的服务器上拉了nginx.pid到run目录,结果被进程删掉了,还是报一样的错误

后来查询发现

2021-03-17_nginx脚本启动 cannot open pid file-CSDN博客

原因是Nginx 启动时 PID 文件并未生成,导致文件无法读取

所以在nginx.service 文件中添加

bash 复制代码
ExecStartPost=/bin/sleep 0.1

让进程等0.1s,生成文件

但是还是报错

最后是修改了nginx.service和nginx.conf中的nginx.pid的路径

bash 复制代码
vi /你的nginx路径/conf/nginx.conf

发现是nginx.conf中的pid路径是默认不指定的,pid那句话是注释掉的,最后删除注释符,并且指定pid路径。修改完成后重新load一下配置文件。

bash 复制代码
nginx -t
nginx -s reload

执行reload的时候报错

报错:nginx:errorinvalid PID number "" in "/run/nginx.pid"

运维系列:Nginx报错:nginx: error invalid PID number in "/run/nginx.pid"的解决方案_nginx relaod invalid pid num in-CSDN博客

根据我自己的情况对上面文章的内容进行了修改

bash 复制代码
/usr/sbin/nginx -c /nginx的安装路径/nginx.conf

没有报错。进一步执行

bash 复制代码
/usr/sbin/nginx -s reload

nginx的配置文件reload成功后,对systemctl进行reload

bash 复制代码
systemctl daemon-reload

然后restart服务就OK啦

报错:nginx: emerg module "/usr/lib64/nginx/modules/ngx_http_image_filter_module.so" version 1021005 instead of 1027000 in /usr/share/nginx/modules/mod-http-image-filter.conf:1 nginx: configuration file /etc/nginx/nginx.conf test failed

根据文章https://www.cnblogs.com/allay/p/17486284.html

原因:/usr/lib64/nginx/modules/ 内的组件包不兼容

推测是之前的组件包是旧的,有两个解决办法

(1)使用rpm包安装nginx的话是包里自带的,备份好旧的包之后就可以删除

(2)从新的安装位置复制过来(文章中的做法)

我使用方法1,解决了该报错

相关推荐
阳光九叶草LXGZXJ3 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
奔跑的大白啊3 小时前
多容器共享目录权限踩坑记
linux·ubuntu·共享目录·linux权限·docker 容器化部署
Android系统攻城狮6 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
H.莓飛7 小时前
【C++】命名空间、缺省参数、函数重载与引用
linux·开发语言·c++·visual studio
91刘仁德7 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
硅基手札8 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
沫璃染墨10 小时前
《Linux工程实践篇(一):认识设计模式——从日志系统看策略模式》
linux·c++·安全·设计模式·策略模式
工作10年+,存储芯片行业10 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
wuminyu10 小时前
ForkJoinPool内部WorkQueue的Lock-Free数组操作以及并发任务窃取原理剖析
java·linux·c语言·jvm·c++
她说彩礼65万10 小时前
C语言 堆区和栈区
java·linux·c语言