滑动窗口(C++)

样例输入

复制代码
8 3
1 3 -1 -3 5 3 6 7

样例输出

复制代码
-1 -3 -3 -3 3 3
3 3 5 5 6 7

数据范围

对于 20% 的数据,K≤N≤1000;

对于 50% 的数据,K≤N≤10^5;

对于 100% 的数据,K≤N≤10^6。

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;

int a[1000006];

void yjc(int n, int w) {
	deque<int> q;
	for (int i = 0; i < n; ++i) {
		while (!q.empty() && a[q.back()] <= a[i]) {
			q.pop_back();
		}
		q.push_back(i);
		if (i >= w - 1) {
			cout << a[q.front()] << ' ';
			if (q.front() == i - w + 1) {
				q.pop_front();
			}
		}
	}
	cout << endl;
}

void xzh(int n, int w) {
	deque<int> q;
	for (int i = 0; i < n; ++i) {
		while (!q.empty() && a[q.back()] >= a[i]) {
			q.pop_back();
		}
		q.push_back(i);
		if (i >= w - 1) {
			cout << a[q.front()] << ' ';
			if (q.front() == i - w + 1) {
				q.pop_front();
			}
		}
	}
	cout << endl;
}

int main() {
	int n, w;
	cin >> n >> w;
	for (int i = 0; i < n; ++i) {
		cin >> a[i];
	}

	xzh(n, w);
	yjc(n, w);

	return 0;
}
相关推荐
C嘎嘎嵌入式开发6 分钟前
什么是僵尸进程
服务器·数据库·c++
王老师青少年编程5 小时前
gesp(C++五级)(14)洛谷:B4071:[GESP202412 五级] 武器强化
开发语言·c++·算法·gesp·csp·信奥赛
DogDaoDao5 小时前
leetcode 面试经典 150 题:有效的括号
c++·算法·leetcode·面试··stack·有效的括号
一只小bit6 小时前
C++之初识模版
开发语言·c++
CodeClimb7 小时前
【华为OD-E卷 - 第k个排列 100分(python、java、c++、js、c)】
java·javascript·c++·python·华为od
apz_end8 小时前
埃氏算法C++实现: 快速输出质数( 素数 )
开发语言·c++·算法·埃氏算法
仟濹8 小时前
【贪心算法】洛谷P1106 - 删数问题
c语言·c++·算法·贪心算法
北顾南栀倾寒9 小时前
[Qt]系统相关-网络编程-TCP、UDP、HTTP协议
开发语言·网络·c++·qt·tcp/ip·http·udp
old_power10 小时前
【PCL】Segmentation 模块—— 基于图割算法的点云分割(Min-Cut Based Segmentation)
c++·算法·计算机视觉·3d
涛ing11 小时前
21. C语言 `typedef`:类型重命名
linux·c语言·开发语言·c++·vscode·算法·visual studio