Linux8-messages有dnf报错处理

隔几个小时,就有如下的告警

Aug 5 05:44:14 db dnf356416: Unable to read consumer identity

Aug 5 05:44:14 db dnf356416: This system is not registered with an entitlement server. You can use subscription-manager to register.

Aug 5 05:44:14 db dnf356416: CentOS Linux 8 0.0 B/s | 0 B 00:00

Aug 5 05:44:14 db dnf356416: Errors during downloading metadata for repository 'InstallMedia':

Aug 5 05:44:14 db dnf356416: - Curl error (37): Couldn't read a file:// file for file:///mnt/BaseOS/repodata/repomd.xml Couldn't open file /mnt/BaseOS/repodata/repomd.xml

Aug 5 05:44:14 db dnf356416: Error: Failed to download metadata for repo 'InstallMedia': Cannot download repomd.xml: Curl error (37): Couldn't read a file:// file for file:///mnt/BaseOS/repodata/repomd.xml Couldn't open file /mnt/BaseOS/repodata/repomd.xml

Aug 5 05:44:14 db systemd1: dnf-makecache.service: Main process exited, code=exited, status=1/FAILURE

Aug 5 05:44:14 db systemd1: dnf-makecache.service: Failed with result 'exit-code'.

Aug 5 05:44:14 db systemd1: Failed to start dnf makecache.

Aug 5 09:02:05 db dnf473997: Unable to read consumer identity

Aug 5 09:02:05 db dnf473997: This system is not registered with an entitlement server. You can use subscription-manager to register.

Aug 5 09:02:05 db dnf473997: CentOS Linux 8 0.0 B/s | 0 B 00:00

Aug 5 09:02:05 db dnf473997: Errors during downloading metadata for repository 'InstallMedia':

Aug 5 09:02:05 db dnf473997: - Curl error (37): Couldn't read a file:// file for file:///mnt/BaseOS/repodata/repomd.xml Couldn't open file /mnt/BaseOS/repodata/repomd.xml

Aug 5 09:02:05 db dnf473997: Error: Failed to download metadata for repo 'InstallMedia': Cannot download repomd.xml: Curl error (37): Couldn't read a file:// file for file:///mnt/BaseOS/repodata/repomd.xml Couldn't open file /mnt/BaseOS/repodata/repomd.xml

Aug 5 09:02:05 db systemd1: dnf-makecache.service: Main process exited, code=exited, status=1/FAILURE

Aug 5 09:02:05 db systemd1: dnf-makecache.service: Failed with result 'exit-code'.

查看dnf-makecache.service服务是非活动,执行stop发现问题点

root@db \~# systemctl status dnf-makecache.service

● dnf-makecache.service - dnf makecache

Loaded: loaded (/usr/lib/systemd/system/dnf-makecache.service; static; vendor preset: disabled)

Active: inactive (dead) since Mon 2024-08-05 10:07:46 CST; 52min ago

Process: 513042 ExecStart=/usr/bin/dnf makecache --timer (code=exited, status=0/SUCCESS)

Main PID: 513042 (code=exited, status=0/SUCCESS)

Aug 05 10:07:46 db systemd1: Starting dnf makecache...

Aug 05 10:07:46 db dnf513042: Updating Subscription Management repositories.

Aug 05 10:07:46 db dnf513042: Unable to read consumer identity

Aug 05 10:07:46 db dnf513042: This system is not registered with an entitlement server. You can use subscription-manager to register.

Aug 05 10:07:46 db dnf513042: Metadata cache refreshed recently.

Aug 05 10:07:46 db systemd1: dnf-makecache.service: Succeeded.

Aug 05 10:07:46 db systemd1: Started dnf makecache.

root@db opt# systemctl stop dnf-makecache.service
Warning: Stopping dnf-makecache.service, but it can still be activated by:
dnf-makecache.timer

直接关闭dnf-makecache.timer,观察了几个小时,发现再也不报错了

root@db opt# systemctl status dnf-makecache.timer

● dnf-makecache.timer - dnf makecache --timer

Loaded: loaded (/usr/lib/systemd/system/dnf-makecache.timer; enabled; vendor preset: enabled)

Active: active (waiting) since Thu 2024-03-21 11:23:47 CST; 4 months 15 days ago

Trigger: Mon 2024-08-05 11:48:32 CST; 46min left

Mar 21 11:23:47 db systemd1: Started dnf makecache --timer.

root@db \~# systemctl stop dnf-makecache.timer

root@db \~# systemctl disable dnf-makecache.timer

相关推荐
weixin_403810131 小时前
EasyClick iOS 免越狱自动化脚本怎么写:从环境判断到跑通第一个脚本
运维·ios·自动化
程序猿老A1 小时前
GPU云服务器怎么安装AI
运维·服务器·人工智能
小白的码BUG之路1 小时前
Docker -- No space left on device
运维·docker·容器
‎ദ്ദിᵔ.˛.ᵔ₎1 小时前
linux 进程间通信
linux·网络
Ruiery1 小时前
Linux 6.6内核 CPU 深度解析(八):percpu 变量 — 每个 CPU 一份数据,无锁访问
linux·运维·服务器
91刘仁德1 小时前
传输层协议深度拆解:端口寻址、UDP 报文与 TCP 可靠性机制全解析
linux·网络·c++·网络协议·tcp/ip·udp·c
AIgorithmGEEK2 小时前
[Linux]HTTP 应用层协议全解(中篇)
linux·网络·网络协议·http
玖石书2 小时前
linux 安装uv(python虚拟环境管理)
linux·python·uv
皓月盈江2 小时前
Hexo博客Butterfly5.7.0主题网站信息:本站访客数和本站总浏览量的数据一直加载不显示的解决方法
linux·hexo·butterfly·busuanzi·vercount·本站访客数·本站总浏览量
程序猿老A2 小时前
云服务器怎么配置视频存储?
运维·服务器·音视频