545C - Woodcutters(1500)

Woodcutters

题面翻译

给 n n n 棵树在一维数轴上的坐标 x i x_i xi,以及它们的长度 h i h_i hi。现在要你砍倒这些树,树可以向左倒也可以向右倒,砍倒的树不能重合、当然也不能覆盖其他的树原来的位置,现在求最大可以砍倒的树的数目。

$ 1 \le n \le {10}^5$

$ 1 \le x_i, h_i \le {10}^9$

题目描述

Little Susie listens to fairy tales before bed every day. Today's fairy tale was about wood cutters and the little girl immediately started imagining the choppers cutting wood. She imagined the situation that is described below.

There are $ n $ trees located along the road at points with coordinates $ x_{1},x_{2},...,x_{n} $ . Each tree has its height $ h_{i} $ . Woodcutters can cut down a tree and fell it to the left or to the right. After that it occupies one of the segments $ [x_{i}-h_{i},x_{i}] $ or $ [x_{i};x_{i}+h_{i}] $ . The tree that is not cut down occupies a single point with coordinate $ x_{i} $ . Woodcutters can fell a tree if the segment to be occupied by the fallen tree doesn't contain any occupied point. The woodcutters want to process as many trees as possible, so Susie wonders, what is the maximum number of trees to fell.

输入格式

The first line contains integer $ n $ ( $ 1<=n<=10^{5} $ ) --- the number of trees.

Next $ n $ lines contain pairs of integers $ x_{i},h_{i} $ ( $ 1<=x_{i},h_{i}<=10^{9} $ ) --- the coordinate and the height of the $ і $ -th tree.

The pairs are given in the order of ascending $ x_{i} $ . No two trees are located at the point with the same coordinate.

输出格式

Print a single number --- the maximum number of trees that you can cut down by the given rules.

样例 #1

样例输入 #1

5
1 2
2 1
5 10
10 9
19 1

样例输出 #1

3

样例 #2

样例输入 #2

5
1 2
2 1
5 10
10 9
20 1

样例输出 #2

4

提示

In the first sample you can fell the trees like that:

  • fell the $ 1 $ -st tree to the left --- now it occupies segment $ [-1;1] $
  • fell the $ 2 $ -nd tree to the right --- now it occupies segment $ [2;3] $
  • leave the $ 3 $ -rd tree --- it occupies point $ 5 $
  • leave the $ 4 $ -th tree --- it occupies point $ 10 $
  • fell the $ 5 $ -th tree to the right --- now it occupies segment $ [19;20] $

In the second sample you can also fell $ 4 $ -th tree to the right, after that it will occupy segment $ [10;19] $ .

思路:我们可以从前向后遍历,首尾可以直接加2, 因为首向左尾向右,我们只需要从2遍历到n - 1即可

AC代码:

cpp 复制代码
#include<bits/stdc++.h>

using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
typedef pair<int, double>PDD;
const int N=2e5 +10;
const int MOD = 1e9 + 7;
const int INF=0X3F3F3F3F;
const int dx[]={-1,0,1,0,-1,-1,+1,+1};
const int dy[]={0,1,0,-1,-1,+1,-1,+1}; 

//马
const int dxx[]={-1,2,1,1,-1,2,-2,-2};
const int dyy[]={2,1,-2,2,-2,-1,-1,1};    
const int M = 1e7 + 10;

int a[N];
int x[N], h[N];
int o[N];//用来记录左边那棵树向右倒的长度
int main()
{
	int n;
	cin >> n;
	for(int i = 1; i <= n; i ++)
	{
		cin >> x[i] >> h[i];
	}
	//首尾的数不用管
	int res = 0;
	//利用贪心算法
	for(int i = 2; i <= n - 1; i ++)
	{
		if(x[i] - h[i] > x[i - 1] + o[i - 1]) res ++;//向左倒
		else if(x[i] + h[i] < x[i + 1])//向右倒时需要记下来长度因为期对后续有影响
		{
			o[i] += h[i];
			res ++;
		}
	}
	if(n == 1) cout << 1 << endl;
	else 
	cout << res + 2 << endl;
	return 0;
}
相关推荐
2850g7 分钟前
LeetCode 94. 二叉树的中序遍历
数据结构·算法·leetcode
LuckyRich112 分钟前
【动态规划】回文串问题
算法·动态规划
筱姌15 分钟前
数据结构实验1
数据结构·c++·算法
张琪杭17 分钟前
深度学习-目标检测(一)-R-CNN
人工智能·深度学习·算法·目标检测·cnn
再不会python就不礼貌了21 分钟前
一步步教你利用大模型开发个性化AI应用,告别‘人工智障’!
人工智能·学习·算法·oracle·llama
ZZZ_O^O30 分钟前
面向对象程序设计之模板进阶(C++)
开发语言·c++·算法·模版
繁依Fanyi43 分钟前
SpringBoot + Vue + ElementUI 实现 el-table 分页功能详解
java·开发语言·人工智能·python·算法
四角小裤儿儿1 小时前
Java数据结构(八)——插入排序、希尔排序
java·开发语言·数据结构·算法·排序算法
万河归海4281 小时前
C语言——在有序数组中插入一个新的元素,且数组的排列不变
c语言·数据结构·算法·visualstudio
终末圆1 小时前
JDBC与MyBatis:数据库访问技术的变迁【后端 15】
前端·数据结构·数据库·后端·算法·mybatis·jdbc