545C - Woodcutters(1500)

Woodcutters

题面翻译

给 n n n 棵树在一维数轴上的坐标 x i x_i xi,以及它们的长度 h i h_i hi。现在要你砍倒这些树,树可以向左倒也可以向右倒,砍倒的树不能重合、当然也不能覆盖其他的树原来的位置,现在求最大可以砍倒的树的数目。

1 \\le n \\le {10}\^5

1 \\le x_i, h_i \\le {10}\^9

题目描述

Little Susie listens to fairy tales before bed every day. Today's fairy tale was about wood cutters and the little girl immediately started imagining the choppers cutting wood. She imagined the situation that is described below.

There are n trees located along the road at points with coordinates x_{1},x_{2},...,x_{n} . Each tree has its height h_{i} . Woodcutters can cut down a tree and fell it to the left or to the right. After that it occupies one of the segments \[x_{i}-h_{i},x_{i}\] or \[x_{i};x_{i}+h_{i}\] . The tree that is not cut down occupies a single point with coordinate x_{i} . Woodcutters can fell a tree if the segment to be occupied by the fallen tree doesn't contain any occupied point. The woodcutters want to process as many trees as possible, so Susie wonders, what is the maximum number of trees to fell.

输入格式

The first line contains integer n ( 1\<=n\<=10\^{5} ) --- the number of trees.

Next n lines contain pairs of integers x_{i},h_{i} ( 1\<=x_{i},h_{i}\<=10\^{9} ) --- the coordinate and the height of the і -th tree.

The pairs are given in the order of ascending x_{i} . No two trees are located at the point with the same coordinate.

输出格式

Print a single number --- the maximum number of trees that you can cut down by the given rules.

样例 #1

样例输入 #1

复制代码
5
1 2
2 1
5 10
10 9
19 1

样例输出 #1

复制代码
3

样例 #2

样例输入 #2

复制代码
5
1 2
2 1
5 10
10 9
20 1

样例输出 #2

复制代码
4

提示

In the first sample you can fell the trees like that:

  • fell the 1 -st tree to the left --- now it occupies segment \[-1;1\]
  • fell the 2 -nd tree to the right --- now it occupies segment \[2;3\]
  • leave the 3 -rd tree --- it occupies point 5
  • leave the 4 -th tree --- it occupies point 10
  • fell the 5 -th tree to the right --- now it occupies segment \[19;20\]

In the second sample you can also fell 4 -th tree to the right, after that it will occupy segment \[10;19\] .

思路:我们可以从前向后遍历,首尾可以直接加2, 因为首向左尾向右,我们只需要从2遍历到n - 1即可

AC代码:

cpp 复制代码
#include<bits/stdc++.h>

using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
typedef pair<int, double>PDD;
const int N=2e5 +10;
const int MOD = 1e9 + 7;
const int INF=0X3F3F3F3F;
const int dx[]={-1,0,1,0,-1,-1,+1,+1};
const int dy[]={0,1,0,-1,-1,+1,-1,+1}; 

//马
const int dxx[]={-1,2,1,1,-1,2,-2,-2};
const int dyy[]={2,1,-2,2,-2,-1,-1,1};    
const int M = 1e7 + 10;

int a[N];
int x[N], h[N];
int o[N];//用来记录左边那棵树向右倒的长度
int main()
{
	int n;
	cin >> n;
	for(int i = 1; i <= n; i ++)
	{
		cin >> x[i] >> h[i];
	}
	//首尾的数不用管
	int res = 0;
	//利用贪心算法
	for(int i = 2; i <= n - 1; i ++)
	{
		if(x[i] - h[i] > x[i - 1] + o[i - 1]) res ++;//向左倒
		else if(x[i] + h[i] < x[i + 1])//向右倒时需要记下来长度因为期对后续有影响
		{
			o[i] += h[i];
			res ++;
		}
	}
	if(n == 1) cout << 1 << endl;
	else 
	cout << res + 2 << endl;
	return 0;
}
相关推荐
明月看潮生18 分钟前
青少年编程与数学 02-019 Rust 编程基础 09课题、流程控制
开发语言·算法·青少年编程·rust·编程与数学
oioihoii26 分钟前
C++23 views::slide (P2442R1) 深入解析
linux·算法·c++23
yuhao__z1 小时前
代码随想录算法训练营第六十三天| 图论9—卡码网47. 参加科学大会,94. 城市间货物运输 I
算法·图论
June`1 小时前
专题三:穷举vs暴搜vs深搜vs回溯vs剪枝(全排列)决策树与递归实现详解
c++·算法·深度优先·剪枝
vlln1 小时前
适应性神经树:当深度学习遇上决策树的“生长法则”
人工智能·深度学习·算法·决策树·机器学习
冲帕Chompa2 小时前
图论part09dijkstra算法
算法·图论
·云扬·2 小时前
【PmHub后端篇】PmHub中基于Redis加Lua脚本的计数器算法限流实现
redis·算法·lua
周Echo周2 小时前
20、map和set、unordered_map、un_ordered_set的复现
c语言·开发语言·数据结构·c++·算法·leetcode·list
zkmall2 小时前
推荐算法工程化:ZKmall模板商城的B2C 商城的用户分层推荐策略
算法·机器学习·推荐算法
矿渣渣3 小时前
AFFS2 的 `yaffs_ext_tags` 数据结构详解
数据结构·算法·文件系统·yaffs2