麒麟sp3离线安装docker,docker-compose,nginx记录

背景

很多单位,都开始用国产操作系统了,这次踩的坑就是麒麟sp3,简单记录下

查看系统环境

输入指令:

bash 复制代码
arch

得出结果:

一般会输出x86_64、armel 、aarch64等。在选择对应软件版本时也要选择对应的架构。

提醒:下文中所有的版本都会是x86_64

docker相关

下载docker地址

download.docker.com/linux/stati...

指定docker版本

安装docker

下载后的docker文件上传至服务器根目录的home文件夹下

1.进入文件夹
bash 复制代码
cd /home
2.解压缩
复制代码
tar -xzf docker-20.10.10.tgz
3.移动解压后的全部内容到/usr/bin/下
bash 复制代码
mv docker/* /usr/bin/

编译docker配置文件

1.编辑docker.service
bash 复制代码
vi /usr/lib/systemd/system/docker.service
2.复制以下代码到docker.service
ini 复制代码
[Unit]
 
Description=Docker Application Container Engine
 
Documentation=https://docs.docker.com
 
After=network-online.target firewalld.service
 
Wants=network-online.target
 
[Service]
 
Type=notify
 
ExecStart=/usr/bin/dockerd
 
ExecReload=/bin/kill -s HUP $MAINPID
 
LimitNOFILE=infinity
 
LimitNPROC=infinity
 
TimeoutStartSec=0
 
Delegate=yes
 
KillMode=process
 
Restart=on-failure
 
StartLimitBurst=3
 
StartLimitInterval=60s
 
 
[Install]
 
WantedBy=multi-user.target
3.添加docker.service文件的权限
bash 复制代码
chmod +x /usr/lib/systemd/system/docker.service
 
systemctl daemon-reload
4.创建daemon.json

如果发现已经存在docker文件,直接进入docker文件夹内就行,无需新建

bash 复制代码
cd /etc
mkdir docker
cd docker
touch daemon.json
vi daemon.json
5.复制以下代码到daemon.json
json 复制代码
{
  "registry-mirrors": ["https://registry.docker-cn.com"],
  "exec-opts": ["native.cgroupdriver=systemd"]
}
6.reload内容、启动docker、设置开机启动
bash 复制代码
systemctl daemon-reload
systemctl start docker
systemctl enable docker
验证docker安装

输入指令:docker -v 出现版本提示,说明安装成功

安装docker-compose

下载地址

github.com/docker/comp...

下载指定版本

下载后的docker文件上传至服务器根目录的home文件夹下

1.进入文件夹
bash 复制代码
cd /home
2.安装并分配权限
bash 复制代码
mv docker-compose-Linux-x86_64.docker-compose-linux-x86_64 /usr/bin/docker-compose
chmod +x /usr/bin/docker-compose
3.验证
复制代码
docker-compose -v

docker启动问题

permission denied

sql 复制代码
Error response from daemon: failed to create task for container: 
failed to create shim task: OCI runtime create failed: 
container_linux.go:328: starting container process caused "permission denied": unknown

在systemd中查看docker服务是正常启动的,文件权限也没问题,多方查找问题无果,最后找文档发现,如果系统安装了podman,这是安装银河麒麟时的可选项,也是一款容器管理工具,有着很多和docker相似的功能,同时安装podman和docker,就会引发以上错误信息提示,卸载掉podman后docker容器就可以正常启动了。

大概意思守护进程被进程被占用了,卸载podman就行

卸载指令yum remove podman

参考资料

麒麟V10安装Docker、Docker-compose、Nginx

记录一次银河麒麟中的docker无法启动容器的问题

麒麟V10操作系统Kylin Linux Advanced Server release V10 (Lance)版本 docker run时报错permission denied

银河麒麟操作系统 v10 中离线安装 Docker

相关推荐
well06122 分钟前
Linux 文件相关底层知识
linux·运维·服务器
库拉镜像AI牛牛1 小时前
漫剧工作室量产方案:依托知漫剧 AI 短剧降本增效
大数据·服务器·前端·人工智能·语音识别
MrSYJ1 小时前
别人再问你路由表是啥,这篇文章摔它脸上
docker·云原生·kubernetes
沫璃染墨1 小时前
《从零入门Linux系统篇(五十八):线程篇·十一——线程安全与死锁详解:从可重入到多锁管理》
linux·服务器·开发语言·c++·驱动开发·安全·架构
羑悻2 小时前
穿越Docker内核迷雾:揭秘镜像分层存储的叠加态与卷挂载的多维空间穿梭技术
后端·docker·容器
姜鱼问生2 小时前
宝塔面板优雅下线:先 stop 再 disable 再 rm
运维·服务器
闭包不眠2 小时前
PDF文字提取交付前该检查什么
运维·服务器·图像处理·人工智能·计算机视觉·pdf
guo_wen_qiang3 小时前
云服务器sentinel搭建-控制台
服务器·sentinel
for_ever_love__3 小时前
容器类型全家桶——list、tuple、dict、set 与推导式
python·容器·数据类型·大模型开发
筑梦之路3 小时前
docker-compose方式部署kafka集群(Kraft方式)——筑梦之路
docker·容器·kafka