docke安装elastic search

1 创建docker-compose.yml

yml 复制代码
version: '3.8'

services:
  es:
    image: elasticsearch:7.12.1
    container_name: es
    environment:
      - ES_JAVA_OPTS=-Xms512m -Xmx512m
      - discovery.type=single-node
    volumes:
      - /docker/elasticsearch/es-data:/usr/share/elasticsearch/data
      - /docker/elasticsearch/es-plugins:/usr/share/elasticsearch/plugins
    privileged: true
    networks:
      - es-net
    ports:
      - "9200:9200"
      - "9300:9300"

  kibana:
    image: kibana:7.12.1
    container_name: kibana
    environment:
      - ELASTICSEARCH_HOSTS=http://es:9200
    networks:
      - es-net
    ports:
      - "5601:5601"
    depends_on:
      - es

networks:
  es-net:
    name: es-net
    driver: bridge

进入docker-compose.yml所在文件夹执行命令

shell 复制代码
docker-compose up -d

2 解决报错

第一次启动是会报错的,还需要执行一下步骤

1 修改文件夹权限
shell 复制代码
chmod 777 -R /docker/elasticsearch

/docker/elasticsearch是docker-compose.yml所在文件夹

2 下载分词插件

下载链接: link

将此压缩包解压后,放到/docker/elasticsearch/es-plugins文件夹中

注意文件夹结构,中间有一个ik文件夹层级
#### 3 执行docker容器

删除docker中原来的的es和kibana容器,重新在docker-compose.yml所在文件夹执行

shell 复制代码
docker-compose up -d

3 访问kibana

首页
http://127.0.0.1:5601

控制台
http://127.0.0.1:5601/app/dev_tools

相关推荐
Elastic 中国社区官方博客6 小时前
错误最多的服务运行正常:使用 ES|QL 从日志进行根因分析
大数据·运维·数据库·sql·elasticsearch·搜索引擎·全文检索
迪康coolmu6 小时前
屏幕水印与防拍照落地:从水印类型到泄密溯源的完整配置
运维·网络·安全·网络安全·数据安全
0+1116 小时前
Linux --进程间关系和守护进程
linux·运维·服务器
weixin_403810136 小时前
EasyClick iOS 免越狱自动化脚本怎么写:从环境判断到跑通第一个脚本
运维·ios·自动化
程序猿老A7 小时前
GPU云服务器怎么安装AI
运维·服务器·人工智能
小白的码BUG之路7 小时前
Docker -- No space left on device
运维·docker·容器
Ruiery7 小时前
Linux 6.6内核 CPU 深度解析(八):percpu 变量 — 每个 CPU 一份数据,无锁访问
linux·运维·服务器
事圆则缓7 小时前
Android 使用 Jenkins 实现 CI/CD,并用 SonarQube 建立质量门禁
android·ci/cd·jenkins
程序猿老A8 小时前
云服务器怎么配置视频存储?
运维·服务器·音视频
程序员老陆8 小时前
Docker 命令全景指南:从镜像构建到生产运维
运维·docker·容器